MMS support Telia Sweden?

Interesting, ok.
You could try filing a bug report at the mentioned url asking for telia to be added.

Not sure what else you can do.

After the latest update to chatty, it seems I can put whatever I want in the Chatty MMS settings and still get the paper clip to attach an image. I have been trying different gnome-settings modem APNs, but only get the following errors in journalctl:

dec 14 14:25:08 pureos mmsdtng[1351]: mmsd-tng[1351]: ../plugins/modemmanager.c:set_context() Current Context APN:, mmsd-tng settings MMS APN:
dec 14 14:25:08 pureos mmsdtng[1351]: mmsd-tng[1351]: ../plugins/modemmanager.c:set_context() The modem is not connected to the correct APN!
dec 14 14:25:08 pureos mmsdtng[1351]: mmsd-tng[1351]: ../plugins/modemmanager.c:bearer_handler() Set MMSC: http://mmss/, Set Proxy:, Set MMS APN:

Ok, this is really weird!
Here are my settings, that finally made it work:

chatty settings

However, chatty settings seem to clear the proxy setting every time the modem is restarted (which I do by toggling the kill switch). The proxy setting should be

1 Like

Also, the mms received ended up in a group conversation with me, my phone number and the other person :smiley: not in our regular chat.

Maybe this issue:

Yes, looks like the same issue.

I also got MMS to work with a Telia SIM card now, but as you showed above that seems to require setting the APN to “” for both MMS and for the regular mobile data connection. Then MMS works, but for me mobile data does not work anymore then. I mean, it works in the way that MMS messages are clearly fetched using that connection, but it no longer works for general Internet access.

Perhaps Telia only allow MMS-related network traffic using the “” APN. If that’s the case, then we need to make things work with two different APNs, “” for mobile data and at the same time “” for MMS.

So we need things to work with multiple APNs,ere is an issue about that:

I have tried a “Comviq kontant” SIM card also, and in that case things work better because in that case the MMS APN is the same as the regular mobile data connection APN, both are “”. So in that case MMS can work together with the mobile data connection.

Not completely sure here, but I think I have both mobile data and mms working simultaneously with the settings above. The chatty proxy setting gets cleared upon a modem restart though, and I think I had to toggle mobile data off/on to get it to work with the APN. However, that is not much different from with the other APN selected. Oftentimes, after leaving a wifi network, the phone pretends to be connected but won’t fetch any e-mails etc. until after a mobile data toggle. Librem5’s internet connection is not reliable for me, even when it says it is connected…

What about if you turn off WiFi using the kill switch, then try to use the web browser – does that work when you are using the “” APN?
I think it will not work.
If that does work for you, I have to try again and see what went wrong for me.

Atm no, but I am pretty sure it worked at one point. Anyhow, the indicator reports mobile 4G connectivity either way, which is wrong if mobile data is not working.

Hack it into the file yourself?

Per giving the directory, and the file to be edited is seemingly serviceproviders.xml - until a fix comes through from upstream?

1 Like

It turns out this info is in fact in /usr/share/mobile-broadband-provider-info/apns-conf.xml

<apn carrier="Telia MMS" mcc="240" mnc="01" apn="" mmsc="http://mmss/" mmsproxy="" mmsport="80">
<apn carrier="Telia 3G" mcc="240" mnc="01" apn="" type="default,supl"/>

So, question is, why isn’t Telia MMS settings used by Chatty automatically?

… and why is the info potentially in both files?

Not sure what you mean here?

You are talking about a different .xml file. Maybe Chatty uses the file that I referenced, not the one that you referenced.

You should confirm though your exact mcc and mnc - which you can get using tips on the above-linked page.

1 Like

The odd thing is that in the file serviceproviders.xml I find Telia MMS credentials under Multicom:

            <name>Multicom Security</name>
                    <network-id mcc="240" mnc="01"/>
                    <network-id mcc="240" mnc="05"/>

                    <!-- -->
                    <apn value="">
                            <plan type="postpaid"/>
                            <usage type="internet"/>
                    <apn value="">
                            <usage type="mms"/>
                            <name>Telia MMS</name>

whereas under Telia it reads:

                    <network-id mcc="240" mnc="01"/>
                    <network-id mcc="240" mnc="05"/>


                    <!-- -->
                    <apn value="">
                            <plan type="postpaid"/>
                            <usage type="internet"/>
                            <name>Telia 3G</name>

there is no MMS info and a reference to some old url (“”) that doesn’t seem to exist anymore.

So, if I hack in the MMS info under the <name>Telia</name> tag, would it likely work then?

1 Like

No idea! But just save a copy of the file before you start hacking away at it. I don’t think much can go wrong as long as you aren’t relying on remote access via the cellular modem in order to get into the phone. :wink:

You should confirm your mcc and mnc - and I don’t know how the duplicates are handled.

It didn’t make a notable difference. No MMS being sent, unless I activate the MMS APN in gnome-settings, which then breaks mobile data as Telia has different APNs for mobile surf and MMS as @Skalman pointed out above.

And this one is still missing from serviceproviders.xml:

SFR France added already?

I guess that file isn’t used by pureos. The correct credentials seem to be in /usr/share/mobile-broadband-provider-info/apns-conf.xml
However, as long as Telia Sweden keeps different APNs for mobile data and MMS I have to do the workaround discussed here. At least until pureos will be able to handle to different APNs at the same time.