Mount Librem 5 on Linux Desktop

When I plug in a USB cable from my running and unlocked Byzantium Librem 5 to my Ubuntu Bionic desktop computer, my desktop computer seems not to recognize the Librem is attached, nothing is mounted on the desktop computer. This is unlike an android device, which the Ubuntu desktop immediately recognizes as being plugged in.

What might be wrong, or what might I be missing? Thanks.

1 Like

Check this thread and the link to the video: New Post: Librem 5 File Transfer

And this: Librem 5 USB Mount to Linux

Yes. This is more like connecting two laptops with a USB cable.

Here are some tutorials for easy file transfer options over your wireless network (I recommend sftp as a super-convenient method):

Ok, I see. I just assumed that there might be some built in slick connection ability as I experience with android. I’ll check out the links you shared. Thanks.

1 Like

Some of these Tips & Tricks were for the earlier phones, which shipped with the amber repository installed. Newer phones are shipping with byzantium, so the older tips may have “evolved” by now.

This might be useful, too:

Still reading through all the stuff you linked. I came across this:

So, since all I’m doing is a USB tether between the Librem 5 and the desktop computer, shouldn’t I see something happening on the desktop computer? But when I run the lsusb command in the terminal of the desktop computer while the librem is tethered, it does not see the librem. (I’m just trying to see how to get this tethering to work.)

1 Like

Did you already try flipping the USB-C end, according to the guide?

I did several times, but nothing

I haven’t tried that particular functionality, so I’ll have to defer to other members. You might try contacting support, too.

While I have the librem connected, my Ubuntu machine keeps giving me this message: “Connection failed Activation of network connection failed” like every minute the librem is connected. But that’s all it says.

I think it’s telling you that you haven’t created a USB network connection in your network manager.