My first week of using the L5, Pics and questions

PureOS store - Can I add other Distros software repos? Will they work?

Dell Docking Station WD19 19.5 volts powered by a 130 Watts power source. Connects to L5 via USB-C and allows for 2 qty external monitors via HDMI connection, Mouse, Keyboard, Ethernet cord & sound wire to external speakers…however, the phone charges and gets fairly hot after about 10 minutes. Charging light on L5 goes from Steady Red to Blinking red. At that time I have unplugged the L5 from the Dell dock (to ensure it does not over heat the L5).

FlatPaks- Some install fine like Blanket, CherryTree, KeepassXC, Yubico Authenticator and Yubikey Personalization app, but other flatpak apps wont install like spotify and onlyoffice…Upon trying to install those i get “failed to install file: not supported”. Are flatpaks written for certain CPU architectures?

Camera app does not see thru both F/R lenses, but the app itself opens up just fine.

Megapixels does see thru the F/R lenses but is very dark for some reason. Ive never used that app before on my PC. Is it supposed to be dark?

Application settings dont stick upon reboot. IE: display settings keep resorting to 200%, which is too big to allow most apps to function. When you display the apps down to 100-150% you can see the apps just fine, but upon rebooting the L5, it then resorts back to 200%

No bluetooth found…I though the L5 came with a built in Bluetooth chip?


For the camera I believe there’s a setting (exposure?) to adjust to make it brighter.

No settings that i could find within the app self. Upon trying to take a pic i get a error "Could not save image! Unknown error: The viewfinder is not in the READY state.

You need to adjust gain, exposure, white balance and focus manually with controls above the image, nothing’s automatic there yet.


Blinking red means that it stopped charging automatically (but it won’t discharge if there’s enough power provided via USB). If you want to use the phone intensively in docked mode, it’s best to charge it to full first, so you get rid of heat that comes from the battery being charged.

BTW - when I compile things on a docked phone, I simply put a small fan nearby - this single thing manages to reduce the phone’s temperature a lot and prevents it from thermal throttling.


Many of these issues are discussed, sometimes extensively, in other topics.

I would recommend against that. It isn’t even a good idea on a desktop / laptop.

It might work if you are knowledgeable enough to fix things up when they go pear-shaped.

I recommend you monitor the charging current.


Good to know these work on the phone. Have you tried the Yubico apps with an actual YubiKey on the USB-C port?

How did you end up with the Camera app? It’s completely unsupported.

Megapixels is installed by default on my Librem5, I received it about a week ago.


The question was about gnome-camera (pinhole) app. Megapixels is expected to be there and work indeed :slight_smile:

1 Like

The yubikey USB-C does not function or recognize that the key is in it when I try it in KeepassXC. However, I brought up the terminal and pressed the side of my Yubikey and it presented the touch code onto the terminal window (thus working). My guess is there is a missing dependency piece that still needs to be installed in order to use the Yubikey with KeepassXC.

1 Like

MegaPixel does work, but it does not seem to keep the lighting settings up a reboot. There seems to be a lot of setting resets on the L5 upon reboot. Not sure why

I never actually thought about preserving settings between boots, as camera conditions are very volatile, but… my camera does it, so I guess that’s useful. But automatic mode is way more important.


Thanks for the feedback. And have you tried it in Yubico Authenticator?

I believe to use it in KeePassXC it may have to be configured properly, which yours might not be, i.e. to provide a Challenge-Response slot that KeePassXC can recognize.

The touch button is just emulating a USB keyboard, so no surprise that this is working.

Even though the yubikey authentication is installed…i cant get it to open. However, the Yubikey personallization does seems to function (or at least read my key).

1 Like

It’s supposed to - it’s tied to a kill switch though, was that toggled off?

no the switch is on…ive played with the toggles trying to figure it out…

That stinks… I wish I had mine to see stuff like this and troubleshoot, but I won’t get mine for months. :frowning:

I had problems with bluetooth and did this:
After contacting the support team, they may ask you to do steps similar to the following:

  1. Get a more modern firmware from a repo. We have listed here on this forum to use , but the support team pointed me to a fork using the command wget . It might be beneficial to try one if the other doesn’t work.
  2. Create a firmware folder on your phone if it doesn’t exist already: sudo mkdir /lib/firmware .
  3. Move the newly downloaded firmware, using sudo mv -t /lib/firmware RS9116_NLINK_WLAN_BT_IMAGE.rps
  4. Reboot the phone.
  5. Attempt to turn on Bluetooth in the settings.
  6. If trouble occurs, open a terminal, and save the dmesg for he support team: for example, I did sudo dmesg > dmesg_new_firmware.txt .

I found this in this post Bluetooth support for Librem 5 now I can connect my earphones but no the bluetooth mouse that isn’t showing up.


I have not had a chance to try the fix yet, but upon researching i found the following command that should allow keepass to read the yubukey.

sudo udevadm trigger