[MyL5] arrived and looks good. First impressions

Yes! Arrived today.
The overall experience was pretty good!


  • I got a SanDisk Extreme SD card + adapter, just in case you wonder if it’s any good
  • The SmartCard looks nice, with Purism logo on it. Also, its small bag was fixed with tape so it doesn’t get lost in the box.
  • The charger can travel the world: US by default, adapter for EU and GB (I think)

Boot & Play

Turned it on, entered disk PIN, entered lock PIN, went through the assistant, and… ended up with a device that was connected to my WiFi and the Nextcloud instance on my Librem Mini.

Take a moment to appreciate how rad that is. A device that asks for your nextcloud credentials during setup. You open the Files app, and there it is: a nextcloud mount just waiting for you to exchange files.

Update: So, you open up contacts for the first time, and… gasp it… asks you whether your nextcloud should be your default address book!? :scream: :joy:

I was mildly amused that you are only allowed to connect to WiFis with 8-or-more character passwords. (Gnome default?) :smirk:

Other than that, I installed all app & system updates, rebooted without any issues. :+1:
Installed Librem Social as a Web app. :+1:
Listened to a pod cast in the browser, sound was good :+1:
Usage says, initially, 3GB are used, ~27GB are free. :+1: (this is so not-Androidish)

I managed to not properly insert the cable into the wall-wart, leading to a non-charging phone. Well, PEBCAK. Or rather PICNIC. :man_shrugging:
I noticed, it charges at about 1% per minute, until about 70%, where it slows down a lot while approaching 100% (which already indicates that fully charging is not the best thing for batteries).
During my mild usage, all temperature sensors were pretty much 35°C, except the battery which was a bit above 40°C during charging.
It was a nice handwarmer, but really not bad.

I didn’t do much with it yet, just a bit of looking around.
I did not yet insert any cards.

It is, by the way, refreshing to enter passwords and not worry much about how safe they are on the device.

Minor glitches

So far, I didn’t hit any major road-blocks, just a few minor glitches.

Setup assistant

  • Initially, the date was way off, (July), but that did not create a problem with the WiFi, and fixed itself after that was connected
  • The timezone was wrong. I would expect the assistant to ask for that!?
  • During keyboard selection, if you tap the prominently displayed Preview link, it opens a weirdly-sized new window, which, of course, does not show an on-screen-keyboard, but a desktop keyboard. There’s no back button, so if this is your first encounter with Phosh, you might struggle a bit :slight_smile:


  • Even though I was aware that swipe-up does not yet work (you have to tap), I’m not getting accustomed to it. For some reason I subconsciously thought, swipe down works, but of course not. And every time I fall for it. I should have known, because, luckily, @guido.gunther is working on that just right now, so thanks :slight_smile: As he aptly points out, the video also works if you play it upside down :stuck_out_tongue_winking_eye:

Updates / Store

  • after rebooting, there was a message about the updates. It showed all app-updates twice, but the system-update only once

Well… that’s somewhat amusing. While still useful, the Usage monitor… I don’t know what’s a good term for this… It’s self-sufficient? Schroedingeresque? In the sense that, the resources are burnt because you look at them. It’s like… “Hey, look how I eat up one of your cores to show you that one of your cores is eaten by me, to show you this fact with 30fps.” Windows 95 on a 133MHz box solved that by only doing one fps :wink:

In case you have the kill-switch off, it’ll just be black. And stay that way if you flip the switch. However, that can be fixed by switchting between back/front camera input once (two taps).

That’s it for the moment. (minor updates)


Congratulations, @Caliga! It was a long wait.

I’m curious, which applications are pre-installed on byzantium?

In case you are unfamiliar, for mastodon client there is tootle available from the repos.

there is gpodder, that with some patches should fit nicely: https://source.puri.sm/kyle.rankin/librem5-local-helper-scripts/-/tree/master/gpodder


Calls, Chatty, Web, Contacts (*)
2048, Backups, Calculator, Chess
Clocks, Disks, Document Viewer, Files
Geary, Image Viewer, Maps, Megapixels
PureOS Store, Settings, Terminal, Text Editor
Usage, Weather



I had tried tootle years ago when I created my librem one account, and it crashed during start. So I stuck with the web ui.
Anyway, just tried it again on the L5, and boy this looks good!
Plus, with a pleasant dark mode :+1:

However, setup is mediocre: Not fitting the screen properly (only during setup!), and if you don’t think about hiding the OSK (so you can see the insert marker), it’s hard to paste the security code.

Not urgent. I’m not a big pod-cast-listener, just came accross this one via Librem Social.

Now, with your help, figured out the gnome-online-accounts only support LibremOne accounts that have e-mail enabled.
Next: figuring out why my personal email account is not accepted for IMAP in gnome-online-accounts.

Does your bluetooth work properly? Does your camera make two files instead of one when you take a picture?

Is that bad? :smiley: It intentionally makes two files: DNG, which is a raw shot that’s suitable for manual processing; and an automatically developed JPEG file.


A choice if you also want the raw files would be best. I am a photo enthusiast, but don’t find the camera useful enough (it is a bit rough around the edges, to say the least) to bother with any post processing yet.

1 Like

Before my L5 I was running Megapixels on Pinephone with Manjaro. There I could opt out from the DNG files, which mostly take up extra space atm.

I second this. I don’t see myself doing anything with the raw files, precisely because I am not a photo enthusiast. I just want it to work, point and click.

You could always write a cron job to run as purism and wipe out ~/Pictures/*.dng


A choice if you also want the raw files would be best.

Fortunately, that is easy to fix. Megapixel uses a bash script called postprocess.sh to do the conversion from dng to jpg. That script can be overriden per user and a simple deletion of the dng file would be a one line change in that file.


Since 2003 there is WPA and WPA 1 supports 8-16 characters, WPA 2 8-63 characters, so it’s not Gnome’s idea which caused this requirement :wink: