[MyL5]: first impressions

That’s what they are selling:


(Well, that’s community edition which has ended). I expect the motherboards to be back in stock after the factories start the production again after the recently Chinese New Year vacation. Probably they will be available at the same time with the restocking of PP with the default OS (March-April).

1 Like

Sweet, I’ll keep an eye out for it.

It goes without saying that you should let it install all the updates that are available. Early on I had some lockups etc. but the frequency of that has dropped right away.

Me too. A Bluetooth keyboard works fine but I was not able to get Bluetooth (music) sound output to work (so far).

I think GPS (GNSS) is not working in software yet.

It’s working for most people. I don’t think that it will automatically mount. Start with

ls -l /dev/sd*

What type of file system (e.g. ext4, vfat, …) and what capacity of card (e.g. 32 GB)?

Yeah, I could connect with a smart band just fine, but no way to connect to headphones.

ls just shows /dev/sda. It’s a 32Gb lexar, ext4, same for 32G sandisk

sudo fdisk -l /dev/sda

It is a little bit fiddly to ensure that both the SIM card and the uSD card are correctly positioned in the tray, and stay that way as you slide the tray back in. Maybe bring the tray out again and check, if you haven’t already.

If still no joy, I would try a different uSD card, for fault isolation purposes.

I tried with another uSD. Also, I removed the sim just to have less things to care about, removed/inserted the tray a few times with no luck.

fdisk: cannot open /dev/sda: No medium found

Thanks a lot for this comparison to the PinePhone. A friend of mine lended his PinePhone for a few weeks to me and while it’s very fun to mess around with due to it being so open, I use it a lot less than I anticipated because it’s slow and the battery life is really bad (even with everything toggled off, but with wifi only soft-toggled to easily enable it while at home). I hope it becomes a bit faster and gets better battery life with updates. If that happens I might start carrying it beside my android phone daily.

If the Librem 5 already has better battery and is faster at the same time as it also has room for battery and performance improvements, that makes me more optimistic!


Funny. My first impression when I opened the box was that Librem 5 is not at all so thick and heavy. I compared to my Moto G6 and the only difference is that it is a little bit thicker. But reading the terrible noise about how thick and heavy it is I expected much more. I suppose that people are comparing to those extremely thin phones - not to medium size phones like Moto G6. Compared to my old Nokia N900 it is even thinner but has a larger screen. But everyone has his own taste.

I really like the sturdiness of Librem 5. I use my phone in the forest and I would be very nervous with a thin phone. I cannot tell how it compares in other respects yet but it was important to change the settings of the TP-link C7 router to 20 MHz bandwidth to get a stable connection - it was useless with the auto setting. And the date setting was OK once I realized that I had a Swedish SIM card and set the time zone to Stockholm. Because you nowadays can use your SIM cards in the whole EU it is important that you are careful with the settings.

The phone antenna seems fairly good but I have to check the WiFi antenna because I have poor signal even close to the router.

But it is nice to have Debian in the phone (as I have in all computers). Almost everything is familiar except Gnome which I have never used. I suppose it will take some time to learn all the quirks …


I have no problem with bluetooth headphones:

Plus, my microSD card was recognized right away. Lollypop displays and plays the stored music on the card fine. Files shows my card mounted and lets me explore the files.


I start to think that it might be an hardware problem then, for the microSD not being seen in any way

Here’s what I see on my L5:
Files app:

Disks app:

Disks app sees the ‘drive’ (it’s not a software problem), but under volumes it says: no media

1 Like

I have tried bluetooth and i can connect to my desktop pc. But file transfer from the desktop to the librem5 does not seem to work.

You might have to contact Purism for more diagnostic expertise.

Thanks, I wrote them yesterday

We are checking this information with some of the Librem 5 developers to
check if there is any further test that we can do.

Did you already check this one here to rate your user experience?

Thanks! I did

Quick update: still no news on the SD thing (I got some reply from the purism support, but no fix yet).
Regarding random reboots, I’ve not had any in those days.

I also tried a couple of games (the usual supertuxkart and animatch) and they work really well. Overall, the experience is quite nice (far from perfect or at least at pair with an android phone, but we’re on the right track)


Update: Purism support said it might be an hardware problem and will replace it since it’s under warranty. In one day they sent me the “return label”, so I just had to put the phone back in its shipping box along with its accessories, went to the postal office with the return label and that’s it (I’m in Europe and the phone is being sent to Germany. Since it’s a replacement, I won’t have to pay for customs again). Purism support is great, now let’s hope the new/fixed phone is shipped fast.

To quickly delete personal data, I removed .config, .cache, Music/Documents/Downloads, .local/share and few others, plus I removed some of the installed app.

Side note: I’m back to the pinephone, which feels slower but hey, at least I didn’t erase data on it.


The operating system really ought to provide this function, not as a high priority, but eventually.

Even the iPhone has this function - you just have no way of knowing whether it really does what it says. :frowning: