[MyL5] Librem 5 arrived. Where is file explorer? Certification issues

Okay folks,
It has arrived and I am very happy.
I’m very pleased with the device in my hand and want to thank the creators of the device.

The wait has been infuriating but at the end it is indeed worthwhile.

I haven’t yet inserted a SIM card.

Few issues.

  1. When trying to update os I get certification error
  2. Is there no file explorer??
  3. Is there no home page?
  4. I cannot install lollypop because there’s no certification or it’s not in amber repository ??
  5. How do I install flatpaks ?



Make sure you have set the Date, Time, AND Time Zone correctly. See Settings>Details>Date & Time. Best to set it manually.
Nemo works well as a file explorer; search for it in the PureOS store.
The home page is the app collection, let’s say.
Lollypop should be already installed.
For flatpaks, you have to first install the flathub repo. (Instructions in linked wiki.)


Check the time for that, you may have to set in manually in beforehand.

  1. Check the system date/time for the certificate problem.
  2. Answered in the link provided by @amarok
  3. What is a home page for you? you’ve got a main screen and if you press in the arrow in the bottom you’ll see a kind of home page
  4. Check point 1

a. flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
b. flatpak install flatseal for example


Date, Time, AND Time Zone. It works best if you do it manually.


Congratulations! I recommend reading or at least skimming everything that has been posted on the Librem 5 forum since November 18th. You’ll find a lot of answers, tips, tricks, and information on apps that work well.

1 Like

Update the estimates if you would, so we can have a mental image of when to expect ours

@dos, can there be an additional screen during additional setup that allows choosing time zone, data and time that can be used to address the “Certificate error” ?


How ?
timedatectl set-timezone Europe/London
Didn’t work
Any link to a resource ?? Please.

I think that should have done it. Maybe if you restart? Are you connected to the internet?

Edit: And are you sure the Date is correct?

@joao.azevedo Hey Joao, any ideas about @sherab_kelsang’s certification error?

Use the GNOME Settings application. There is a Date & Time section.

Both the Automatic Date&Time as well as the Time Zone are toggled on.
Doesnt work.

after a restart - nothing has changed - obviously the command I used is not working

And is the correct Date & Time and Time Zone shown?

Take it off auto until after you get set up. Then you can toggle it back on.

1 Like

Automatic should get time corrected if you have internet (wifi). If you don’t - switch to manual and set using date or timedatectl set-time command

it says requires internet access - but i have both SIM and wifi
the Date & Time are not correct
The Time Zone is Correct (London)

MANUALLY SET both the Date & Time in the xxxxxx I mean in Date&Time, under Details in the Settings App.

1 Like

I would try to set them manually, and disable Automatic Date & Time for the moment.