[MyL5] Received my Librem 5 (Evergreen)

Or worse… end up pregnant because you skipped a day of birth control! :crazy_face:

1 Like

Off topic, but: Why should pregnancy be worse than dying?


Ah, I thought you also meant that predictive system that can learn also didn’t work for you. That sounded very surprising.


I would be interested to know which carrier you went with and how well the modem works for that network.

I’m going to stay with Sprint and I’m a little concerned about how to ask them for a new SIM chip, in that the only thing I want is 4G LTE cell service for now.

Anyway, I’m very pleased you have your phone, since it means that mine can’t be too far away!




Sorry for being off-topic. It was just a joke. :tongue:
Not everyone wants or can have offspring!

@JR-Fi @amarok wlr-randr is now packaged for the Librem 5 and available from the repos. No need for build magic.


I’ve tested 2 different AT&T resellers (MVNOs): my regular SIM, which I normally use in the Android, and a Truphone prepaid SIM; they both get good LTE in my house. Right now I have the Truphone SIM in the L5, but I mostly keep the mobile data off and just use my wifi. I haven’t even taken the phone out of the house yet! Lol!
As was said earlier, the L5 caller’s voice sounds slightly muffled to recipients right now, but that issue is being worked on.


Take it from someone that already made that experience, it can survive on the outside world :wink:


No doubt! Lol!
By the way, where can I find the IMEI of my device?

In Settings > Mobile > Modem Details (at the end of the page)


Oh wow, I totally missed that particular screen. As I said, I don’t have the modem on very often, and no settings under Mobile are visible when it’s off.

1 Like

@amarok, I want to add your info to https://source.puri.sm/Librem5/community-wiki/-/wikis/Cellular-Providers

Can you confirm that SMS and data work with Truphone? Did you have to change any of the APN settings? Have you only been using LTE or have you tried with 2G or 3G?


the modem is not embedded in in the SoC, consider it similar to a Wifi module on a laptop, if it is not connected it is non existent for the (in this case) phone


And the owner? :wink:

It has been determined that, when he is dragged away from his latpop to the outside world, he can survive as well.


That must be why Chats doesn’t respond to touch when I have Mobile disabled.

At the moment chats will not show stored SMS if the modem is disabled, that issue is known, and it is being worked on:

But if you have an xmpp, telegram, matrix account in chatty, it will work even with the modem disabled.

XMPP support exists by default, telegram and matrix you would need to build the plugins from source, the matrix plugin is quite resource intensive atm.


SMS: confirmed
Data: Odd…not getting data at the moment. Truphone’s APN is just truphone.com with no other settings. Let me investigate.



If you have an Icon similar to this one in the top bar it means that there is no data (wifi or mobile data). You can toggle the “Mobile data” button in the mobile settings off and on once to see if that solves the issue

1 Like

I’ve got data with Truphone now. I removed the SIM and tried a different carrier, then reinserted the Truphone SIM. Everything works.
BTW, Amos, I don’t think AT&T (Truphone runs on them in the US) has 2G anymore, right?