New Librem 14 will not power on

One day laptop worked, next day it will not power on or show any charging indicator. I can’t even get to any on screen boot activity.

I’ve only had this for 1 month and was using a lot for first week but then got distracted with life. Got back into it two days ago, no problem… then yesterday, crickets, notta, nothing!

Submitted support email but curious on how prevalent this is? Don’t see much about it on this site… one good thread on the battery and charging best practices. Another thread mentioning that either the battery is fried (pain) or the circuitry (disaster).

I had left the adapter plugged in when not using and wondering if battery is fried, even though thread states that the adapter/machine is smart enough to stop charging before reaching 100%.

Pictures show before and after holding power button. The lights flash after 1 sec and the go back off after another sec. If I keep holding power button down, the battery amber light stays on after other lights go off, until I release the button.

BEFORE HOLDING DOWN POWER BUTTON - ALL DARK

WHILE HOLDING DOWN POWER BUTTON - TEMPORARY LIGHTS (Including screen)

how are you charging - USB-C or BJ connector? It’s been reported that USB-C charging sometimes won’t work on a completely dead (or turned off) Librem 14.

Hi @MrChromebox - thanks for asking. I’m using the std power adapter that shipped with it (no usb-c) for round power port. But I had been leaving it plugged in while not using it for a couple weeks.

P.S. Purism Support just responded with (abbreviated):

This sounds like a firmware crash, I would recommend resetting the EC firmware by unplugging the internal battery connector from the mainboard for at least 10 mins to force a reset.

yes that’s the barrel-jack (BJ) type power supply.

sounds like the EC might be in a weird state. The best way to reset it is to remove all power, and sadly the L14 doesn’t have an externally-accessible reset button like the older L13/15 models. So you’ll need to unscrew and remove the back cover, disconnect the internal battery, then reconnect after 30s

damn ninja’d by support

edit: Once it’s booting again, be sure to update both the EC firmware and the main coreboot/Pureboot firmware to the latest releases

LoL - no worries, your response makes me feel much better!!! I’d already been inside the case to swap out the SSD on week 1 which required disconnecting the battery so at least it’s familiar ground. Thanks again!

Good advice- will do!

So @MrChromebox - is it a bad practice to leave the adapter plugged in when not using?

I just went through a similar ordeal with my L14. I had it for about a month and one day I got a red battery light… but the laptop was plugged in and it had been plugged in. The battery was draining with the provided barrel jack plugged in. I checked the tip of power cord with my multimeter and it was supplying sufficent voltage. I turnned off the computer with 15% left in case I had to boot it back up and try any command stuff after I contacted tech support.

They did give me some things to check. But by the time I went to power it back on it was in the same state as yours. Some response from the lights, but no power up. A day later there was no response from the lights on any button press. Muerto.

I had to send it back and get a new one. Didn’t really hear what failed on it, just that I was getting a new one. But they were responsive and got one back to me quickly.

I’ve had the new machine for two weeks now and all is well. Though I expect to be nervous around the 1 month mark :laughing:

Thanks @dbrokaw1251, interesting… sounds identical and looks like I’m heading down same path.

Hi @MrChromebox - I just opened case and unplugged the main battery for 15m then plugged back and tried to power on. No change at all.

We are talking about the big laptop battery and not the little round cmos battery, right?

@dbrokaw1251 I was searching on Librem laptop reset and came across this nice article by @MrChromebox himself that seems to be discussing the mysteriously random EC problem… although the article says the problem was fixed. Hmmm

Disconnect both.

Whatever I experienced was evidently not able to be resolved by repair techs because I was initially sending it back for “service”. Ultimately, I was sent a new machine. So I imagine whatever happened in my case was something beyond a simple unplug and replug situation.

Like I said it was unfortunate that it was necessary, but they were very responsive to the issue and didn’t hesitate in replacing the computer. So good on them for that.

I will revisit this thread in a month and let y’all know if it’s still working!

Sounds good! We’ll see where I’ve landed by then.

Ok, can’t hurt anything at this point. Thanks @Gavaudan

Ok, disconnected main battery and cmos. No change, still won’t power on.

Just to be clear, you have to leave them disconnected for about a minute or so.

Looks like an old brick for a Dell.

Yes, left both unplugged for 15mins+

So sad… all the excitement and waiting for the new laptop to arrive, to get a brick. Hoping for better days.

1 Like