New Librem Mini : firmwire issue :failed to load rtl_nic/rt18168e-3.fw (-2)

Hello Purism team ,
i recently purchased Librem mini with coreboot, just last month running PureOs.

  1. Problem i am facing
  • Everything was running fine until few days ago it started booting up in cmd line by default and when i used esc key to go into settings OS was throwing an error unable to load firmware rtl_nic/rt18168e-3.fw (-2) .
  • sudo dmesg listed errors messages
    firmware :failed to load rtl_nic/rt18168e-3.fw (-2) .
    Unable to load firmware rtl_nic/rt18168e-3.fw (-2) .
  1. Steps i have taken so far to try to resolve it on my own
    • followed steps on purism site to install firmware .
    • stackoverflow answers that try to manually add the missing packages .
    • rebooted once updated .
  2. Status so far - Not resolved .
    Need purism communities help. stepwise if possible as i am still a cmd line noob .

this is totally fine and normal, no need to worry. The firmware for the RTL Ethernet nic is optional, it is not needed for proper operation. Since it is a non-free firmware we do not include it in PureOS.

Actually if you do (as root or via sudo):
dmesg | grep firmw
you will see some more failed firmware loads, all of which are optional and not needed for proper operation.



Hello Nicole ,
Thanks for your reply .

Ok so let me restate the problem i am facing now .

  1. While booting even hitting esc takes me straight to virtual terminal .

  2. i am having trouble going to graphical interface . when i execute sudo apt-get install pureos-desktop i get error unable able to locate the package .

  3. I just need help to restart my pure OS GUI like earlier ( as default )

thanks ,

apt install pureos-gnome

its saying unable to locate the package .

apt update
and show me output from this please.
i suppose you tired to add debian repositories into your /etc/apt/sources.list
you did it wrong, and mixedup repos, so it replaced some apps from system with debian one.
it’s reversible i will help you but have to see what exactly you changed.
simples way is show contents of /etc/apt/sources.list and /etc/apt/sources.list.d/*

then i will show you how to do this rignt and install missing fimrwares (even if those are not required)

oh thanks so my output for sudo apt update is
Reading package lists ….Done
Building dependency tree…Done
Reading state information…Done
All packages are up to date.

+sudo dmesg shows same error that i was getting earlier failed to load rtl_nic/rt18168e-3.fw

what was before package dependencies…
it should looks liek this

ccan you please show me your /etc/apt/sources.list file contents?

that fw file is irrelevant. NIC will work without it.
first lets fix your installation of system, less important stuff we will fix later.

first make sure your apt sources list contain ONLY FOLLOWING LINES (delete every ting else)

# Main package repository for PureOS
deb byzantium main

# Important security updates
deb byzantium-security main

# Other updates for resolving non-security issues
deb byzantium-updates main

then remove if exist any file on /etc/apt/sources.list.d/

$ sudo apt update
$ sudo apt full-upgrade
$ sudo apt install pureos-gnome

Oh thanks . When i run $ sudo apt install pureos-gnome it throws an error " Unable to locate package pureos-gnome "

can you please do apt search pureos-
and show me the output
because it is definetly in repository.
and what version of pureos we are fixin? :wink: (because that may have impact)

Sure thanks here is the output.

so i am 200% sure you broken your system packages manager:
and din’t done cleanup of /etc/apt/sources.list as i requested
or did exactly what i requested on PureOS 9 / while entries i passed is for PureOS 10.
probably you are in single user mode and don’t have internet connectivity.

why i think that
normally packages are reported as

in my case it’s

all your packages are only /now

which means apt don’t have repositories info
did apt update reported any errors?
do you have internet connectivity?

ping works?
if not then first we have to connect you to the internet , plug ethernet cable to network card
then run sudo dhclient eno0

then depending if you are using pureos 10, then leave file as i requested
if running pureos 9
then edit apt sources.list and replace byzantium with amber

then invoke apt update , it should report fetching repos over http and then redo
whole apt comands set i posted above

i am connected to via ethernet cable so internet is there

ping please
and run
ip a a
and check if eno0 have assigned ip address.
if youa re in emergency mode, internet isn’t up for sure.
you have bring it up manually
so sudo dhclient eno0 will do the job

what worries me here is reason why your system don’t wish to boot.
emergency shell normally shows whens systemd is not able to start core services.
can you reboot your librem
then when emergency shell message show , press enter
and type : journalctl
then pres shift and while holding it pres GG to scroll to last lines
and do a picture of whole screen?

there will be error message there, because i believe , you hurt your system while you mixed packages out of official PureOS repo, your graphical system is still there, but system won’t bot,
that can be fixed, but i need to know what is an error here.

my bad
ip a
(single a)

looks like i am connected