New Phone Can`t Connect With Calls

Speaking of AT commands, it’s not clear to me which, other than the sudo line, is a command and which is an output in this:

To Enable VoLTE:
sudo screen /dev/ttyUSB3

Can someone elucidate?

All of these are commands to type. screen opens a direct terminal to modem’s interface. ATE enables character echo (so you can see what you’re typing), AT+CGDCONT creates a new context for IMS, and AT$QCPDPIMSCFGE marks it as the one to use for IMS (VoLTE). Then ATE0 turns character echo back off. AFAIR the modem should respond with “OK” after each AT command.


Sorry for disappearing.

It is correct that you won’t see as you type the first command in that Kyle method. I believe it is because using this function (screen) actually initiates sending keystrokes directly to the modem as you go, which is why you need to tell it to echo stuff back. That first command (ATE) is actually turning on the function that sends back from the modem what you type as you type it. Luckily that is a short command.

But that is why if you type in an incorrect keystroke you can’t just “backspace” it and expect it to go away like typing a normal command in the terminal. I don’t think the backspace actually erases it, but I know it certainly doesn’t echo. That is why if I hit an incorrect keystroke, I just killed the terminal session and started over. I was not aware of the ctrl-c that amarok recommended, which is probably a better way of doing the same thing so you could just restart at the beginning of the last command.

When you hit enter after each command line, it tells it to execute. If what you typed is incorrect, hopefully it just returns “error” and you get to try that command again. That happened to me at least twice. But try to type carefully and check it before you hit enter.

And in the end, the final command that you send (ATE0) turns the echo back off. So now you will see nothing else you type, but it will keep sending those keystrokes directly to the modem. Don’t do that. After you turn the echo back off, just kill the terminal. Then you can cycle the modem and see if you can get some 4G.


Seeing as we are drilling down …

I assume that the spaces before the AT commands are a bit bogus. Not required? Maybe ignored by the modem anyway? Unhelpful?

I would want a customer to cut-and-paste the whole lot, starting from sudo ending with ATE0. No typing errors. Doesn’t really matter whether it echoes. But that requires a prior sudo command to avoid the password prompt.

User has to type Ctrl+D at the end? something else? I mean switching off the modem could make the tty in /dev go away anyway and maybe screen will drop out because of that but …

1 Like

Separate answer - The phone has worked reliably since activated. I have it set to 4G only. Clear connection. Much clearer than my old Blackberry. I have dropped maybe one call, out of a whole lot, but likely not the phone’s fault.

The only issue I’ve had was funny more than anything. Something in software land got confused when I was receiving a text and phone call at the same time. It told me the wrong person was calling from contacts, and then seemed to remain 1-person behind on notifying me who was calling the next few tries. Probably until I restarted. Calls worked fine. Just the tag that said who I was talking to was off. Weird.


I think it’s just formatting, there are no spaces to type there.

Yes, screen drops out in that case.

That’s a known issue with older ModemManager when VoLTE is enabled, but there’s an update (1.18.6-1pureos2) coming that is supposed to fix this.


I didn’t know enough to recommend whether copy-paste would work. i.e. does pasting really send keystrokes to the modem like you would want them to? I honestly don’t know the answer to this, and I was too afraid to try.

I would think that copy/paste works fine, then, if you’re hitting Enter after each.

1 Like

Copy’n’pasting one command at once (without including the new line character) should work, but pasting multiple commands may cause problems.


Just want to thank all who give advice to this issue with the Lebrem5.
So…I bit the bullet and decided to go ahead and run these commands. sudo socat - /dev/ttyUSB3,crnl
then I was prompted for password…ok fine so far. Then I had a blinking cursor and typed
ATE (enter) screen said OK then AT+CGDCONT=2,“IPV4V6”,“ims” (enter) screen said OK then AT$QCPDPIMSCFGE=2,1,0,0 (enter) screen said OK then ATE0 (enter) screen said OK and the cursor is still blinking like its waiting for more input. So I turn off modem at the kill switch wait a few secs then turn back on phone is still on the terminal page,cursor still blinking. So I chose restart phone thinking this would all cycle in and I could make a call.Nope. Still cant call out.If I call it from another phone I get message"were sorry but the person at this number hasn`t set up their voice mail,blah blah. So…???

Try again, but this time close the terminal before you cycle or disconnect the modem.

Ok Gavaudan…what would be the proper way to close the terminal without completely swiping the page up then swiping up again and shutting down terminal?

On the phone, what you describe is the easiest way to do that.

yeah…I typed in command againafter a short time message across screen said “command successful” then slid screen into backround and hit modem kill switch. A little while I turned modem back on and restarted phone. Still Nothing. No receive or make calls. Nudda.Nuttin.Gonna send it back. I`d rather Purism mess with it. Thanks Gavaudan

With the “command successful” response from the modem, I’d bet the modem is good to go now for VoLTE, and the issue is with something else. But the issue could be with a different setting, or with AT&T. Again, this is just a hunch, but I’d say it’s worth a last tinker with the easier to change settings. Mine is still working with PureTalk, on AT&T backbone, but maybe they are less restrictive with the phones on the MVNOs.

So the settings I’d look at are under the Settings -> Mobile. On mine the following works:

Mobile Data On
Data Roaming Off
Network Mode 4G Only
Network Pure Talk [of course yours will be AT&T or something]
Access Point: RESELLER (under the name Pure talk, again, yours will be att or something here)
SIM Lock Disabled

Modem Details is just informative, but I’m curious if yours says “lte” under network type.

In the end, I’m glad you took the leap and gave it a shot. I know it’s tough to convince yourself it’s a good idea.

Thank you Nate for all your welcomed input! Ive just repackaged up the phone and tomorrow itll be on its way back to Purism. Im an old guy who bought into the whole privacy phone thing.Mostly I wanted to be able to use it for crypto in a way the apple phone uses its phone to pay for things.. But I dont have the time or patience to type commands because stuff don`t work. So… thanks again! your post were detailed and informative! Take care!

1 Like

All this (typing AT commands over serial lines to a modem) reminded me back to the last century when we used modems to connect to remote UNIX systems :slight_smile: We used kermit (nowadays ckermit) to do so and I installed it last night just for fun and tested it with the “modem” in the L5:

sudo apt install ckermit

sudo kermit
C-Kermit 9.0.305 OPEN SOURCE: Alpha.02, 19 Sep 2020, for Linux+SSL+KRB5 (64-bit)
Copyright (C) 1985, 2020,
Trustees of Columbia University in the City of New York.
Type ? or HELP for help.
(/home/purism/) C-Kermit>set escap 21
(/home/purism/) C-Kermit>set line /dev/ttyUSB3
(/home/purism/) C-Kermit>set carrier-watch off
(/home/purism/) C-Kermit>connect
Connecting to /dev/ttyUSB3, speed 9600
Escape character: Ctrl-U (ASCII 21, NAK): enabled
Type the escape character followed by C to get back,
or followed by ? to see other options.

(now I typed Ctrl-U C to get back to kermit's command level)

(Back at pureos)
(/home/purism/) C-Kermit>quit
Closing /dev/ttyUSB3...OK

The three init commands set .... can be stored in a file ~/.kermrc and you just can forget them.


I’m using minicom on my Librem 5 instead. The basic idea is the same. (‘Escape’ is Ctrl+A.)

awesome thanks for charing ill try to set the VoLTE setting with kermit 8) didnt seem to take with the other method for me.

Generates error unfortunately on entering second line:


Watch out for so-called “smart quotes” v. “straight quotes”. I would be 90% sure that any modem would want straight quotes but your post has the former.

The previous paragraph contains smart quotes. Here is a straight quote: "

1 Like