New Phone Can`t Connect With Calls

cursor is blinking…nothing happening. Cursor stopped blinking. nothing. At least there were no error messages. Seems locked up

Did it maybe finish and then display the prompt line again?

prompt line didn`t come back…just a plain blinking cursor that quits blinking like it quit working

shall I reboot phone and try again?

OK, I don’t have any experience with AT commands, so we had better let someone qualified respond.

For what it’s worth, I just installed socat and ran the socat command. I’m at the same cursor point as you; I think this is where you enter the AT command, but as I said, I don’t know how to carry on from here.

BTW, I wrote “cnrl” before, but it should be “crnl.” Sorry. I think you did, too, initially, hence the “unknown option” message.

If you want to cancel an operation in the terminal, activate the Ctrl key, then hit “c” and don’t forget to then disable the Ctrl key.

I thank you Amarok!! Appreciated!! Francis

1 Like

Stay tuned. I’m sure somebody here will chime in.

I`ll hang :innocent:

We can’t really help you with a procedure that we can’t see. As far as I can tell, you have not posted the link. So we would be guessing as to what the next steps are.

Kyle method: VoLTE support progress

and note the comment to double check everything as you type it.

You will have the same issues with sudo and needing the password and the password’s not being echoed on the screen (for security reasons) but I guess you are on top of that now.

The first command in the Kyle method may also not be echoed on the screen. (Not sure about that.) But anyway, if the first command does not echo then don’t worry about it. Worry if the subsequent commands are not echoed.

Also, a random comment from me: It can be that immediately after you plug a modem in, the system itself is chatting furiously to the modem and you can interfere with that and it can interfere with you. So after booting up, and assuming that the modem on the Librem 5 is switched on (not killed), I would leave it for some minutes before attempting this procedure.

Speaking of AT commands, it’s not clear to me which, other than the sudo line, is a command and which is an output in this:

To Enable VoLTE:
sudo screen /dev/ttyUSB3

Can someone elucidate?

All of these are commands to type. screen opens a direct terminal to modem’s interface. ATE enables character echo (so you can see what you’re typing), AT+CGDCONT creates a new context for IMS, and AT$QCPDPIMSCFGE marks it as the one to use for IMS (VoLTE). Then ATE0 turns character echo back off. AFAIR the modem should respond with “OK” after each AT command.


Sorry for disappearing.

It is correct that you won’t see as you type the first command in that Kyle method. I believe it is because using this function (screen) actually initiates sending keystrokes directly to the modem as you go, which is why you need to tell it to echo stuff back. That first command (ATE) is actually turning on the function that sends back from the modem what you type as you type it. Luckily that is a short command.

But that is why if you type in an incorrect keystroke you can’t just “backspace” it and expect it to go away like typing a normal command in the terminal. I don’t think the backspace actually erases it, but I know it certainly doesn’t echo. That is why if I hit an incorrect keystroke, I just killed the terminal session and started over. I was not aware of the ctrl-c that amarok recommended, which is probably a better way of doing the same thing so you could just restart at the beginning of the last command.

When you hit enter after each command line, it tells it to execute. If what you typed is incorrect, hopefully it just returns “error” and you get to try that command again. That happened to me at least twice. But try to type carefully and check it before you hit enter.

And in the end, the final command that you send (ATE0) turns the echo back off. So now you will see nothing else you type, but it will keep sending those keystrokes directly to the modem. Don’t do that. After you turn the echo back off, just kill the terminal. Then you can cycle the modem and see if you can get some 4G.


Seeing as we are drilling down …

I assume that the spaces before the AT commands are a bit bogus. Not required? Maybe ignored by the modem anyway? Unhelpful?

I would want a customer to cut-and-paste the whole lot, starting from sudo ending with ATE0. No typing errors. Doesn’t really matter whether it echoes. But that requires a prior sudo command to avoid the password prompt.

User has to type Ctrl+D at the end? something else? I mean switching off the modem could make the tty in /dev go away anyway and maybe screen will drop out because of that but …

1 Like

Separate answer - The phone has worked reliably since activated. I have it set to 4G only. Clear connection. Much clearer than my old Blackberry. I have dropped maybe one call, out of a whole lot, but likely not the phone’s fault.

The only issue I’ve had was funny more than anything. Something in software land got confused when I was receiving a text and phone call at the same time. It told me the wrong person was calling from contacts, and then seemed to remain 1-person behind on notifying me who was calling the next few tries. Probably until I restarted. Calls worked fine. Just the tag that said who I was talking to was off. Weird.


I think it’s just formatting, there are no spaces to type there.

Yes, screen drops out in that case.

That’s a known issue with older ModemManager when VoLTE is enabled, but there’s an update (1.18.6-1pureos2) coming that is supposed to fix this.


I didn’t know enough to recommend whether copy-paste would work. i.e. does pasting really send keystrokes to the modem like you would want them to? I honestly don’t know the answer to this, and I was too afraid to try.

I would think that copy/paste works fine, then, if you’re hitting Enter after each.

1 Like

Copy’n’pasting one command at once (without including the new line character) should work, but pasting multiple commands may cause problems.


Just want to thank all who give advice to this issue with the Lebrem5.
So…I bit the bullet and decided to go ahead and run these commands. sudo socat - /dev/ttyUSB3,crnl
then I was prompted for password…ok fine so far. Then I had a blinking cursor and typed
ATE (enter) screen said OK then AT+CGDCONT=2,“IPV4V6”,“ims” (enter) screen said OK then AT$QCPDPIMSCFGE=2,1,0,0 (enter) screen said OK then ATE0 (enter) screen said OK and the cursor is still blinking like its waiting for more input. So I turn off modem at the kill switch wait a few secs then turn back on phone is still on the terminal page,cursor still blinking. So I chose restart phone thinking this would all cycle in and I could make a call.Nope. Still cant call out.If I call it from another phone I get message"were sorry but the person at this number hasn`t set up their voice mail,blah blah. So…???

Try again, but this time close the terminal before you cycle or disconnect the modem.