New Post: My First Week of Librem 5 Convergence

I have received a second unit of Baseus (the first was faulty) and I can also verify that it works even with the screen protection of ViaScreens I have added. I mean that even with this increased width of the phone the amount the phone “travels” in the dock to connect to the usb-c is enough to make it work. But, you have to give it some time. Say, wait for at least 10 seconds to see that the charging led lights up. If you just connect and expect for charging to start immediately, the way it does when you connect it to the charger it will not work. Give it more seconds.

Now, there is a problem with sound. One of the scenarios for the dock is to connect it through hdmi to a TV and play a video on the TV with the L5 (say with vlc or mpv). VLC can not be moved to the TV screen. How to you grab its window with a mouse? Nevertheless the main problem is how to route the sound through hdmi to the TV.

To make sure it works through Baseus I tried with my sons Samsung using Samsung DeX. And it works. So the Baseus dock can stream the sound to the TV.

But on the L5 how can I do that? It plays through the L5 speaker. I opened Settings→Sound and there does not appear any new output device to select. I can select L5speakers, Handset, Multichannel Output - Modem, and Analog Output - Modem. (4 options).

Is it possible somehow? If not from the interface maybe through terminal?

1 Like

How about using pavucontrol for sound settings? I think you have to install it from the repositories. IIRC there is some tag with a dropdown to select HDMI output.

That is out of my memory from years ago on my desktop.

I installed pavucontrol and connected the the L5 to the TV. Again, there is no such option. In the output devices there is no HDMI out.

Try going to the “Configuration” tab. Do you see HDMI devices in the menu for “Built in audio”? Try selecting an entry with “Digital Stereo (HDMI) Output”.

pavucontrol on L5 with amber, Configuration tab
Build-in Audio
Profile Default
The only other option is Off.

on L13 with byzantium there are plenty of Profiles including HDMI out in pavucontrol.

Is this really a difference of Amber with Byzantium or it is something else? Something specific to L5?

I doubt that this is a pure amber vs. byzantium issue (I reckon that if you were running amber on your L13 you would also see the HDMI profiles). However the audio on the L5 in byzantium might have more options of course - is there anyone here who can check? If not, we could ping one or two of the devs who hang out on these forums.

@amosbatto was asking a related question here: L5 Multiple Audio Outputs.

1 Like

Just checked the @amosbatto question you gave me. Nope. The playback tab for the application lollipop I tested gives only two options:

  1. Speaker+Headset+Jack
  2. Modem
    No hdmi output. Rechecked Configuration tab, no hdmi output there either. So it is time to ask some developer. Dear @dos or @Kyle_Rankin who originally wrote (I think) about the docking do you know what is the problem and no hdmi output is given in either build-in sound preferences or pavucontrol on L5 with amber?

There’s no support for audio output over DP in the kernel yet. From what I know there’s nothing in the hardware that would prevent it from being supported, so it likely just needs some kernel driver work.


Oh, OK @dos So this is one more missing piece which should be considered, I guess, as part of “convergence”. Thanks for clarifying this.

Not to be forgotten, if there is a project I could file a “bug” report please provide a link.


So it is reported by Todd himself. Good.

I tested the L5 with a Trust 7-in-1 dock (HDMI, Ethernet, 2Usb, 2 Card reader, Power In) powered by a 61W PD3.0 power supply (tried both with L5 stock and this one).

Both USB devices work fine (keyboard and mouse), both with and without power supply plugged in (but the battery discharged super fast when not plugged in). HDMI output works, too, sometimes even when it’s not plugged to power supply (but this is inconsistent). Also, when plugged in, /sys/class/power_supply/max_170xx_battery/current_now reports -0.1A/-0.3A (with the L5 display off, wifi off, modem on) which means -1% in a few minutes). Also, sometimes the screen goes blank and reappears with some horizontal shift (the right part of the display is shown on the left. Usually unplugging and replugging the dock restores the right aspect.

The device itself advertise support for USB-C PD pass through up to 5A 100W.
I suspect the dock does not support PD3.0 (I had a problem with a laptop usb-c charger rated 45W = 20V*2.75A maximum, 3A for other voltages including 5V, 9V and 12V) which was not able to charge the L5.

Can this be fixed by some future upgrade, or should I return the dock?

(No battery: power cycling)

You can check what power contract does your hub negotiate with:

cat /sys/class/power_supply/tps6598x-source-psy-0-003f/uevent

5V/3A should be able to charge the phone with no issues.

1 Like


  • Trust 61W Power supply:
    • Alone: 5V2.4A
    • Hub: 5V0.5A
  • Purism Power supply:
    • Alone: 5V3A
    • Hub: 5V0.5A
  • Varta PowerBank (with PD):
    • Alone: 5V2.4A
    • Alone (non-PD port): 5V0.5A
    • Hub: 5V0.5A

I don’t understand why only the purism power supply gets to 3A even if the trust one should support 5V3A (same goes for the varta power bank, which states: 5V3A, 9V2A, 12V1.5A). I’m using the same usbc-usbc cable (purism one) in this tests.
Also, the usb hub seems not to use PD being always capped at 0.5A.

Likely yes. It is only being recognised as a standard USB 2.0 / 3.0 port and the Librem 5 is limiting to 0.5A.

Is it a software thing? If I’ll never be able to use this hub with the L5 keeping its charge, I’d better replace it, but if it’s a matter of “waiting for an upgrade” I’ll keep it…

If you are connecting the Librem 5 to the correct USB-C port on the dock and it negotiates to standard USB 2.0 max power (500 mA) then it’s probably not going to work for you. Even if the USB-C PD firmware on the Librem 5 changed, that won’t necessarily do anything to override the dock side, which is a blackbox.

Does it make a difference if you vary the order in which you connect things up?

The bottom line though is that unless and until you can see it negotiate a decent amount of power, it isn’t going to work.

Yes. Even so, 2.4A should be more than enough to operate and charge the Librem 5.

Ok I found out something that’s even more interesting. I plugged a samsung charger (rated 9V1.67A, 5V2A with adaptive fast charging), which negotiates 5V0.5A. I the used it to power the USB hub, and now I gets 5V0.9A.

The same goes for an Ikea charger (rated 5V2.4A) and for an LG one (rated 5V1.8A).

Too bad that’s not enough to charge the device consistently (I get +/- 0.2A). However I’d say there’s a problem in our tps6598x firmware. Also, according to this, it seems that enabling voltages above 5V in the firmware might fix some of the power supply issues.

Not really. L5 obeys what your hub is telling it, and seems like it tells that it supports up to 500mA over 5V when used with PD source. Some poorly implemented hubs do that, which is why it’s important to check how the hub operates at 5V specifically ( Higher voltages can be enabled in TPS65982 configuration, but that’s not recommended.

If you feel adventurous you can override the input current limit manually:


Thanks! I set the input to 2.1A (0x28), now the phone is always charging with 0.4-1A, 2 usb devices and HDMI plugged in. At first it seemed to work fine (the phone was charging, hdmi output worked ok) but then visual glitches started to appear again. I guess I’ll have to try with a new hub