New Post: My First Week of Librem 5 Convergence

today I received this hub


Option : 8-in-1


Video 1
Video 2
Video 3
Video 4
Video 5

9 Likes

I’m using the same dock as Kyle ( Baseus GN16A ) and noticed one thing that’s a drawback for my (admittedly weird) use-case: I’ve been using the L5 as a stationary device on my desktop, not needing to take it with me. As a result I’m running it without a battery to avoid putting any wear on it for the time being.

The charger that comes with the phone powers it fine when directly plugged in, but if I run it through the Baseus dock, it won’t operate without a battery installed. Must not pass through the required amps? Not sure.

I also tried the same scenario with a Lenovo ThinkPad USB-C Dock Gen 2 (40AS0090US), and while the phone started to boot, it would stop, reset, fail, and after a few attempts, stop attempting to boot up. Kind of surprised about that one, as it can drive/power my Thinkpad fine.

Probably not something 99% of people care about, but wanted to share my battery-less L5 experiences. :smile:

3 Likes

Yeah that sounds like it’s not providing enough amperage. It does take a lot of power to drive the display and peripherals. A good dock will also be able to charge the L5 while doing this, but it won’t charge it very quickly.

1 Like

@bjm and @Lagomorph, I added your comments to the wiki: https://source.puri.sm/Librem5/community-wiki/-/wikis/Tested-Accessories

What ports you have tested on the hubs? Can you use the lsusb command to provide the USB ID number for your hubs?

1 Like

How does convergence feel? I mean, really feel?

@Kyle_Rankin Does the Baseus dock actually charge L5? Does it provide PD? Because the specs at some stores say something like USB-USB-C does not charge. Maybe this means something else, and I get confused.

The dock I have does indeed charge the L5 while in use. Of course driving a monitor, keyboard and mouse does require more power from the Librem 5, so while the dock does charge the L5, it charges slowly compared to charging while undocked.

1 Like

Given the L5’s weight it could well be brass already :stuck_out_tongue_winking_eye:

I ordered this one via the “official” Baseus ebay store and it was 23€ including shipping.

How did you get the red LED to stop blinking with the battery out?

purism@pureos:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 2020:2060  
Bus 001 Device 003: ID 0424:4041 Standard Microsystems Corp. Hub and media card controller
Bus 001 Device 002: ID 0424:2640 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 0781:5580 SanDisk Corp. SDCZ80 Flash Drive
Bus 004 Device 003: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 004 Device 002: ID 05e3:0626 Genesys Logic, Inc. 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 006: ID 25a4:9311  
Bus 003 Device 008: ID 1ea7:0066 SHARKOON Technologies GmbH [Mediatrack Edge Mini Keyboard]
Bus 003 Device 007: ID 13fe:3400 Kingston Technology Company Inc. 
Bus 003 Device 005: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 004: ID 05e3:0751 Genesys Logic, Inc. microSD Card Reader
Bus 003 Device 003: ID 05e3:0751 Genesys Logic, Inc. microSD Card Reader
Bus 003 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
purism@pureos:~$  


4 Likes

I didn’t; it blinks incessantly. At first it was distracting, but after awhile I didn’t notice it.

I just answered the same question on Matrix, so let me copy that:

there is a bq25895 register that tells it to disable the status LED
https://www.ti.com/lit/ds/symlink/bq25895.pdf
page 39, REG07, bit 6 - STAT_DIS
take care though, other bits in this register seem pretty dangerous.
in any case, sudo i2cget -f -y 3 0x6a 0x07 will give you the current value of the register
and you can set a new value with sudo i2cset -f -y 3 0x6a 0x07 <VALUE>
so in this case you would read the current value, set bit 6 and write it back.
just triple check that you change the correct bit :wink:
as long as you’re sure you set the value correctly it should be fine.
it would get problematic if you, say, cleared the wrong bit and forgot about it.
and after a while it turns out that you disabled Charging Safety Timer which won’t be able to ensure safety anymore :smiley:
so, as a example:

purism@librem5:~$ sudo i2cget -f -y 3 0x6a 0x07
0x8d
purism@librem5:~$ sudo i2cset -f -y 3 0x6a 0x07 0xcd # turns STAT LED off
purism@librem5:~$ sudo i2cset -f -y 3 0x6a 0x07 0x8d # turns STAT LED back on

3 is the i2c bus number, 0x6a is the device address, and 0x07 is the register address.
the idea was that you read the current value (which turned out to be 0x8d on my device), then you set its 6th bit which results in 0xcd which you then write back to the register

5 Likes

:open_mouth:

What was that about triple checking? The example commands are correct but the associated text is erroneous - and exactly the kind of thing that you are warning about.

1 Like

Ha!

Edited, thanks :slight_smile:

1 Like

Hi I’m trying to use the Kensington SD4600P docking station with my Liberm 5 dogwood, but it seems not to detect convergence mode. Do I need to do something in the terminal to make the mode active? Is there a way to force it to become active if not?

1 Like

Not every USB-C dock happens to work with the Librem 5. My understanding is that USB-C PD negotiation implementations run all over the map and that the USB-C standard in general is kind of a mess.

1 Like

I’ve wondered about this too but my dock is still stuck in the Suez Canal. :wink:

Two questions:

  • are you running the latest software?
  • what is the USB vendor and product id of your dock?

I too wonder what the exact conditions are that have to be met in order for the Librem 5 to go into ‘Docked’ mode (because it didn’t work when I tried it with the hardware that I had to hand).

The Librem 5 needs to detect the USB keyboard and mouse, and ideally also the USB-C Display Port display (but I’ve noticed on docks where the keyboard and mouse don’t work simultaneously with the display that it enters “docked mode” just with keyboard and mouse). Sometimes the negotiation with a particular USB-C hub doesn’t work and you only get one or the other. Other times you may get both but not Power Delivery. It really depends on the hub.

1 Like

So if I have a Bluetooth keyboard and mouse (which I do, and they work with the Librem 5) and I use it directly with a USB-C DisplayPort display (no need for a dock / hub / anything else, and the display does ‘work’ with the Librem 5), the Librem 5 won’t work out-of-the-box to enter “docked mode”?

I can live with this. I have an actual dock on order. I’m just exploring what is supposed to work and what is supposed not to work (at the current time).