No more WiFi after today OS update

Yes I updated to 5.11.0-1 because I had the WiFi issue and downgraded again. Now uname -r returns

I received the Librem5 yesterday and after playing with it during a few hours (and experiencing one or 2 crashes when installing apps via the store) the wifi was not working anymore. Switching off/on the wifi HKS was of no help, same deceptive result with a reboot. I had to switch the phone off and on again for the wifi to work, as reported by antonis.

Then I updated the kernel and once again, after a reboot, I had no wifi, even after switching the phone off/ switch on.

Finally, for the wifi to work again, I had to switch off all three HKS and switch them on again. I hope this can help someone.

Woaw, stupid me, I thought the top switch was also for wifi, but it’s the middle one! :crazy_face:

Forget what I said, it works great, actually :smiley:


After the downgrade is the firmware correct or is it still muddled ?

It is still muddled. Is there a way to flash it?

There is a way to reflash it. Come onto matrix or contact

1 Like

Pic: [MyL5] Australia/New Zealand



I have now upgraded to the latest 5.11 kernel from 5.9, preliminary results seem to show, for me, there is some performance benefit for WiFi in some scenarios and I’m also seeing one new Bluetooth issue.

For WiFi:

5.2GHz 40MHz, connected to Mikrotik (hAP ac^2), no significant performance difference from 5.9 kernel.

2.4GHz 20MHz, connected to Ubiquiti (Nano HD), 300-400% increase in download performance compared to 5.9 kernel. Sounds impressive, but it was very poor on 5.9 kernel and this performance increase just brings it inline with the 5.2GHz download performance.

2.4GHz 20MHz, connected to Mikrotik (hAP ac^2), this configuration sees the highest download performance but also the highest variance in download rates with lowest observed being 1.1MB/s and highest at 4.1MB/s. The rough calculation in my head suggests that this configuration, although highly variable, gives the highest average download rates.

I am seeing the issue of having to toggle the WiFi/BT HKS to bring up the card after boot, as I understand it, it is expected for those seeing this issue with previous 5.11 kernel versions that this issue will persist with this version also.

For Bluetooth:

I am seeing a new issue in that if I disable Bluetooth in software from the settings window, subsequently re-enabling it in software does not bring Bluetooth back up, the window remains displaying the large Bluetooth icon and denoting “Bluetooth Turned Off”. So far this has been 100% repeatable for me.

In order to bring it back up I had to ensure that Bluetooth was enabled in software then restart the bluetooth service…

sudo systemctl restart bluetooth

…or for those, like me, who can’t retrain their muscle memory and still deal in old money…

sudo service bluetooth restart

…still works.

I would assume toggling the whole card on/off via HKS may also bring it back up but I did not test that.

I did see this Bluetooth issue on previous versions of the 5.11 kernel but I didn’t spend any real time on those kernel versions to check if it was repeatable or not.

Bluetooth seems to be more adversely affected in comparison to the 5.9 kernel when running both Bluetooth and WiFi simultaneously. I am basing this on observations with having WiFi connected on 5GHz and streaming audio via Bluetooth (to a PS Audio Sprout, although not sure that matters), With WiFi and Bluetooth running simultaneously there is a lot of (what presents itself as) intermittent interference of some sort, lots of very short dropouts in quick succession, at times to such an extent that streaming audio becomes unusable.

I am also seeing that Bluetooth seems a little more ‘glitchy’ on 5.11 in comparison to 5.9 kernel. With WiFi disabled in software and running Bluetooth only, I am noticing more small glitches/short dropouts. It is notably more but not significantly more than on 5.9 kernel so this may just be circumstance of the moment, more time will tell.


So I just updated to byzantium using the device flash script, and applied all updates via apt. After rebooting, my wifi won’t work at all, even if I reboot, cold boot, or toggle any combination of the hks/software switches.

dmesg | grep redpine:

redpine_91x: rsi_probe: ***** 9116 Module *****
redpine_91x: redpine_hal_device_init: oper_mode = 13, coex_mode = 2
redpine_91x: rsi_load_firmware: *** Flash is Empty ***
redpine_91x: redpine_hal_device_init: Failed to load TA instructions
redpine_91x: rsi_probe: Failed in device init
redpine_91x: redpine_set_clr_tx_intention,357: Wait eventfailed
redpine_91x: rsi_tx_scheduler_thread,623:  Failed to get tx_access
redpine_91x: redpine_set_clr_tx_intention,357: Wait event failed
redpine_91x: rsi_coex_scheduler_thread,112:  Failed to get tx_access
redpine_91x: rsi_probe: Failed in probe...Exiting

That doesn’t look good…

This looks like a severe problem. I just looked at the issues here but could not find any existing issue for that:

Could you add an issue describing your case there?

The replacement wifi+bt module arrived and im writing this from the wifi in the phone, the problem was a faulty module! Was easy to replace and if I forget the annoyance, empowering to be able to fix it myself.
In wifi I experience limited signal, sporadic disappearing after hks. In BT managed to connect to a pair of earphones. Good for music but large lag in calls. Will be testing more. So I guess i have what everybody else has now, it works but has edges to smooth. :wink:
Got charged 13$ for the customs of the module, will see if purism reimburses them.


@fiacco do you fixed the WLAN/BT troubles in your mobile computer(L5)?

No, I didn’t. But I’ve learned to deal with it. First, as someone pointed out above, the problem happens only after a restart, not at startup after power off. Second, toggling the switch has always worked for me. That’s it on the WiFi front. With regard to the BT I’m not using it, since it doesn’t allow for hands free driving, which is the only function that I need.

OK, I run byzantium on the L5 and the kernel was upgraded “linux-image-5.11.0-1-librem5” which provides kernel “5.11.11pureos1” (name -a only tells me “5.11.0-1-librem5” with a build date from April 6).

Since then, wifi has not worked for me. When toggling the hardware kill switch, all I get is a entry in dmesg saying: “mmc1: error -110 whilst initialising SDIO card”
It slowly stops being fun trying to daily drive the phone, I have to admit.

1 Like

I’m afraid so, Sebastian.

1 Like

It’s still fun to sit in the driver’s seat in the garage and play with the controls. :wink:

Hope we get our license soon!


It also happened after I upgraded, but for bluetooth. I haven’t tested wifi so I don’t know about that.

As byzantium is currently in development, while it may be undesirable to the end user, shouldn’t it not be expected that things may break? WiFi in particular as the driver/firmware is an area that is under active development at the moment.

I am running the system purely as downloaded from Purism and I have no problems with WiFi. But WiFi will not start after reboot - I have to switch off the phone for a while.

Strange that Wlan is not working with some user. I have 2 Evergreen and both work very very well BUT my both L5 has PureOS raw, i do not moved or changed anything on the systems. At the moment i am not using both L5 because i need Byzantium at minimum and one cover case. Librem 5 will work & look beautiful when reach gnome-40-gtk4.
The other day i was reading some docs of the L5-WlanBT driver, then i see that L5 can not work with wi-fi at 40 mhz wide band, i still not tested if 40 mhz not work at the moment on L5, maybe this info can help at some user with wlan troubles.
Also if the HKS wear fast the wifi can be troubled, i hope that the Purism HKS buttons are professional to prevent wear on long use it.

1 Like

That may mean … not working with a 40 MHz channel width in the 2.4 GHz band. It works fine with a 40 MHz channel width in the 5 GHz band.