No Wifi, cannot set date and time

When I go to Settings > Bluetooth, I see ‘No Bluetooth found. Plug in a dongle to use Bluetooth’.

I don’t know where to enable Wifi in Settings. I don’t see a switch in Settings > Network.

Wi-Fi settings should also be there, except when the hardware switch is turned off, in which case it would not appear:

Once you tap on Wi-Fi, you get this page (I’ve temporarily disabled mine in order to hide the available network names):

My WiFi switch is on, but I don’t see the Wi-Fi entry in the Settings menu. The first entry is Network, then Mobile then Bluetooth.

This seems like a hardware problem.

And it’s strange that BT is there, but not WiFi, since they’re both controlled by the same hardware switch.
Probably time to email:

Alright. Thanks a lot for the help!

1 Like

I don’t know if you saw this thread, but it might be related:

…or maybe not, since you’ve completely reflashed to Byzantium. Everything should be nice and fresh.

EDIT: Are you able to see WiFi from within the Advanced Network Connections app? See here.

If so, can you create a connection to your network?

1 Like

This issue may not be what I have with my Librem 5, but sometimes after booting/rebooting, the Wi-Fi won’t be available (even though my hardware switch is definitely on). If I turn the hardware switch off, wait for 20-30 seconds, then switch it back on, most often the Wi-Fi will be available again until another reboot.


From what to what? amber to amber? byzantium to byzantium? amber to byzantium? something else?

Was WiFi working before you reflashed?

I doubt it.

No, but it may be appropriate to contact

It could be a firmware issue.


Thanks. I tried that but it didn’t work for me.

1 Like

I hadn’t used the phone for many months and started using it again yesterday. I did not check the previous version before flashing, but it was probably amber. I flashed byzantium now. WiFi was not working before I reflashed.

Support is helping me out. Thanks!

1 Like

Nope. That app does not show WiFi either. Just Ethernet.

To close this thread, I contacted Purism support and after a few exchanges which involved me sending phone logs, they concluded the WiFi card was broken and sent me a replacement. WiFi and Bluetooth work as expected with the new card installed.


Not so fast.

I just today got my Librem 5 USA…and I cannot set the time on it.

I have no wifi. I know that. That’s not the complaint.

The problem is the app to set the time is simply not useful. I can’t figure out how to tell it to accept the setting I just input, and backing out with < simply causes what I did to be ignored. Even if it does seem to take, it gets thrown away before I can (or as I actually) exit the main settings screen. Where the heck is the OK or Apply button?

1 Like

It should apply and stick on exit. Instead of using the < button after you adjust the time, minimize the screen (tap the “housetop” icon under the display), then swipe the dialog box up to dismiss it. See if that helps.

If you have a SIM card, inserting that and using “automatic” on the date/time should set it for you.

1 Like

I don’t have automatic available. That’s not the point. The doggone thing should let me set the time if it’s going to pretend to offer the option.

And what you said about swiping upwards doesn’t work either.

Setting the time is a popup over the time page, so both a little picture of the popup and the main time page show up in the “swipe up” area. Swiping those away doesn’t change the phone’s time.

Honestly, why does a user have to play guessing games like this? Is someone too lazy to put in an Apply button?

Another “thing” that needs to be ensured is: Settings -> Mobile -> Mobile Data = ON. In addition, please type inside Terminal app:
date --utc
sudo apt update
TZ=GMT date

You might also use timedatectl command (if chosen so):

No you’re missing the point.

The software has a bug. There is this “option” (that appears to be either broken, or written with a non-obvious method of applying changes) to set the date WITHOUT any sort of connectivity. It’s broken. I’m NOT asking how to turn on connectivity, I’m asking how to set the clock without connectivity.


I would agree. Please see: “Set the time manually”. Refer to the following as well:
sudo hwclock --show
sudo hwclock --help

setting the time with sudo date works…until I restart the phone. It’s obviously getting a wrong time from some piece of hardware at bootup.

sudo hwclock --show gives me an error message: “hwclock: ioctl(RTC_RD_TIME) to /dev/rtc0 to read the time failed: invalid argument” (Also applies if I don’t do --show). This command works on my ubuntu desktop.

As an aside, now that I have the phone at home, it turns out the wifi is actually broken (though bluetooth apparently is functional).

I’m sorry to hear that, yet I do not get any kind of error on my Librem 5, when here related command used.

EDIT: Is this one working on your phone:
sudo hwclock --systohc --update-drift --verbose?

How about:
sudo dmesg | grep rtc-m41t80?