Not able to change audio profile of bluetooth headset device

I managed to use the Bluetooth adapter in my librem 15v3.
Following the workaround in this thread:

So now I wanted to connect a bluetooth headset. Basically connecting works, but only with a simple sound profile where the quality is way to bad can be used. “Headset Head Unit (HSP/HFP)”

I try to switch to a profile with a higher quality in the lower area, but this does not really work (it only worked once after installing the bluetooth driver). “High Fidelity Playback (A2DP Sink)”

When I use another application like blueman (Bluetooth Manager) I see the error massage “Failed to change profile to a2dp_sink” in the lower area when I try to switch the profile there.

So I’m wondering if there is a possibility to analyze or fix this.

Thanks for any idea in advance.

You can try to re-add device. It may be that you paired device while it was in HFP mode so it didn’t advertise A2DP. Also in blueman i think there’s an option ‘rediscover services’ or something like that.
Finally I’d go to bluetoothctl and do first -
info <MAC>
there should be
UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb)
line in services. And then just do
connect <MAC>
and see what it gives. If it’s simple connected/disconnected - i’d look into PA. Use
pactl list modules short
and look for module-bluez5-discover. If it’s there - try
pactl unload-module module-bluez5-discover; pactl load-module module-bluez5-discover
connect <MAC>

I tried to reconnect using bluetoothctl only:

remove <Headset_MAC>
scan on
pair <Headset_MAC>
connect <Headset_MAC>

[<Device_Name>]# connect <Headset_MAC>
Attempting to connect to <Headset_MAC>
Failed to connect: org.bluez.Error.Failed
[CHG] Device <Headset_MAC> ServicesResolved: no

So it seems to be some kind of issue related to bluez.

pactl gives:

pactl list modules short
No protocol specified
xcb_connection_has_error() returned true
Connection failure: Connection refused
pa_context_connect() failed: Connection refused