No bluetooth in new Librem 15 v3

I finished installation on a new Librem 15. Everything seems to work now except bluetooth. The wifi/bluetooth switch is on, and wifi works, but it doesn’t seem to even recognize that it has bluetooth. The appropriate settings dialog says:

No Bluetooth Found

Plug in a dongle to use Bluetooth

Any help would be appreciated. Thanks!

The situation, unless something has changed, is that the 15v3 has all the hardware necessary for Bluetooth, but doesn’t ship with drivers because FOSS drivers don’t exist yet.

in order to help fix this problem, Purism is, last i checked, trying to hire a developer to make these drivers.

If you want Bluetooth and don’t care about the drivers being trustworthy and open, you can just install proprietary binary drivers. I’m not sure which, someone will chime in.

Ok, good to know. I’ll look into that. Thanks!

You need a proprietary firmware:

More info:

Yep, that did it. It took me a few minutes to realize that I’d also disabled Bluetooth with the Fn+F12 button when I was trying to figure it out initially. Once I turned it back on, though, it worked just fine. Thanks again

1 Like

I just followed your instructions and bluetooth worked fine afterwards. But I realized that mac address spoofing of the Wifi card did not work any more. So since I prefer spoofing my mac address over bluetooth, I purged the atheros firmware afterwards.

The strange thing is: bluetooth is still working and mac address spoofing is still disabled. The firmware package is removed, so

dpkg -l 

does not list it any more. How can that be possible?

I received my Librem 15 on Friday and am trying to get Bluetooth working.

I followed these instructions and it is still greyed out in the settings window.

the package is definitely installed:

I would be grateful for further suggestions.

Might want to make sure bluetooth isn’t turned off with either the wireless switch, or the Fn+F12 button. I did the latter myself

I tried that of course to no avail but then I tried it again and after a significant pause my BT started working and is fine now.

I would like to ask if the Librem 15 laptop, version 4, has the bluetooth working right out of the box. Can anyone confirm this?

short answer is no.

Long answer is same as above for the v3 models, since using the same wifi/BT module. There’s no open-source BT firmware, and since PureOS doesn’t ship proprietary firmware, you need to enable the non-free repo to make use of BT.

This is something we’re actively working to remedy though.


I appreciate the quick response. I read something online today that Atheros has gone somewhat “Open Source”, back in August 2018.

I saw they had released some sort of non-proprietary driver for their wireless devices.

If that is not true, or they have not been installed into PureOS as of yet, I will use the work around as currently prescribed…once I purchase a new Librem 15 v4.



Hello, i am new in this forum and i have the same Problem with the Bluetooth. I have a Librem 15V3 with German keyboard. I was able to install

sudo apt-get install firmware-


but it doesn’t work.
would be nice if someone could help me what the problem is.

Greetings Mari9

You will not be able to enable Bluetooth unless you add non-free repositories and then install the non-free firmware from there. The Wifi/Bluetooth card used in the Librem laptops does not have a libre/open-source driver for Bluetooth.

See this post if you want instructions for how to do that:

1 Like

Thank you for your help. Now i am able to find the source. I run the update. But now i get this.

sudo apt install firmware-atheros
E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

should i Deinstall this firmware. It might help.


Hmm, I usually only see that error message if there is another process (like the Software center) searching for or installing updates at the same time, or if I forgot sudo.

Can you just try again after making sure you don’t have the Software app doing anything?

Reading state information… Done
firmware-atheros is already the newest version (20190114-2).

firmware-linux-free is already the newest version (3.4).
The following packages were automatically installed and are no longer required:

now i have installed atheros and linux-free

i made a restart but it still says No Bluetooth Found.
do i have to change back the source so i don’t get upgrades from a different source ?

Another option is a cheap (< $10) dongle.Yes it’s slightly annoying and uses one of your USB ports, but it’s very low profile, works well, and doesn’t require putting non open-source drivers on your computer.

Hmm, strange. I guess it may be worth uninstalling the previous firmware packages you installed.

sudo apt remove firmware-ath9k-htc firmware-ath9k-htc-dbgsym firmware-linux-free