Notes from the updates [running commentary on small things]

This is just a standard Debian package needrestart. You must have installed it at some point, it’s not installed by default.

The dialog can be interacted with using the OSK just fine, by the way, although it’s not exactly the most convenient thing to use indeed. All the needed keys are available there.

Interesting, I hadn’t noticed I had (intentionally [seems to have been with docker]). Good to know. Will edit the previous post. It did seem like a development towards more informative update how ever, hence the though it was an intended development of PureOS.

Noticed for phosh/phoc there is no emergency contact and emergency contact cannot be saved. Probably known issue?

Also makes me wonder why there is a emergency contact UI separate from Gnome Contacts, wouldnt it have been easier to just add a checkmark that classifies a Gnome Contact as an emergency contact, or a dropdown alteration for phone number where user could select “Emergency” instead of “Home” …

Thanks I created the folder, and the emergency contact did not save still, however when adding your personal info in like name, then it saved. When selecting the emergency call button the emergency contact previously added is still not listed though. So will have to wait until Phosh/Phoc 0.29 to see if that fixes things.

1 Like

I don’t think that it is supposed to read the emergency contacts… Yet.

Thanks that explains the custom emergency contact not showing, additionally for me there are no emergency numbers shown, or imported from SIM, like 911 - nothing is shown.


FYI in case others search here.
Docked into the Hoyoki hub, and doing updates/upgrades I need to click the do it icon, restart, and though it states, ‘restarting’, it sits a long time (passing the decryption(?) is on because the background on the L5 is not pitch black. After 2 minutes, it shut down (power off). I pressANDhold the Power button, is when I get a blank screen with [OSK] which I click and the keyboard shows up. Enter numeric password, then Settings > Displays > and punch in the data and hit Apply and am back to where I left.

I envision a faster way when docked. For me, SSH is not one of them. I’m OK with the process as it is but sure that faster is on the back burner for now.

Requires frequent page refresh of Firefox and other apps.

There appears to be an issue with:
1.establishing mobile data connection,
2. re-establishing mobile data connection

Symptoms are really slow Pure OS flatpak app installs(socket I/O timeout erros - basically doesnt work), websites that do not load until you refresh ~3-5 times on average.

4G and OpenVPN appear connected, toggling HKS appears to establish connection to openVPN, while symptoms still happen. Electron apps appear to be less impacted somehow, once streaming is established there are basically no interruptions of video stream 720p 30fps.

Mobile Setting has a new tab called Sensors. Sensor readings (in human understandable values) and some contrast settings.

1 Like

Swipe down from the top edge and take a look at the volume slider. See the little arrow next to it? A quick drop down list of outputs and inputs.

1 Like

Ooh! Nice!

since last updates as of Dec 30th stock Byzantium encrypted image:

  1. volume button is not repeating anymore
  2. (fixed by deleting profile, using system proxy) firefox ESR seems broken, wont load pages at times, tls handshake errors etc
  3. phone connections freeze mobile and wifi, has to be force restarted with unkown applications running and stopping restart
  4. (reported before still exists) mobile data connection dropping even though it shows connected is worse than it was before
  5. camera does not save images any longer, some permission issue with the Pictures folder possibly

I have noticed this too. This morning I needed three reboots before I could use the phone normally.

Probably needs an actual error message.

It is sometimes easier to diagnose such problems with e.g. wget or at the very least you would see whether you get an error at all from the command line using the same URL as gave a problem in Firefox.

For me, I think this happens mostly after connecting my phone to a laptop dock. Sometimes connections continue to work, but mostly not. Wifi and mobile show as connected, but I can’t toggle these from the pull down menu in phosh nor through the HW kill switches. A force reboot seems to be the only thing that helps.

1 Like

since last update including kernel:

Linux pureos 6.6.0-1-librem5 #1

The phone seems to have gotten less stable:

  1. sometimes freezes and does not accept touch input
  2. sometimes when that happens and you perform a hard reboot phone freezes on OSK phosh login screen, LUKS screen still works fine
  3. shell sometimes crashes and restarts, especially when toggling mobile data after first reboot
  4. sometimes after wake from suspend in chatty text input is halting and slow while online
  5. previously reported but might have gotten worse toggling HKS for wifi/bluetooth isnt registered properly in the phosh and indicators do not disappear or reappear correctly

I confirm this. This is why I started this thread: Stability, oopses, and traces of the Librem 5 - statistics and details
And maybe, because I had to reboot so often by long pressing the power button, this indirectly also contributed to a corrupted file system on the boot partition. But the instability might also be related to this:
Can't turn on after latest update (kernel), no response to touch input, USB keyboard not working - #16 by janvlug


thanks for reporting these can confirm all of those issues and plugging in usb charging cable sometimes causing these. Same cable and charger used previously that worked without issues.


On ubuntu i can simply install and use a different kernel if the one installed doesnt work using grub. I wonder if the previous kernel for L5 can be downloaded and installed (kernel with all patches applied)

1 Like