Notes from the updates [running commentary on small things]

Thanks that explains the custom emergency contact not showing, additionally for me there are no emergency numbers shown, or imported from SIM, like 911 - nothing is shown.

2 Likes

FYI in case others search here.
Docked into the Hoyoki hub, and doing updates/upgrades I need to click the do it icon, restart, and though it states, ‘restarting’, it sits a long time (passing the decryption(?) is on because the background on the L5 is not pitch black. After 2 minutes, it shut down (power off). I pressANDhold the Power button, is when I get a blank screen with [OSK] which I click and the keyboard shows up. Enter numeric password, then Settings > Displays > and punch in the data and hit Apply and am back to where I left.

I envision a faster way when docked. For me, SSH is not one of them. I’m OK with the process as it is but sure that faster is on the back burner for now.
~s

Requires frequent page refresh of Firefox and other apps.

There appears to be an issue with:
1.establishing mobile data connection,
2. re-establishing mobile data connection

Symptoms are really slow Pure OS flatpak app installs(socket I/O timeout erros - basically doesnt work), websites that do not load until you refresh ~3-5 times on average.

4G and OpenVPN appear connected, toggling HKS appears to establish connection to openVPN, while symptoms still happen. Electron apps appear to be less impacted somehow, once streaming is established there are basically no interruptions of video stream 720p 30fps.

Mobile Setting has a new tab called Sensors. Sensor readings (in human understandable values) and some contrast settings.

1 Like

Swipe down from the top edge and take a look at the volume slider. See the little arrow next to it? A quick drop down list of outputs and inputs.

1 Like

Ooh! Nice!

since last updates as of Dec 30th stock Byzantium encrypted image:

  1. volume button is not repeating anymore
  2. (fixed by deleting profile, using system proxy) firefox ESR seems broken, wont load pages at times, tls handshake errors etc
  3. phone connections freeze mobile and wifi, has to be force restarted with unkown applications running and stopping restart
  4. (reported before still exists) mobile data connection dropping even though it shows connected is worse than it was before
  5. camera does not save images any longer, some permission issue with the Pictures folder possibly

I have noticed this too. This morning I needed three reboots before I could use the phone normally.

Probably needs an actual error message.

It is sometimes easier to diagnose such problems with e.g. wget or at the very least you would see whether you get an error at all from the command line using the same URL as gave a problem in Firefox.

For me, I think this happens mostly after connecting my phone to a laptop dock. Sometimes connections continue to work, but mostly not. Wifi and mobile show as connected, but I can’t toggle these from the pull down menu in phosh nor through the HW kill switches. A force reboot seems to be the only thing that helps.

1 Like

since last update including kernel:

Linux pureos 6.6.0-1-librem5 #1

The phone seems to have gotten less stable:

  1. sometimes freezes and does not accept touch input
  2. sometimes when that happens and you perform a hard reboot phone freezes on OSK phosh login screen, LUKS screen still works fine
  3. shell sometimes crashes and restarts, especially when toggling mobile data after first reboot
  4. sometimes after wake from suspend in chatty text input is halting and slow while online
  5. previously reported but might have gotten worse toggling HKS for wifi/bluetooth isnt registered properly in the phosh and indicators do not disappear or reappear correctly
5 Likes

I confirm this. This is why I started this thread: Stability, oopses, and traces of the Librem 5 - statistics and details
And maybe, because I had to reboot so often by long pressing the power button, this indirectly also contributed to a corrupted file system on the boot partition. But the instability might also be related to this:
Can't turn on after latest update (kernel), no response to touch input, USB keyboard not working - #16 by janvlug

2 Likes

thanks for reporting these can confirm all of those issues and plugging in usb charging cable sometimes causing these. Same cable and charger used previously that worked without issues.

3 Likes

On ubuntu i can simply install and use a different kernel if the one installed doesnt work using grub. I wonder if the previous kernel for L5 can be downloaded and installed (kernel with all patches applied)

1 Like

Maybe just revert to a recent backup?

1 Like

If your phone still has a previous kernel that worked better then you can select it using flash-kernel but having a backup before doing that is a good idea.

1 Like

Tried:

aptitude search linux-image

Linux pureos 6.6.0-1-librem5 #1 SMP PREEMPT Tue Mar 19 03:54:14 EDT 2024 aarch64 GNU/Linux p linux-image-5.10.0-27-arm64 - Linux 5.10 for 64-bit ARMv8 machines (signed) p linux-image-5.10.0-27-cloud-arm64 - Linux 5.10 for arm64 cloud (signed) p linux-image-5.10.0-27-rt-arm64 - Linux 5.10 for 64-bit ARMv8 machines, PREEMPT_RT (signed) p linux-image-5.10.0-28-arm64 - Linux 5.10 for 64-bit ARMv8 machines (signed) p linux-image-5.10.0-28-arm64-dbg - Debug symbols for linux-image-5.10.0-28-arm64 p linux-image-5.10.0-28-arm64-unsigned - Linux 5.10 for 64-bit ARMv8 machines p linux-image-5.10.0-28-cloud-arm64 - Linux 5.10 for arm64 cloud (signed) p linux-image-5.10.0-28-cloud-arm64-dbg - Debug symbols for linux-image-5.10.0-28-cloud-arm64 p linux-image-5.10.0-28-cloud-arm64-unsigned - Linux 5.10 for arm64 cloud p linux-image-5.10.0-28-rt-arm64 - Linux 5.10 for 64-bit ARMv8 machines, PREEMPT_RT (signed) p linux-image-5.10.0-28-rt-arm64-dbg - Debug symbols for linux-image-5.10.0-28-rt-arm64 p linux-image-5.10.0-28-rt-arm64-unsigned - Linux 5.10 for 64-bit ARMv8 machines, PREEMPT_RT p linux-image-6.1.0-0.deb11.13-arm64 - Linux 6.1 for 64-bit ARMv8 machines (signed) p linux-image-6.1.0-0.deb11.13-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.13-arm64 p linux-image-6.1.0-0.deb11.13-arm64-unsigned - Linux 6.1 for 64-bit ARMv8 machines p linux-image-6.1.0-0.deb11.13-cloud-arm64 - Linux 6.1 for arm64 cloud (signed) p linux-image-6.1.0-0.deb11.13-cloud-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.13-cloud-arm64 p linux-image-6.1.0-0.deb11.13-cloud-arm64-unsigned - Linux 6.1 for arm64 cloud p linux-image-6.1.0-0.deb11.13-rt-arm64 - Linux 6.1 for 64-bit ARMv8 machines, PREEMPT_RT (signed) p linux-image-6.1.0-0.deb11.13-rt-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.13-rt-arm64 p linux-image-6.1.0-0.deb11.13-rt-arm64-unsigned - Linux 6.1 for 64-bit ARMv8 machines, PREEMPT_RT p linux-image-6.1.0-0.deb11.17-arm64 - Linux 6.1 for 64-bit ARMv8 machines (signed) p linux-image-6.1.0-0.deb11.17-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.17-arm64 p linux-image-6.1.0-0.deb11.17-arm64-unsigned - Linux 6.1 for 64-bit ARMv8 machines p linux-image-6.1.0-0.deb11.17-cloud-arm64 - Linux 6.1 for arm64 cloud (signed) p linux-image-6.1.0-0.deb11.17-cloud-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.17-cloud-arm64 p linux-image-6.1.0-0.deb11.17-cloud-arm64-unsigned - Linux 6.1 for arm64 cloud p linux-image-6.1.0-0.deb11.17-rt-arm64 - Linux 6.1 for 64-bit ARMv8 machines, PREEMPT_RT (signed) p linux-image-6.1.0-0.deb11.17-rt-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.17-rt-arm64 p linux-image-6.1.0-0.deb11.17-rt-arm64-unsigned - Linux 6.1 for 64-bit ARMv8 machines, PREEMPT_RT p linux-image-6.1.0-0.deb11.18-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.18-arm64 p linux-image-6.1.0-0.deb11.18-arm64-unsigned - Linux 6.1 for 64-bit ARMv8 machines p linux-image-6.1.0-0.deb11.18-cloud-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.18-cloud-arm64 p linux-image-6.1.0-0.deb11.18-cloud-arm64-unsigned - Linux 6.1 for arm64 cloud p linux-image-6.1.0-0.deb11.18-rt-arm64-dbg - Debug symbols for linux-image-6.1.0-0.deb11.18-rt-arm64 p linux-image-6.1.0-0.deb11.18-rt-arm64-unsigned - Linux 6.1 for 64-bit ARMv8 machines, PREEMPT_RT c linux-image-6.1.0-1-librem5 - c linux-image-6.2.0-1-librem5 - Linux 6.2 for the Librem 5 and its devkit p linux-image-6.3.0-1-librem5 - Linux 6.3 for the Librem 5 and its devkit p linux-image-6.3.0-1-librem5-dbg - Linux kernel debugging symbols for librem5 i A linux-image-6.5.0-1-librem5 - Linux 6.5 for the Librem 5 and its devkit i A linux-image-6.6.0-1-librem5 - Linux 6.6 for the Librem 5 and its devkit p linux-image-6.6.0-1-librem5-dbg - Linux kernel debugging symbols for librem5 p linux-image-arm64 - Linux for 64-bit ARMv8 machines (meta-package) p linux-image-arm64-dbg - Debugging symbols for Linux arm64 configuration (meta-package) p linux-image-arm64-signed-template - Template for signed linux-image packages for arm64 p linux-image-cloud-arm64 - Linux for arm64 cloud (meta-package) p linux-image-cloud-arm64-dbg - Debugging symbols for Linux cloud-arm64 configuration (meta-package) v linux-image-generic - i linux-image-librem5 - Linux kernel for the Librem 5 and its devkit p linux-image-rt-arm64 - Linux for 64-bit ARMv8 machines (meta-package) p linux-image-rt-arm64-dbg - Debugging symbols for Linux rt-arm64 configuration (meta-package)

aptitude reinstall linux-image-6.5.0-1-librem5

But it cant find the package which is odd.

Also:

sudo flash-kernel linux-image-6.5.0-1-librem5

cant find the files. Also where are the required headers that need install? It says it is installed. Currently searching for the folder where it is hiding.

1 Like

Since the latest linux-image -32 update my librem 5 has experienced the following occasional issues:

  1. after wake from suspend mobile data and wifi locked and cannot enable or disable through hardware kill switches
  2. phone has occasionally rebooted for no known reason
  3. there are occasional graphics rendering issues shown as green striped rendering in free tube when showing the app panels
  4. GPS has sortof started to work again, but you have to coax it to start tracking when using puremaps
2 Likes

Are you suggesting GPS did not work well with the previous kernel version?

1 Like

yes i mean it didnt work at all not just not well, now since the update it sortof works but does not refresh update location frequently enough
6.6.0-1-librem5 is running currently not sure what version it was before

firefox touch is lost at times, ungoogled chrome under wayland rendering doesnt work correctly

1 Like