Open pages files in libre office

I have used libre office on microsoft, iOS and pureOS.
When I run it on iOS it opens apple pages documents just fine. In PureOS I have that option, too but it opens the pages document incomplete. The text is there, but photos in the document are only shown as a place holder.

How can I “import” my old apple pages documents correctly?

Have you tried installing libetonyek?:
sudo apt install libetonyek

If that isn’t the problem, then maybe you are using an image format that needs a library that you can to install.

Another idea is to convert your .pages files to .docx and then import them into LibreOffice. There are many zero-cost websites to do that:


Depending on your definition of “zero cost”?

Unless the document is intended for making public anyway e.g. on the web, I won’t be uploading my documents to a random web site.


I tried the install but libetonyek was not found:
E: Unable to locate package libetonyek

1 Like

Sounds about right. It’s much better to use the Synaptic Package Manager to handle these sorts of things. So without further adu, here’s how to solve your problem:

#1. Install the Synaptic Package Manager from the Software Store that comes with PureOS. This is as easy as opening the Store application, clicking the magnifying glass in the upper left-hand side of the window, and typing “Synaptic Package Manager” in the search bar that appears. Installing the package manager is as easy as clicking the big blue Install button on the Synaptic store page.

#2. Once Synaptic Package Manager is installed, the world of Linux is at your finger tips. Open the Synaptic Package Manager, and from the buttons located at the bottom-left side of the screen, select the “Status” button (circled in red). Once there, select the “Not Installed” category from the list of categories, and scroll down to “libetonyek” in this category. There should be two packages available for install: “libetonyek-dev” and “libetonyek-tools”. Click the checkmark boxes next to both of these. Once you’ve completed this process, click the “Apply” button (also circled in red) and follow any prompts/confirmation boxes to complete the install:

As you can see, the Synaptic Package Manager makes everything easier. :slightly_smiling_face: Let me know if you need anymore help.

Oh, I just realized that the suggestions in this thread might not work because Apple Pages might be treating the inserted images as “links”, and what you’re seeing in the final document is simply a preview (though I still highly recommend you install the Synaptic Package Manager because it’s a really useful tool to have installed.)

Let me expound. When you insert an image in Apple Pages, what’s really being inserted is a link; say C:\Users\Ralf\Photos\prettypicture.png (yes I know that’s the Windows filesystem, but bear with my hypothetical; I don’t know the Mac filesystem). The photo in the document is nothing more than a preview: it isn’t actually inserted as a physical photo. So when you transfer the document to PureOS, the link is broken because not only do you have an entirely different filesystem, you also don’t have the original photos stored on your PureOS harddrive.

So if my “broken link” theory is true, then the only way you’ll be able to fix this problem is by deleting the placeholder images, and reinserting the original photos back into the document on the PureOS computer.

[Why I think this way: This is how resource management works in Microsoft PowerPoint (using “links” instead of actually inserting resources).]

There is a libetonyek package in both Amber and Byzantium. Update the package list and then try to install:
sudo apt update
sudo apt install libetonyek

If that doesn’t work, then post your sources list, because it isn’t configured correctly:
cat /etc/apt/sources.list
cat /etc/apt/sources.list.d/*

or at least apt search libetonyek

(I just worked out that this is lib + keynote backwards.)

For me on Ubuntu that gives

libetonyek-0.1-1/impish,now 0.1.10-1build1 amd64 [installed,automatic]
  library for reading and converting Apple Keynote presentations

libetonyek-dev/impish 0.1.10-1build1 amd64
  library for reading and converting Apple Keynote presentations

libetonyek-tools/impish 0.1.10-1build1 amd64
  library for reading and converting Apple Keynote presentations -- tools
1 Like

@amosbatto, your kind advice and hopefully solution should work, therefore just slight correction from my side, as @irvinewade explained above, it looks like (while using Debian at this moment) that the package is (under PureOS) called libetonyek-0.1-1:
sudo apt search libetonyek-0.1-1
sudo apt install libetonyek-0.1-1

P.S. libetonyek-tools package is available as well (will pull/include libetonyek-0.1-1).

1 Like

I mean, this is all based on the assumption that Apple Pages doesn’t just use links and previews. For all we know, installing the libetonyek libraries won’t actually work (which it shouldn’t if links and previews are indeed the methodology used). That still needs to be confirmed.



Certainly not something that I can or want to confirm but … links could still work correctly

  • if they must be or are relative - and relative is limited to “same directory”
  • if they must be or are relative - and relative uses a syntax that is independent of the native file system (e.g. like URLs, always using / even when the native file system uses \ or : as path element delimiter)

Of course in those scenarios it would still be necessary to copy the underlying images over.

Installing libetonyek did not make any difference.
I executed apt search libetonyek - and it showed me three different libetonyek packages installed.

Apple pages documents are saved as a folder system. Within that folder system are all files, including photos. To transfer a pages document from one computer to another one has to first zip it to get everything belonging to the document. I have two of those zipped documents on my PureOS hard drive, but none opens correctly in libre office.
But when I dive into the folders, I can find all the photos/pictures the document should contain.
Therefore I am concluding, that something is not working when libre office runs in PureOS and thus prevents it from correctly opening pages documents.

For fault isolation then … does it work correctly when you run LibreOffice under Microsoft Windows on the same document?

Additionally, can you test LibreOffice under a different Linux distro? (In other words, is there something wrong that is specific to PureOS or is it generically wrong under Linux?)

Apparently a .pages file is just a .zip file (as is .docx, as is .odt), so if you are sufficiently technical, you may be able to look into the question that @Jack_Sparrow raises above as to how the images are referenced.

Is any of the content non-confidential so that you can make it available on the internet for someone else to have a look at? If not, can you make a small example one page .pages document that demonstrates the problem and make that available on the internet?

Really this just illustrates why proprietary formats are evil, and how they serve to lock you in.


I’m no expert but still think that your current reasoning won’t help anyone if mentioned files aren’t unzipped to .pages file as LibreOffice should be able to import some .pages documents:

Otherwise only file that you’ll be able to see as “useful”, after unpacking those two archives (referring here to your two particular .pages archives), is preview.jpg file:

What I’m about to learn here, it is the main package required, as @amosbatto kindly recommended to check out if present (don’t think that usage of this package is correlated to PureOS install or setup), while without package installed my above post proposal, related to “import” of .pages document into LibreOffice, won’t work either.

As said above I can open the pages document running libre office under iOS and also Microsoft. I don’t know exactly how pages references the photos. But as said above I can find them inside the pages document folder.
I would sure upload a document but the forum does not allow documents.

1 Like

There is no need to upload your files, please download “attachment 162231” and test it for your purpose (I do not have some extra time, sorry). Perhaps downloading of libetonyek-0.1-1 in recent version 0.1.10-3 might help with: sudo dpkg -i libetonyek-0.1-1_0.1.10-3_amd64.deb, or even instaling/upgrading to the higher version of LibreOffice through bullseye-backports might help as well.

I am running

apt search libetonyek
Sorting… Done
Full Text Search… Done
libetonyek-0.1-1/byzantium,now 0.1.9-4 amd64 [installed,automatic]
library for reading and converting Apple Keynote presentations

libetonyek-dev/byzantium,now 0.1.9-4 amd64 [installed]
library for reading and converting Apple Keynote presentations

libetonyek-tools/byzantium,now 0.1.9-4 amd64 [installed]
library for reading and converting Apple Keynote presentations – tools



sudo apt list libreoffice-core -a
Listing… Done
libreoffice-core/bullseye-backports 1:7.2.5-1~bpo11+1 amd64
libreoffice-core/stable,stable-security,now 1:7.0.4-4+deb11u1 amd64 [installed,automatic]
libreoffice-core/oldstable 1:6.1.5-3+deb10u4 amd64

@Ralf, as explained (and as I hoped) within my above post, conversion of linked .pages file worked for me after:

I tried downloading but apparently didn’t get the right file. Too many choices.

ing database … 147705 files and directories currently installed.)
Preparing to unpack libetonyek-0.1-1_0.1.10-3_amd64.deb …
Unpacking libetonyek-0.1-1:amd64 (0.1.10-3) over (0.1.9-4) …
dpkg: dependency problems prevent configuration of libetonyek-0.1-1:amd64:
libetonyek-0.1-1:amd64 depends on libc6 (>= 2.32); however:
Version of libc6:amd64 on system is 2.31-13.
libetonyek-0.1-1:amd64 depends on libstdc++6 (>= 11); however:
Version of libstdc++6:amd64 on system is 10.2.1-6.

dpkg: error processing package libetonyek-0.1-1:amd64 (–install):
dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.31-13) …
Errors were encountered while processing:

1 Like