Post-Flash Blues: Cannot send Pics W/ Chat (still)

No. I straightened it out - (answered in post # 93, 94, or 95 in " Can’t figure out reflashing librem 5" - it can’t tell either at

:sweat_smile: :rofl: :joy:

UPDATE: @amarok
In System > Mobile > Network > and making a change or not, and select “Set”, I am met with a grey error on dark grey that drops down from the top. It is wider than the screen, therefore left and right are cut, and in horizontal, won’t scroll down so I can see all of the error.
Too, the error is onscreen for only about 6 seconds. I suspect that it can be ignored.

If there is a way to video the screen to capture the error, maybe I can freeze it and get the centre of it? BTY, I did try a screen-cap but unable to get it to capture the meant the error is onscreen.

This is silly. It worked before the flash, and everything is set the exact same way before the flash. Chat needs surgery, it’s refusing to delete text, or texts /w pic. And it shows the most recent text sent any where in between other texts. Not alpha, numerical, or date/time.

Maybe flash it again?

1 Like

I’m not sure what’s going on with your Chats issues. Maybe @JCS can advise how to best get support.

In the BM818 Tool (VoLTE) app, does the firmware version indicate a date of ...20220930... (or later)? If not, although it might not have any bearing on the messaging app, you will need to upgrade it in order to get VoLTE working. Purism Support can tell you how to do that. [EDIT: I see you answered that in another post.]

It might fix things, but no guarantees. It’s probably worth trying.

1 Like

When flashing, it is hard to tell if it just quit to command prompt, or was done. A Flash Completed - Success or something to indicate it finished would be nice…

BTW - going to JCS to get to support is another Been There, Done That.

I installed “Dino” thinking it would replace Chat. Now there’s no way to save space by removing it. I didn’t sign up on Dino. Installing anything should come with a Caveat that once it’s on, there’s only one way to get rid of it - flash.

Off to flash for 4th :face_with_symbols_over_mouth: time.

I take it you don’t know what or how I can capture the error mentioned in the above under “Update @amorok”? Perhaps knowing what the error is, might lead to the naughty Chat.

1 Like

You posted here that it did finish successfully: Time to flash is now - but how? - #134 by Sharon

1 Like

I sincerely apologize for believing in, and posting the L5 results displayed by the flash/device. Sorry.

1 Like

I’ve tested this one, once upon a time: List of Apps that fit and function well [Post them here.] - #260 by amarok

Or use a second camera if you have one.


1 Like

I’ve never (nor had to, despite the transition from TMO->ATT backhaul networks via AweSIM) had to touch anything within Settings > Mobile > Network > Network. I don’t know of anyone that has gone this route, so I don’t think this is what you want to do.

I have no experience with Koodo, but typically you only have to adjust the APN and sometimes Network Mode (4G Only in the case of AweSIM).

Chats? I knew you can delete entire message threads, but I wasn’t even aware that deleting individual texts was supported. Is this what you mean?

Strange. Chatty just reads the metadata and payload from ModemManager and dumps it into the database. Are chats continually being misplaced, or does it seem like a temporary glitch?

I’m sorry, I have a mountain of responsibilities outside of the forums and I’m not always timely at checking my notifications or ensuring that messages don’t fall on the floor. Is there something you’d asked me where I never addressed?

1 Like

No. I meant it’s not deleting anything. I have discovered it’s worse than that. Chat stores sent/received texts wherever in the list it feels like. There is no longer any sense in how they are listed. A new text comes in, and I have to scroll up and down looking for it.

Chat Details opens Group, not details.

Can only send/receive texts.

Last ditch effort to fix everything by flashing - again - results in no more pics w/ texts. Texts are out of order - a new text today might be anywhere. Rebooting and they are mixed up again.

When I do a Power > Power Off > Power Off, it goes to a black screen with “LIBREM” and stays that way. I have to hold the switch in for a few seconds to shut it down.

The mobile settings and Chat that worked are exactly what they were before the flash that was working before flash. And the same settings won’t send pics.

I am going to re-do the flash, again via desktop to L5. But before I got started again, I checked the last flash log and found a lot of errors at the start.
I’ll log out with this desktop and go to the PureOS desktop,. log in again, and copy the errors to here.

Is there supposed to be a note of some sort that when Flash is done, announcing that it’s done? Or does it just end with 3 empty command lines?

No. As I mentioned, you guys are very busy as it is and I don’t expect any answers soon. I did ask how much it might cost to send the L5 back, someone vapes everything and re-installs the OS (back to factory settings - so to speak).

I’m sure a reply will be coming soon. Now I’ll get those error lines for you or whomever wants to read and analyze it.

Back in a few minutes w/ the errors.

Copy of the startup w/ errors:

bin			  LANShareDownloads    RECOVER-PC
data			  librem5-flash-image  teamviewer_amd64.deb
deb_Amber_inSources-list  Music		       Templates
Desktop			  opt		       Tviewer
Documents		  Pictures	       Videos
Downloads		  Public	       Wiremin\ sintall\ extyractas
pure1@pure-pc:~$ cd ..
pure1@pure-pc:/home$ dir
pure1@pure-pc:/home$ cd\
> dir
WARNING:root:could not open file '/etc/apt/sources.list'

Could not find the database of available applications, run update-command-not-found as root to fix this
Sorry, command-not-found has crashed! Please file a bug report at:
Please include the following information with the report:

command-not-found version: 0.3
Python version: 3.7.3 final 0
Distributor ID:	PureOS
Description:	PureOS
Release:	9.0
Codename:	amber
Exception information:

local variable 'cnf' referenced before assignment
Traceback (most recent call last):
  File "/usr/share/command-not-found/CommandNotFound/", line 23, in crash_guard
  File "/usr/lib/command-not-found", line 93, in main
    if not cnf.advise(args[0], options.ignore_installed) and not options.no_failure_msg:
UnboundLocalError: local variable 'cnf' referenced before assignment
pure1@pure-pc:/home$ dir

and ended with:

Running hooks in /etc/ca-certificates/update.d...
Processing triggers for libvlc-bin:amd64 (3.0.20-0+deb11u1) ...
Processing triggers for dbus (1.12.28-0+deb11u1) ...
Processing triggers for libc-bin (2.28-10+deb10u2) ...

(this is line 4403 <---my comment)


1 Like

It says your PureOS distribution is Amber, whereas the instructions are for Byzantium and up.

lsb_release -c says it’s Byzantium

Both the host with the installer and the victim, L5, :slight_smile: are both Byzantium.

1 Like

Okay, but that clearly does not add up with the bug report:

This was only generated wihin the last several hours, right?

Yes. Within last hour. And I just tested and posted the lsb_release then posted them./

1 Like

Okay, I suggest flashing a PureOS image on a USB drive, then boot and use that instead to reflash the Librem 5.

Sorry to seem dense, but I flash a “image” to a USB stick/thumb drive/ and boot the USB - where is the USB going to be plugged into when (1) Flashing it and (B) booting it.

I have already done the upgrades to Byzantium on both the L5 and Host (desktop) sometime ago so it seems to me, that both are telling it like it is and the Installer itself has a mistake. But I will get set up with USB thing to be ready when I know where things go.

1 Like

The host computer.

To amarok, I apologized with…

In response to Duh, You mentioned to everyone that I posted that the flash was successful. i apologized for believing what the phone-wannabe showed me. Since then I’ve l;earned not to trust anything I see the device posting to the screen.
That’s all it was.

I think if I get this -thing- working as expected, not as advertised, I would have more time to be positive to it’s outlook.

Puri should pay you guys for without you folk, Puri would be swamped and not last long.
Or at least a 10% increase in your pay. :rofl:

1 Like

Or at least a 10% increase in your pay. :rofl:

Humph… 10% of nothing is still… :shushing_face:


It’s a old dig when volunteering. Mmmm, never mind. I shouldn’t use old jokes.

1 Like

You got me on that one.
I don’t know if a joke is old or not.
Since I’m a foreigner (to the US of A or Canada) and thus not familiar with many jokes,
I need some time and (sometimes some) explaining to discover if you are serious or just joking.
No need to stop with those jokes.
Laughing is the best medicine we have.




should be a fair indication that @Sharon was joking.

1 Like