Powering the L5 without battery or USB

Hi. I’ve been unlucky and my Librem 5 has stopped charging, now my battery is dead, and no matter what I do I can’t get any life in it. I’ve read all about removing the battery, pressing volume up, etc, but the led indicator does never turn on whatever I do. So I thought about powering on the phone with a DC power source, so at least I can do a backup and maybe try an upgrade since the phone stopped charging after an update. This update took a long time and something might have failed silently, I don’t know. Well, since there are three connectors on the phone for the battery I just wonder if I could connect 3.8V DC power source to - and + and ignore the middle connector? I don’t want to break it more…

1 Like

Why bla bla bla? if battery is dead, just buy new battery on Purism Store as almost no body here are Gurus to help. except one. :wink:

. Please be more clear between a dead-battery with empty-battery, as i not going to spend energy to guessing…

1 Like

Just to confirm, what happens when the device is powered off, you remove the battery, and then connect the USB-C to power? Any vibration or notification LED?


Does ‘etc’ include pressing the power button for 20sec ? just checking :wink:


To power the Librem 5 without a battery is easy. Just take it out. The Librem 5 should still work as long as you have the Librem 5 connected to the USB-C charger.


He said:

He might not be able to, if he’s not located in the U.S., as has been mucho discussed here.

Because invariably, someone attempting to answer will ask for more, and as much detail as possible in order to try and provide a recommendation.



Did you use the Purism software app to update, or the terminal? (I’ve found that the software app fails often (or at least appears to fail), while the terminal command always succeeds, and more quickly).


I can’t buy a battery since I’m outside US, and the new battery would just last one cycle since it doesn’t charge.

1 Like

No vibration and no LED. I’ve also tried pressing the buttons for at least 30 seconds. Also shorter, I’ve tried all sort of things.

Often I use the terminal too, but this this I used the software center unfortunately. So I couldn’t really see what was happening.

That was what I thought as well, but in my case it doesn’t work. Maybe the USB connector has come lose internally. That could explain my problem, but there’s also other explanations I guess.

I do not think that the Battery is Dead so i guess that your Librem 5 still ship an old Das-uboot Bootloader so i think that by removing the battery then putting back then doing a SuperLongPress_Power_Button(22sec) your Librem 5 will boot again.
If battery is empty plug in the ORIGINAL Librem 5 cable and charger and perform SLP22sec.
And for better performance of L5 do not use it or experiment with another generic charger/cable than ORIGINAL.

Purism Community

I’ve already tried this many times. The battery is dead as in completely empty, not as in broken. The problem is that as it is now my phone doesn’t charge. I was thinking about taking a backup before sending it to repair, but then I have to power it on. Therefore I wanted to know if someone had tried using another power supply than the battery. I’m pretty sure it works but better to at least try to find out first.

Theoretically you could charge the battery externally to the Librem 5. (I mean I have an external charger and this works. It’s theoretical in the sense that you can’t try that unless you have such a charger.)

I have a feeling that even with a fully charged battery things might not work - but you won’t know unless you try.

This might be easier than attempting to wire in an external DC supply.

Why not use an external LiOn charger or some CV/CC power supply (Labornetzteil in Geman) to charge the battery? If there is some hacker-/makerspace/fablab near you they probably have some.

I read on matrix by Angus:

With all of the HKS switches off, a current u-boot and a proper power delivery supply you should be able to boot. Once running you can enable the HKSes again

That’s a start completely without battery. So have you turned HKS off? If that does not work, you may have an outdated u-boot (at least I read the message this way).

Yes I tried that with HKS off and no battery, without getting any life signals from the phone.

That’s what I want to try. I have a power supply, I just wanted to know if I need to connect the third pin.

What external charger to you have? I’m interested in getting one of those.

Are you using ORIGINAL Cable/Charger? if so even if Device do not turning ON with SLP22sec, leave connected to charger over 15 minutes, then try again.

Purism Community

No I don’t, but I’ve tried many cables and chargers with usb pd. Should make no difference.

I’ve unfortunately tried that too.

Thanks for all the help!

Let me redirect this issue to LL Low Level: @dos

Purism Community

1 Like