Problems with new Librem 15v3: No trackpad and no root file system

I just got my new Librem 15. First, the touchpad doesn’t seem to work in the setup application, though an external mouse does. Second it doesn’t finish the setup process.

I pick a network name, and set username/password. As it moves on to the “Partition disks” step, however, I get an error:

No root file system
No root file system is defined.

Please correct this from the partitioning menu.

Following this post:

I looked at the boot devices, and there are three:

  1. Samsung SSD
  2. Payload [memtest]
  3. Payload [coreinfo]

Booting into #1 achieves the same result as before.

Thanks in advance for any advice!

This looks like your setup is broken for some reason, the solution is to reinstall the system.

We have the USB drive prepare instructions:

and installation instructions:

Ok, I’ll give that a try. Thanks

That worked, thanks! The trackpad never did work during installation, but it works fine now that I’m up and running. There is one remaining problem, though, which I’ve posted in another topic: