Pure OS won't run

good info, but doesn’t sound like what the user is running into since they have it booting to the PureOS splash. This sounds like the crng bug where it doesn’t have enough entropy for certain functions which are waiting on it. Usually, moving the mouse/touchpad (needs to be captured if using a VM) around a bit will allow the live session to continue booting

1 Like

I have been using PureOS on Dell (installing grub manually on UEFI) but I still wonder why puri.sm would break UEFI compatibility, which is available in standard Debian testing?

I have seen many users reporting UEFI compatibility issues on the forum, if Puri.sm would like to promote PureOS they need to consider releasing UEFI version, so we will have freedom to use whatever hardware we want without workarounds.

UEFI isn’t FLOSS, so it won’t be included. You have the freedom to use other distros if that is what you want, but PureOS doesn’t need to support hardware that doesn’t respect your freedom because it requires closed code

3 Likes

Yes you are correct :slight_smile:

Neither cooboot is FLOSS complaint, If Debian includes UEFI why not Purism? I have freedom to use whatever hardware and software I want to, but if purism advocates freedom and privacy they shouldn’t be blocking certain users from using their operating system. Again, I just raised question since PureOS is fork of Debian testing which supports UEFI then why not PureOS.

Debian and PureOS are different operating systems with different approaches to software freedom. The Debian approach is codified in the Debian Free Software Guidelines (DFSG) while PureOS has decided to be recognized as a Free Software Foundation free software GNU/Linux distro: https://www.gnu.org/distros/free-distros.en.html

This is why somethings might be available in Debian and not in PureOS.

1 Like

Thank you for the explanation, is there any future possibility of PureOS code release, so we can compile a version with UEFI support?

Thank you all for the replies. I can easily accommodate Legacy mode etc and all of the other suggestions. Trying in VM and moving the mouse etc had no effect. I am a little confused that some feel that if I get to the grub menu then its not a Legacy/UEFI issue? Maybe its a general compatibility but I have three different systems I can access.

For the moment it will have to wait until the weekend when I will give it a run. As I mentioned in my post I’m hoping for a universal system across devices. I am prepared to put up with some niggles but being a new member to these forums I am just beginning to see the may issues that people are reporting with Pure. If I can get it running it will need to knock me off my feet for me to put it on all three of my devices if its going to give me problems. I came to Linux to avoid issues which is generally the case with so many good distros.

But thank you to all who put pen to paper. I’ve got some things to go on with.

Brad

what VM are you using? I loaded it up under Virtualbox without issue

I’m using Oracle Virtual Box as well. It won’t play ball I’m afraid with mine.

if it’s freezing on the PureOS splash with the progress bar underneath, then it’s definitely the crng bug, and you’ll need to capture the mouse to have it progress. It should be set up as a 64-bit Debian OS, and I think the only setting I changed was the chipset (ICH9)

Thanks for the reply.
I have tried the Debian 64 bit in the VM without luck. Just hangs. And to be clear there is no progress bar beneath the “Pure OS” logo. In the Oracle VM that I using I don’t see a way to adjust the chipset (I assume that is what you’re talking about?). At any rate, this doesn’t help me with getting it onto a laptop. On the weekend if I get time I’ll change to Legacy boot and see if that helps. If not, then I won’t be using Pure. Its a shame because I’m also up for two laptops in the last quarter of the year and I was going to go Pure but now I’m leaning to System 76 with either Pop (which I like) or Ubuntu (which isn’t that much different really).

I am surprised that the Pure people haven’t gotten on top of this. I like the company and their ethos but this OS problem is significant, for me that is. I mean, I can’t even evaluate the OS.

Thanks again for replying.
Brad

Since it seems like you might have machines already running some form of Linux, have you tried GNOME Boxes for your VM hosting? It doesn’t have many configuration options, but I’ve had PureOS VMs work just fine in it

You can also press a few keys on your keyboard (but don’t press the arrow keys) and it will go past the PureOS logo. It only happens upon initial setup in VirtualBox.

1 Like

Thanks for the suggestion, but no I haven’t tried the gnome boxes. This issue really boils down to whether I can get it running on a computer proper, not in a VM so much. Its looking like there are too many issues for this to happen unless I can get it going with some of the suggestions here. To be frank there are just so many alternatives to Pure OS that are hassle free that I may have to forgo the dream of an OS across devices which won’t be the end of the world. As I said in my last post I am really surprised that Pure OS has these issues when most linux distros that I’ve tried are dead simple to get up and going. I had been meaning to try Pure OS for ages but never got around to it, not envisaging a problem. With the Librem 5 not far away it prodded me to try Pure OS. But if seems to good to true…sometimes it is.

I’m not done with it just yet. I’ll try some of the suggestions on the weekend hopefully.

Just to put an end to this so that its nice an tidy and if it may help others who have similar issues.

I did get the OS going (and installed) by initially changing things to Legacy, disabling secure boot etc. But that on it own wasn’t enough. As before I could get it to to the splash screen where it hung. I tried moving the mouse etc to no avail. What got it past this was simply pushing the arrow right key (>) at the bottom of the keyboard. No other keys seemed to do this, but the arrow key was the one. I did this four times to check.

So now its installed and it runs beautifully. Irritatingly it doesn’t see my wi-fi card which I will get to the bottom of I hope, but that’s an annoying start. I just hope that it doesn’t haven’t quirks in it like this as I go. Now to see if I like.

Thanks very much to those who helped me here, I appreciate it.

1 Like

Your wireless card probably requires non-free drivers which PureOS doesn’t include. You’ll need to find and install them (or they may be included in Debian’s non-free repo, which you can add)

1 Like

The issue with wifi is indeed because your wifi card uses non-free firmware. I had the same issue when I installed PureOS on my Dell 6420 (which worked flawlessly, by the way, without the hangup you mentioned). The firmware is located in Debian’s non-free repository. I’m traveling at the moment and don’t have access to the computer, but can send you the link when I’m home on Monday if you’d like (and if it won’t get me in trouble with the moderators).

I suspected as much with the wifi card. If you could send the link it will save me some hunting which I’d appreciate. Thanks heaps.

Here are some quick steps I wrote for adding the non-free repo. I wrote them in the context enabling Bluetooth on Librems, so the last step of installing firmware-atheros might not be relevant, but if you know which wifi card you have, I’m sure it wouldn’t be too hard to find which package you need to install.

1 Like