PureOS on Macbook?


#62

And did you rebooted the machine?


#63

Yes, I did.


#64

Now you sorta are where I have been. I was trying to use dpkg command. I suspect, I was told to use the Sudo Apt, They thought I had the correct package in hand. I discovered, despite what I had been told, Apt command must be online, So it can call home to the Mother Ship, or it will not work. Also the Apt command would find the additionally needed software. Someone suggested that I use the package manager, which will detect if there is needed additional software. Another issue possibly being, there is, apparently (I dunno) an issue with getting the correct module version for the version of Debian you are using.My current version of Pure OS is based on Debian Buster. Or is that my problem?

Keep in mind that the Debian philosophy is that everything must be free software, not third party. Still some folks provide the firmware for proprietary hardware, like Broadcom. It is not clear to me whether the current download offerings of Proprietary Hardware on Buster for Broadcom even work. Apparently they have to be updated for each Linux Kernel.

The package I found was not sta version. I am not, right now, in a good place, (I am in McDs, which blocks Linux downloads, upgrades) So someone please provide this fellow with the correct Repo, and how to set the Package Manager, like Synaptic. to download from it. Or perhaps, if you download from the entirety of non-free Wireless Firmware for Buster, how to point at it locally on your hard drive download section.

Anyway, it is obvious to me that nearly everyone else on this thread is more Linux knowledgeable than myself. I just have a lot of experience of Not getting the Broadcom Wireless to work.

I am further handicapped because I do not have a wired Ethernet connection to plug into. Which I need to use a package manager, Synaptic or Software manager.

I think I will stop trying to use the Mac Book Pro with Pure, Go to a Distro that has the correct drivers already functioning. At least I can see what driver name that, say Ubuntu uses for my wireless. I will have to research how to identify what Ubuntu is using. Perhaps later this spring I will get at home internet. And an Ethernet cable to plug into.

A fellow on the Puppy Linux forum pointed out that if I start the live version of “Fat Dog” that in the notes for Fat Dog, it describes getting the Broadcom Wireless Drivers to work. I have not read through all that yet. http://distro.ibiblio.org/fatdog/web/ I suspect their packages are uniquely for Fat Dog, not just any Debian.


#65

I do have the Mac connected to internet via USB. At least that works well.
This is a pretty good community here. I believe we will eventually get it figured out.

I wonder what it will take to get the “right-click” to work.
The Mac has a hard click on the mouse pad, not a tap like everyone else. Can PureOS account for that?


#66

Yesterday I was configuring it on my sway compositor - but both (Sway and X) are using libinput for input device management so you can try that method. First try doing ‘xinput list’ to find which touchpad you have, and then if it is synaptic - there’re lot of docs on internet how to configure it, even the one I’ve referenced already above.


#67

https://wiki.archlinux.org/index.php/Broadcom_wireless

https://wiki.archlinux.org/index.php/Talk:Broadcom_wireless#Installation:_broadcom-wl_is_in_the_official_repos_now

more detail


#68

I don’t have pureos, but look at settings -> devices -> mouse & touchpad and see if theres a Tap to Click option. If there is, turn it on, and a two-finger tap should then serve as a right click


#69

I got the click set and the right click works too. Thanks


#70

I read about “kernel” around here frequently. What exactly is a “kernel”.


#71

think of an onion … how it makes your eyes water and sore … now think about the linux-kernel … the “part” that sits between your hardware and software (more visible is the back-end or GUI)


#72

purple, I downloaded the broadcom wl driver but have no idea how to install it. Yes, there is some instruction, but it seems rather confusing with all the options and ifs and go here or maybe there, but no command prompt lines that I may understand with my tiny knowledge of the Linux/Debian/PureOS/Genome/etc. world.


#73

I did you a dis service. I do not think the driver meant for Arch Linux is likely to work for the Pure OS. Arch Linux is not Debian, the base of Pure OS.

Remember I am the fellow who never got his Broadcom wireless working.

What I think might work; Assuming you have an Ethernet cable Plugged into the computer, and the internet working through that. Then to start the package manager. Likely you have two already installed in Pure. Software something or the other. Synaptics Package Manager. You should start one or the other. Take a minute or two and look at the commands available there. You might start the update, which means the program will download a new list of available Updates, and locate which ones you should need. Just for the experience, let it do the Update. Might take a few minutes, but it can not hurt.

Back to the devious Broadcom Wireless problem. You need to point the package manager at a Debian Repository which has Proprietary Wireless Drivers., for Buster I am not sure what that might be, I am using a Windows 10 Computer at McDs. A bit hard for me to research that part. Then you need to use the Software Manager to search for the specific Broadcom Wireless you have.

If it finds it, it should install it on its own.

Option two: Don’t do that package manager. Start the Terminal. I think in the list of available software, down at the bottom is a bunch of Utilities. One of them is – is it xterm, or something term.
Someone more linuxy than me should be doing this. Type at the prompt. sudo apt -i (whatever the driver you need) oh wait, do we have this pointed at the repo you need. I do not have the Linux manual in front of me. Anyway, if you get it pointed at the correct repository, module.

It will first ask for you password to install as root. then it will do all the work. then tell us what it said it did.

Alternatively. One could click on the broadcom driver you downloaded to your computer. The computer should start the extract program. You extract that turkey, then use the terminal to cruise over to it, and use the sudo app command to try to do the install. Cruising the terminal to be in the same directory which the extracted, is to use the “cd” command. Like my name on my computer is beach (I gave it a name of beach house)

cd \home\beach
cd \Downloads
cd \ whatever the directory you have the Broadcom driver in. \

I do not have the correct syntax for the cd command.

Anyway, that did not work for me. I either had the wrong driver, or I needed to be online in some way for the app command to phone home to the mother ship…

I suspect that if I was trying again, I would create a live version of Fat-Dog, boot it, and read the note that the developer there left on how to install Broadcom Wireless Drivers. He knows what he is doing, and has done something similar.

What I wanted to point out in Arch Linux, they might point you to the name of the debian driver you need. Plus they have an interesting note on one of the problems with using the Broadcom Wireless. I knew that Tails had said that the Broadcom wireless should not be used with Tails Linux, because the Broadcom wireless could not be Spoofed. Spoofed means that Tails can not tell the internet that the little code that identifies that specific Wireless -Broadcom can not tell the internet it is something else.

I should not be giving advice. I never got mine working. My excuse is that I do not have an Ethernet cable to plug into my MBP.

I also just bought a Lenovo X 230 Thinkpad, which uses a Intel Wireless, which is a proprietary only Wireless. Likewise, I gave up trying to get that to work with Pure OS. My goal is to do several things which will allow me to use some other Linux with it. But I digress.


#74

oh, copy and paste. On most of my hardware in Terminal. Hold down Ctrl and shift keys, then c or v to copy and paste. or a for select all.

I forgot, one note said to use something cutter to install the Broadcom driver. I think fwcutter. sheesh. that is when before I tried to use the package manager. Just the standard Pure OS repository do not include proprietary blobs (blobs = modules for the firmware used to run specific kinds of hardware) Before I started this, I did not know what a blob was, and I thought I was looking for a Driver, instead it is a Module.

I was asking about installing Wireless on the Puppy Forum: http://murga-linux.com/puppy/viewtopic.php?t=118015

A bit more perspective: When I was using OS X on my Apple MBP. I also tried to use a Wireless Dongle for once or twice. Then I could not access the MBP basic Wireless. Since I had Apple Care at that time, I asked them. They didn’t even laugh at me. They went through the thing of resetting the MBP basic Firmware by booting and holding down this key and that. Not sure what that portends for this project of using a MBP with Linux. I have started and used a lot of different Linux Distros on the MBP, which automatically used the Broadcom Wireless, and did not cause any continuing issues. Apple Mac OS X just always works because the folks at Apple have a rigid approach to things, not flexible.


#75

I’ve had to install a wifi driver in a debian OS before. I’ll look tomorrow and see if I can’t find that info again.


#76

So what’s the difference between Kernel, BIOS and firmware?


#77

tl;dr > they refer to the inner (lower) levels of code

as far as i understand the rabbit hole goes deeper … micro-architecture level of the CPU, GPU but i would not dare to talk about that since that’s too deep for my limited perception so far … maybe @ somebody else if you want a TL;DR explanation or just search around the fora here or elsewhere … :wink:


#78

Yes, that has always been my understanding, that it is the link between the OS and the I/O.
But according to the graphic you posted earlier, the kernel does the same thing.
So it sounds like the BIOS, the firmware and the kernel are all doing similar things, but we have three different names.
Are there distinct differences between the three, or just different names for the same entity?


#79

If we take legacy system in general and DOS in particular - BIOS was acting as a kernel - managing hardware initialisation and hardware abstraction. Then with raise of multitasking system kernel took over the abstraction role while initialisation was still BIOS responsibility (so it started moving to firmware role from kernel - no one was speaking to bios once the kernel took over the control).
Further development led to more and more tasks being took over by the kernel so now BIOS really consists mostly of powering on the system and loading the kernel, the kernel then does HW and OS bootstrapping.
So modern BIOS is firmware. Partly burned into motherboard, partly loaded from the disk - but still firmware. Modern kernel is software.


#80

yeah but the truth is it’s just code … written for different tasks and in different styles/languages … and the lowest of them all is binary-machine-code (0 and 1 in apparent random order)

it’s weird how much power a simple yes/no string can accomplish … if only Stalin and Hitler had it … obedience without question …


#81

please avoid using this name or mention it in any context, I prefer to avoid religion and politics online :smiley:
it is just my personal reason don’t like to get into it or explain who what why where.

Regards, Alex