PureOS on Macbook?


#82

now i’m curious … but ok i’ll indulge you …


#83

in case my name was not good enough hint Alex (Ari) in profile, Ari is Hebrew for Alex. I am Jewish so I prefer not to ever mention that name due to respect for my people’s ancestors, and I avoid politics and religion discussions all together in RL and Online, as a scientist I have mixed feelings about religion orgs. I don’t plan to continue discussion or I plan to explain any more then, so as a personal request don’t use that name again.

Regards, Alex


#84

Just a related post to the main topic had many friends install linux on Macs (various distros) and most of the comments I get is well my MacBook feels like a rocket ship now compared to using MacOS.

Regards, Alex


#85

I have downloaded a file named
broadcom-wl-dkms-6.30.223.271-20-x86_64.pkg.tar.xz

How do I install this thing?
The installer in PureOS can’t do it.


#86

Here is another one making me scratch my head:

I find out about the Debian buster site and read there:
If you are running Debian, it is strongly suggested to use a package manager like aptitude or synaptic to download and install packages, instead of doing so manually via this website.

So I find some “pieces” or maybe files of aptitude to download. But I cannot figure out how to install these things.

You know in MS DOS there used to be an exe file you clicked on and it ran. Or you download an install and click on it and it runs. I guess there is no such thing in Linux. I download something and then I have to use something else to get the first thing to do anything ?


#87

glad you asked …

  1. sudo apt update
    sudo apt upgrade < if there is anything to upgrade to
  2. take a mental or written note of the exact (absolute path > ex > /home/your-user-name-here/Downloads/your-downloaded-package-file-name.deb)
  3. open up a terminal window
  4. write it as bellow - just substitute my hint for your use-case :
    sudo apt install “absolute-path-to-where-you-downloaded-the-deb-file-from-point-1-without-quotes”
  5. type your super-user-root-account-password even if you don’t see it appear on the screen as you write it
  6. hit “enter” on the keyboard
  7. confirm by typing y
  8. hit “enter” on the keyboard again

note that doing it like root (#) will give you a warning about sand-boxing …

NO. there IS a sort-of an equivalent but it’s not .exe - it’s .AppImage

you can find it on some web-sites but you have to trust that it doesn’t run malware …


#88

Broadcom BCM94331 (14e4:4331) uses HT PHY but let us stick with the logic (solution) or philosophical approach (idea), my favorite source here, coming from from @purple (post #26), still not promising it will work while not using PureOS (yet) on MBP. As well, this approach will modify PureOS kernel (stay aware if future kernel updates recognize upcoming change) and therefore this post should be flagged (if so I’ll sing: “Let it Be” from The Beatles).

By rewriting few things, already mentioned ones, please follow this (draft) within Terminal (using Ethernet connection):
~$ sudo apt purge broadcom-sta-dkms
~$ cd /etc/apt
~$ gksudo gedit sources.list or sudo nano sources.list

Add following line: deb http://deb.debian.org/debian buster non-free

~$ sudo apt update (NO_PUBKEY error might appear), if so:
~$ sudo apt install debian-ports-archive-keyring
~$ gpg --keyserver subkeys.pgp.net --recv-keys B4C86482705A2CE1 (if correct, by comparing it to previous: apt update output)
~$ sudo apt-key update
~$ sudo apt update
~$ sudo apt dist-upgrade (hopefully without significant changes, if any)
~$ sudo reboot

~$ sudo apt install wireless-tools network-manager-gnome wpasupplicant
~$ sudo apt install dkms linux-image-$(uname -r|sed ‘s,[^-]-[^-]-,’) linux-headers-$(uname -r|sed ‘s,[^-]-[^-]-,’) broadcom-sta-dkms
~$ sudo modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
~$ sudo modprobe wl
~$ sudo reboot

If BCM4331 chip works and desired: remove or block (with ##) from sources list DebianBuster non-free repository.

This above is just simple draft, not PureOS related, another choice (needs to be proofed and hopefully needed modifications posted here), that might turn on Wi-Fi, yet not compatible (in broader terms) with PureOS. If tested, someone may recap what works/needed and what isn’t working. In addition, post #74 (open source b43-fwcutter driver) might be obsolete, but not sure.

I like aptitude very much:
~$ sudo apt install aptitude

EDIT: sudo apt purge <package_name> Thanks, @ruff!


#89

reC,
I tried your install command, but the packages I downloaded don’t end in “.deb”. These package names end like “pkg.tar.xz”. PureOS has build in package installers. But how do I tell the package unpacker to unpack this particular one found in my downloads folder?


#90

pkg.tar.xz is ArchLinux package format (pacman) and you need debian (deb). Perhaps you just need to choose correct platform when downloading?


#91

purge command not found:
Screenshot%20from%202020-03-01%2007-06-37


#92

you-ve missed apt
sudo apt purge <package_name>


#93

~$ sudo apt install aptitude

That was about the only command line that worked.
But where is aptitude?
I don’t find it aptitude among the PureOS applications.
So I took a longshot and typed aptitude into the terminal and it ran, but how do I get it to install this broadcom package?


#95

Sorry, messed up again. Now working


#96

IMO, without debian buster non-free repository within sources.list there is no major difference if you are using sudo apt or sudo aptitude commands within Terminal.


#97

just got the purge done
but
Screenshot%20from%202020-03-01%2007-37-20


#98

~$ gksudo gedit /etc/apt/sources.list


#99


#100

~$ sudo apt install nano
~$ sudo nano /etc/apt/sources.list
https://wiki.gentoo.org/wiki/Nano/Basics_Guide

Another option is to open Nautilus:
Ctrl+L
admin:///etc/apt
Open sources.list with Gedit (as root).


#101


#102

Add:
deb http://deb.debian.org/debian buster non-free
Try to avoid adding:
deb http://deb.debian.org/debian buster main contrib non-free