PureOS on Macbook?


#103

I added the line, saved the file and exited nano.


#104


#105

Next command was: ~$ sudo apt update
Please continue to copy/paste commands from my post #88. I’ll be away for next two hours, sorry it is must for me.
Maybe to go back with:
~$ sudo apt purge debian-ports-archive-keyring
~$ sudo apt autoremove


#106

Try keyring.debian.org, subkeys server seems to be down.


#107


#108

can you dump dmesg after making modprobe (to see relevant lines)?


#109

Sorry ruff,
I didn’t get that. I am not far enough along in coding.
Please explain more.


#110

I would also like to try installing the following package:

broadcom-wl-dkms-6.30.223.271-20-x86_64.pkg.tar.xz

But I don’t know how to install this one.


#111

broadcom-wl-dkms-6.30.223.271-20-x86_64.pkg.tar.xz is ArchLinux package
broadcom-sta-dkms is its Debian version.
to get dmesg please do
sudo modprobe wl ; sudo dmesg | tail -22


#112


#113

Sorry, I wrote for: sudo apt update if there is NO_PUBKEY ERROR to do some adaptation, but if there is no error there is no need to install debian-ports-archive-keyring. Try to avoid sudo apt dist-upgrade as well. Next copy/paste steps are:
sudo apt install wireless-tools network-manager-gnome wpasupplicant
sudo apt install dkms linux-image-$(uname -r|sed ‘s,[^-]-[^-]-,’) linux-headers-$(uname -r|sed ‘s,[^-]-[^-]-,’) broadcom-sta-dkms
sudo modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
sudo modprobe wl


#114


#115

This is partial end-output without NO_PUBKEY error:
~# apt update
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.

So my draft is not all right, sorry. Please don’t move to the next step if having error on previous. Maybe to try with:
sudo apt purge broadcom-sta-dkms dkms
sudo apt install broadcom-sta-dkms

P.S. This would be just example (for your orientation) for DebianBuster but you need to find something exactly the same if above not working within PureOS.
sudo apt install broadcom-sta-dkms dkms linux-compiler-gcc-8-x86 linux-headers-4.19.0-8-amd64 linux-headers-4.19.0-8-common linux-headers-amd64 linux-kbuild-4.19


#116

Looks like the purge and reinstall worked fine.
The wifi is still not working.

P.S. Noticed Friday: my SD card reader is not working either.


#117

I wonder if it makes a difference working with amd64 packages versus intel?


#118

~$ sudo reboot

P.S. amd64 packages are including Intel.


#119

I had done the reboot already.


#120

Reading here: https://wiki.debian.org/wl

Should I try:

Debian 10 “Buster”

deb http://deb.debian.org/debian buster-backports main contrib non-free


#121

Yes, but without main contrib or read sudo apt update output carefully.
I’m no expert but this might help, try this first:
sudo apt install broadcom-sta-common


#122

it said:
Reading state information… Done
broadcom-sta-common is already the newest version (6.30.223.271-10).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.