PureOS "Software" application mostly empty

Similar to App store “Software” disappeared after pureOS update, my gnome-software app now displays only “Categories: Add-Ons” in the overview screen (I think there should be 6 categories) and no highlighted software advertisement. It is not aware of anything I have installed except for Add-ons.

I tried doing a general sudo apt update but that didn’t work. I intend to try sudo apt reinstall gnome-software but I wanted to know if I could delete/edit some configuration file to try and make it work again first. I found /var/lib/dpkg/info/gnome-software*, and from gnome-software.list:

  • /etc/xdg/autostart/gnome-software-service.desktop
  • /etc/xdg/autostart/gnome-software-service.desktop
  • /usr/lib/x86_64-linux-gnu/gnome-software
  • /usr/lib/x86_64-linux-gnu/gs-plugins-12
  • /usr/share/applications/gnome-software-local-file.desktop
  • /usr/share/applications/org.gnome.Software.desktop
  • /usr/share/dbus-1/services/org.freedesktop.PackageKit.service
  • /usr/share/dbus-1/services/org.gnome.Software.service
  • /etc/apt/apt.conf.d/60gnome-software

But I really don’t know where to start.

1 Like

I have the same issue. It started after the update involving LibreOffice. After that update I had no updates anymore? Perhaps it solves after a new update?

I did attempt the sudo apt remove gnome-software, then sudo apt purge gnome-software, and finally sudo apt install gnome-software to no avail. The application still stays broken. I’ve reverted to periodically running sudo apt update to try and keep things up-to-date.

1 Like

That worked for the PurOS update. Thanks. Now waiting till someone responds and knows how to solve it.

Hi Jason, I have had contact with Customer support and I still was on Distro Amber. Now there is Bizantium. That is why everything was hone. You might have the issue? You can upgrade here: https://tracker.pureos.net/w/recommendations/upgrade_from_amber_to_byzantium./

I made the mistake to not delete the repository that involves Amber and had trouble. Only Bizantium should be ticked (box) in software & updates.

I just went ahead and got Byzantium installed. It took an hour or so (per using the instructions in the link above) and I didn’t encounter any errors. I noted a few warnings that I guessed were rather innocuous, and kept some/updated some configuration files based on what I remember updating.

I had to reinstall FreeCAD which got me up to the latest version, so that’s good. The Software app has all its categories back, but it has been complaining about not being able to download updates (I had edited the /etc/apt/sources.list manually, so I didn’t need to uncheck anything.) I can get around that with manual updates if need-be.

1 Like