App store "Software" disappeared after pureOS update

I updated pureOS on my librem over the past couple of weeks. I did not realize immediately but the pureOS app store called “Software” disappeared from the app menu. Even more surprising, some of the app I had installed from the pureOS app store also disappeared: for example the python editor “PyCharm”.

Has anyone encountered this issue? Any solution?

Thanks in advance.

How did you performed the update?

Please the following command to restore back the software center:

sudo apt update && sudo apt install pureos-desktop


This happened to me too on the 12/20 update, using

  sudo apt update && sudo apt full-upgrade

I have not debugged gnome-software, but several packages of mine were uninstalled, including this one. (I do not really use gnome-software directly.) The two I debugged were dependent on python3<<3.7, and python3 was updated to 3.7 that morning. You might want to pull the thread of dependencies.

1 Like

Thank you @mladen. Your solution worked.

I always update by executing the 3 commands:
sudo apt update
sudo apt upgrade
sudo apt full-upgrade
and then restart the computer.

Should I add the fourth command:
sudo apt install pureos-desktop
to my update routine?

Also in Software, tab Updates, even though my system is up to date, there is still one entry with “OS Updates”. When I press Update next to it, nothing happens.

The reason I am saying that my system is up to date is that in Terminal if I run >
sudo apt update
then I get the message

All packages are up to date.

1 Like

I am new to Linux, but I am enjoying my Librem 13 very much. I am having a similar problem, only it’s my “Software and Updates” app that has disappeared. My computer is not listing it as installed anymore and I can’t find in in the Software “store” anymore either. I didn’t purposely uninstall anything. The problem happened after I connected my computer to WIFI in a hotel, though I don’t know that there is a connection between the two events. Will the solution for restoring the Software “store” app work for restoring the “Software and Updates” app too? Thanks!

No, this was just to re-install this metapackage after it got uninstalled somehow (which should never happen).

It should, go ahead and try sudo apt install pureos-desktop

It hasn’t worked for me. Nothing happens when I click on the Software and Updates symbol.

doesn’t work for me either; “software and updates” cannot be opened.

Same here, Software and Updates won’t launch despite trying above fixes.
12/2018 L13 (marked as v2 externally, but with i7-6500).

As I mentioned in my previous post, gnome-software was uninstalled from my system due to an update. I do not have pureos-desktop, and I did not try Mladen’s suggestion. (I am not avoiding his advice; I just didn’t.)

Recently, I decided to debug this problem, but when I installed gnome-software again, it all worked for me. Something must have changed in the interim.

Perhaps you might try that after the latest updates or forcing a reinstall? I cannot predict if it will work; I can only convey my experience.

Thanks for the reply, Wayne.
I tried what you did again this afternoon, and still no Software & Updates.
I’ve also tried what mladen recommended.
I’m a noob to Linux and will be patient and keep learning.

1 Like

@Wayne : gnome-software got uninstalled on my system also on 12/20 during a regular system update. It would not re-install, so I installed plasma-discover, which is not as pretty as gnome-software but it does work as a software discovery tool.

Both are dumbed down and inferior to Synaptic for displaying dependencies, versions, and changelogs. I like to see all that before updating so I can see what was fixed (and what might break after an update :slight_smile: )

Some days later I was able to re-install gnome-software, but I just did it this way:
$ sudo apt install gnome-software
and it worked fine.

I’ve never heard of package pureos-desktop before, which is not installed on my system and apt says it can be safely removed:

$ apt show pureos-desktop
Package: pureos-desktop
Version: 0.9.4
Priority: optional
Section: oldlibs
Source: pureos-meta
Maintainer: PureOS Maintainers <>
Installed-Size: 10.2 kB
Depends: pureos-gnome
Download-Size: 3,808 B
APT-Sources: green/main amd64 Packages
Description: Transitional package (pureos-desktop -> pureos-gnome)
This is a transitional package and can safely be removed.

It’s a moot point at the moment, because the Purism repo is timing out!

$ sudo apt update
Hit:4 green InRelease                                                    
Err:5 green InRelease                                                         
  Could not connect to (, connection timed out
Reading package lists... Done                   
Building dependency tree       
Reading state information... Done
37 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch  Could not connect to (, connection timed out
W: Some index files failed to download. They have been ignored, or old ones used instead.


Thanks. I tend not to use gnome-software either, which is why it took me so long to get back to it. I used the same command you did.

pureos-desktop was news to me too. Maybe like the other packages that were uninstalled recently, it got deleted along the way! :wink:

Sorry, I forgot to include this information in my last post.

You may know this already, but the command to force a reinstall is:

 sudo apt --reinstall install gnome-software

Otherwise, the apt will complain that the package is already installed.

My other suggestion is to launch gnome-software from the command line to see what messages you get. That is probably easier than combing through the logs.

1 Like

Thank you.
I have the gnome-software “Software” on my GUI, but right next to it is an icon for “Software & Updates.”
This is what does not open from GUI or CLI for me.
Perhaps it’s redundant, a glitch or unnecessary since the “Software” in GUI has an “Updates” tab.
I’ll stop thinking about it!

Oops. My mistake. You did say that, and I suppose my brain filled in my similar problem.

I do not use that package at all, but I tried it and it does not work for me either. If I am not mistaken, it is “software-properties-gtk”.

There is a another thread where this is being discussed, though my error is different than the original post there. I get

ERROR:root:Cannot import UbuntuDrivers: No module named 'UbuntuDrivers'

This bug has been reported here, which is also mentioned in one of the posts in that thread. I suggest monitoring both of those items.

1 Like

Thanks, Wayne.
Checked the thread and Maniphest.
I probably don’t need it.
I’m having a blast learning Pureos/Linux/Librem!

Mine disappeared to on the Librem 5. What i did was:

  1. update phone with linux, kernel updates
  2. updates failed and phone shell did not boot any longer
  3. using jumpdrive restored from saved May 2023 image
  4. used terminal to update / upgrade
  5. rebooted used pureos-software store to update OS Update
  6. after reboot the software store is gone

Using the command above “sudo apt update && sudo apt install pureos-desktop” fails…

unable to locate package pureos-desktop

Using the command above “sudo apt --reinstall install gnome-software” also fails…

pkgProblemResolver: : Resolve generated breaks, this may be caused by held packages also
The following packages have unmet dependencies: puresos-store-common : Conflicts: gnome-software-common

You’re replying to a post from 2019. There’s no pureos-desktop package and gnome-software isn’t supposed to be installed on Librem 5.

On Librem 5, you should have librem5-gnome installed.

1 Like