pureOS version to install in a laptop with 2013 BIOS?

My laptop is a Lenovo Ideapad U430 Touch

Bios Version 7CCN12WW date: 05/18/2013

I had installed pureos-10evel-gnome-live-20220222_amd64.iso without encryption

It is possible run PureOS 11 on it?
I tried it but no success with PureOs 10.3 neither PureOS 11

1 Like


Did you get an error message? What went wrong?

1 Like
PureOS 11 downloaded from:


Burned iso image on usb stick

sudo dd if=pureos-11-gnome-live-20240510_amd64.iso of=/dev/sdc
bs=16M oflag=direct status=progress

Booting pureos11 gnome-live

GNU GRUB version 2.06-13pureos1
*PureOS Live [EFI/GRUB]
PureOS Live [EFI/GRUB] (nomodeset)

error: no suitable video mode found
Booting blind mode

Welcome to Pureos 11.0 installer (calamares)

Inserted a 32 gb usb sandisk disk
Welcome: American Ingles - Next
Location: America New york - Next
Keyboard: English US Default - Next
|Partitions: EFI . the boot environment of this system
Select your storage device: SanDisk 3.2Gen1 28.67 GiB
MBR the type of partition table on the selected storage device.
Install alongside (installer will shrink a partition to make room for PureOS11
[*] Replace a partition (replaces a partition with pureOS11)
Manual partitioning (Yo can create or resize partitions yourself)

sdb1 524MiB FAT32.
Pureos10(10.x) 28.16GiB ext4 (i tried before with no success with 10.3)

Encrypt system {654321pass}
sdb1 524MiB FAT32
rootfs 28.16GiB LUKS
The EFI system partition at /dev/sdb1 will be used for starting PureOS
| Users. Fullname, login: tony pc name: u430
| Password: 123456

Location timezone America/New York. 
System Language American English (United States)
Numbers and dates locale American English (United States)
Keyboard Generic 105-key PC.
Keyboard Layout English US/Default
Replace a partition on disk /dev/sdb (SanDisk 3.2Gen1) with PureOS11
Current: sdb1 524 MiB FAT32
PureOS 10 (10.x). 28.16GiB ext4

After: sdb1 524MiB FAT32
rootfs 26.16GiB LUKS

Delete partition /dev/sdb2.
Create new 28833 MiB partition on /deb/sdb (SanDisk 3.2Gen 1) with file system luks.
Set up fat32 partition /dev/sdb1 with mount point /boot/efi.
Install PureOS on new btrfs system partition.

| Install - PureOS Installer
| Continue with installation?
| [Install now]
{22:37} Unpacking image 1/1
Toggle log : START CALAMARES 3.2.62

Welcome to PureOS!

Thank you for choosing PureOS, a user friendly,
secure and freedom respecting OS for your daily usage. With PureOS, you are the only one in control of your digital life. PureOS is:
-Fast and responsive
-Privacy and security oriented, with freedom by design
-Based on a solid technological foundation
-A fully auditable operating system
-Modern, full-featured and user friendly

Enjoy this release and thank you for choosing PureOS.
The installation will take 15-30 minutes,
depending on your hardware and settings.

{23:09} 54% Removing 5 packages.
[23:13] 54% Removing 5 packages.

meanwhile I read About Calamares installer

3.2.62 for PureOS 11.0

Copyright 2014-2017 Teo Mrnjavac teo@kde.org
Copyright 2017-2022 Adriaan de Groot groot@kde.org
Thanks to the Calamares team and the Calamares translators team.
Calamares development is sponsored by
Blue systems - Liberating Software.

{23:18} 54% Removing 5 packages
(23:24) same
black screen
doesnt boot

1 Like

It seems like you are trying to install PureOS on the same USB drive that has the PureOS image, so you need to change the installation destination to the internal hard drive instead.

No, I booted Pureos11 installer on a 16gb sandisk
And to be installed on a Sandisk 32Gen1

1 Like

That’s rarely a good sign. Can you elaborate on the video hardware? Dedicated graphics card? Integrated Intel? Something else? Can you mention the screen dimensions in pixels?

For fault isolation purposes you might want to try to do the same exercise with a Live Boot of Ubuntu. From GRUB you can add the nomodeset if you have to.

Assuming that there’s nothing useful on the destination disk, I would use gparted to wipe the partition table and then during the install let the install have complete control over the destination disk.

1 Like
  • Screen resolution (1280x800, 1360x768).
sudo lspci -nnk

00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09)
Subsystem: Lenovo Haswell-ULT Integrated Graphics Controller [17aa:3800]

More here:

1 Like

The native screen size in pixels has to be some specific and fixed value. I would assume 1360x768 - which is certainly not demanding. Likewise, for a CPU of that age, the Intel integrated graphics are not demanding.

I was assuming that there’s some operating system already installed and working on your laptop and hence you could just check the actual screen size.


Try disable ‘secureboot’ from bios and try again.

1 Like

Here is a PDF of the Lenevo U430 Touch series’ product specifications:

It is either HD+ (1600x900) or FHD (1920x1080).


@Tonyp Could you try booting the installer in BIOS / legacy mode and installing that way? This may be specific to UEFI boot.

You may need to enable something like legacy boot, UEFI CSM (Compatibility Support Module), etc. in the BIOS. Then you probably need to select a different boot option to boot the installer in BIOS mode. It varies among BIOS vendors so I’m not sure exactly what it’ll look like on the Ideapad.

If you boot in BIOS mode, the boot menu will say “Install PureOS” instead of “PureOS Live [EFI/GRUB]”.


Actually I am running PureOS 10~developer edition on the laptop.

@carlosgonz secureboot It is disabled. But I’ll check again.

@FranklyFlawless thanks for the specs. It is 1600x900 .

@jonathon.hall You are right. When I installed PureOS10~developer edition, the boot menu say "Install PureOS, nothing about PureOS Live [EFI/GRUB]

I guess I need to format the usb stick to hold the pureos11.iso to fit with BIOS/MBR. And the same to the target disk were the PureOS 11 will be installed definitely.

1 Like