PureOS won't boot after upgrade, boots with recovery

After an update PureOS wont boot. The message I keep seeing is

cryptsetup (luks-dbfbe3cd-7972-4e2f-8b5e-c3c860e2c0b7): cryptsetup failed, bad password or options?

I’m a complete idiot, no idea how to proceed.

Did it ask you for a password prior to this? Is it possible you entered that wrong?
If you restart does it prompt you for a password?

1 Like

Nope, its not asked me for anything when I reboot.

mine has been doing that for awhile. after this update it got a little more colorful in the wording. but it still works. in a nutshell, it says it cannot find, therefore process volume.

nonetheless, you should still be able to type a password. it may not show the asterisks and instead appear to keep a blinking cursor. “please unlock disk (blabla):” if you simply hit “enter” or get the password wrong, then it states/asks, “cryptsetup failed, bad password or options?”. Do you get the message, " Please unlock disk (blabla):"? if so, just stroke that password into place until you get it right, asterisks or blinking cursor.

Hi, please see here: https://tracker.pureos.net/w/troubleshooting/failed_boot/

Also, this should have been fixed already: https://tracker.pureos.net/T433#7665


No, I am really never being prompted for a passowrd

I am not able to get to where the pages you linked to suggest. Ctrl + Alt + F2 do nothing at any point, and as far as I can tell there seem to be no option to put in a login or password of any kind.
WHat I do get is taken a screen that tells me that the firmware failed to load. It then says “(initramfs)”

1 Like

so it goes through the initial boot/bios process and automated boot selection (you didn’t hit the “ESC” key) and when it attempts to boot into the OS on your primary (and usual) encrypted hard drive/SSD, LUKS doesn’t prompt you for a password.

probably just a dumb idea from a big dummy (myself), but I would first try booting to an OS on an external USB device so you’d at least have a desktop environment to work with. you might even be able to mount then decrypt that drive from that alternative OS (haven’t decrypted LUKs like that yet, but I’m a noob). but id decryption is successful, then at least you’d be able to back up your Home folder before continuing the crusade for a bandaid or rescue.

also, try holding shift while it boots up and boot into a recovery

1 Like

Booting into recovery worked. Thanks.
But now what?

I can get on via recovery, but upgrading the system isn’t solving the problem.

Oh boi, I remember this happened to me as well the first time I was prompted to boot. After freaking out for 5 long minutes, I toggled Caps Lock and re-entered password, then it successfully resumed back to normal.

No, I am still never being prompted for a password,

1 Like

sorry about the delay. honestly, I don’t know. web search decrypt LUKS hard drive external … maybe do a search specific to your issue and throw in Debian to broad-stroke the issue while remaining relevant to this debian-based distro. @mladen might be able to help with more specifics also. it may have something to do with the full disk encryption package update or one of its dependencies. you can search for broken packages via the command line and reinstall them using apt or apt-get or even downgrade/revert them. take the time to learn a little and it will go a long ways. :wink:

Are you sure you have upgraded your system? Please do this with the Terminal command:

sudo apt update && sudo apt full-upgrade


Yup, tried it repeatedly

So, is there anything else I can try? Because this isn’t working.

There is always an option to reinstall. But I believe this should be fixed now, please try upgrading once again. If you still have problems, please open an issue on our tracker.

1 Like

I am having the same issue (for the record I am brand new at Linux)

After an update PureOS wont boot. The message I keep seeing is

cryptsetup: ERROR: (luks-07f23b4f-d170-4148-b8f1-60b1cec24d20: cryptsetup failed, bad password or options?
No Key available for this passphrase

Wow, so no one is going to help you?
I never got this problem solved either, mostly because life got really busy and I could just cope with it by booting in recovery mode. Is that the case with you too?

This is what it is doing. Any help would be great.

Ok, so for me once you get to this point there is little you can do. So turn it off and let’s start from the beginning.
You should be asked for a password to decrypt at the beginning of boot. Hit anything (for me putting in my decryption key never worked) and then immediately after hitting enter, hold shift. This should bring you to a screen with boot option. Select to boot in recovery mode.
See if that at least gets you somewhere where you can actually run the OS.
That’s the best I’ve got.

1 Like