PureOS won't boot after upgrade, boots with recovery


#21

It may be that you’ve forgotten the password for the disk encryption? When you first ran the laptop you were likely asked for two passwords, one for disk encryption and the other for GNOME. The first one is the one that is being requested in that dialog your seeing.


#22

I have both passwords so I can I add my password for disk encryption? when I reboot it does not ask me for a password it just goes to a blue screen. I will include a pic.


#23

Also so I got the Librem Key with my laptop and its never worked like I have seen in videos


#24

At that blue screen you can simply hit return for it to boot into “PureOS GNU/Linux”


#25

Yep when I try that it does like the first picture I uploaded. Same as with recovery.


#26

Yea, at that blue screen, go to the second option “Advanced Options for PureOS”
That should take you to a second screen. Look for a ‘recovery mode’ option. There might be more than one. For me, it’s the bottom one that works. Try them, see which one gets the system to boot.


#27

I tried that and only the one recovery and it did not work. At this point do I have to wipe it clean and start over? If so how do I do that?


#28

If nothing under the advanced boot options helps, then I can no longer be of any use.
Sorry. Good luck. Maybe someone else here can help you wipe and reinstall your system.


#29

This ISO has an installer on it: https://pureos.net/download/
If you download that and treat it the same way you did your rescue disk you can install PureOS on top of your existing system. Please note that it will erase data on the disk so only do that if you are prepared to lose what data is there. I recommend a back up if you can. Usually you can ‘mount’ the disk with the rescue disk so that you can examine the disk drives for errors, have you tried that with your recovery disk?


#30

I’m having this same issue. Just purchased Librem15 early January. The initial setup and login was fine, but after an apt upgrade, my system(kernel) went from 4.16 to 4.18(and eventually 4.19) I always get the crypt setup error message and no opportunity to put in my encryption pw. So then i just reboot, escape to advanced options(blue screen) and select the 4.16 kernel to boot into and everything works. So, no opportunity to enter any encryption pw during the boot process and i’m stuck using 4.16 until i can get this figured out. I looked in the forums and found a few possible solutions that did not work including modification of the /etc/cryptsetup-initramfs/conf-hook file to include the line CRYPTSETUP=y. I will continue to look for solutions, but i feel like this should be the right place to solve this issue. Thanks everyone.


#31

checked support wiki, already tried two of those, then checked support tracker and found this: https://tracker.pureos.net/T559. looks like we may need to modify and update /etc/default/grub. mine has the same bad entry in this tracker ticket. maybe this will help the other users here. check the last 4 comments from mak and jsbret.


#32

failed. :confused::slightly_frowning_face: continuing search to resolve “cryptsetup failed”.


#33

Funny. This is the same problem i had (see PureOS first impressions ).
Since the laptop was new, my solution was to install debian without encryption. Kinda sad really -.-

For me, it did not give any prompt for the decryption password and offerend to drop into a recovery shell (within initramfs).
Choosing the “recovery mode” from the boot options did not help - it showed the the same problem.
Also in grub there was no option to use the previous kernel version.

The only really good fix here is to provide instructions on how to either

  • manually unlock the partition from within initramfs (busybox + cryptsetup + some other tools) and continue with a boot
  • chroot into the system from a live dvd and unlock the disk offline

and then downgrade linux-kernel to the older version and prevent it from being automatically upgraded again.

Unfortunately I cannot provide you with these instructions since I had never used luks before and there is no documentation on how the encryption is set up in PureOS wink wink.

Edit: I will try to replicate the problem in a VM using the OEM images and try to find a solution. finger’s crossed
Edit 2: latest OEM image does not seem to like VirtualBox


#34

@belzman: I had an issue with LUKS with the OEM image when I took receipt of my 13v3. Ce n’est pas grave, just need to follow a couple of steps. I hope this works for you and I will do my best to follow this thread. Please forgive my nit-picky attention to detail. I do not want to make assumptions about familiarity with Linux.

  1. The first thing I did was go to pureos.net and download the latest ISO. I imaged it to a USB thumb drive via Balena Etcher on another laptop. if you are using Windows, then Rufus is a solid choice: https://rufus.ie/. I am less familiar with OS X but you may use UNetbootin or other techniques (dd if ya nasty!) here: https://superuser.com/questions/63654/how-do-i-burn-an-iso-on-a-usb-drive-on-mac-os-x.
  2. I booted into the PureOS image by hitting ESC and then 2 for the USB thumb drive I was using.
  3. I resolved the pop up by declaring my preferred language, keyboard, etc that the wizard placed in front of me and then once completed, I clicked on Activities to get the dock, and clicked the icon for the installer.
  4. I proceeded through each of the options until I get to the drive selection screen. Here I chose to replace the entire partition with a new one and I was asked to create a passphrase for my LUKS encryption. Once done, I completed the new few items of the wizard and waited for the installation to complete.

I really do hope that we can get you up and going so please reply back if you run into any other issues. Merci, merci.


#35

I am encountering the same issue. After upgrading and rebooting the boot throws a number of failed to decrypt errors without ever prompting for the password, but I have the additional joy of not being able to boot into recovery mode – I get the same error here. This is on a purism 13. Now my computer is unusable. I will most likely be installing a another os :confused: because none of the solutions here have worked and I am at a bit of a loss on how to proceed.


#36

5 months later. still no solution. 3 weeks ago i had some time off from work so i dedicated it to getting support via email. 1 command line / day for 5 days of things that i already did from reading the forums and still no luck. Then all of a sudden, no call no show. support has disappeared. So, if anyone sees negative information in social media regarding PureOS, this might be why. And if someone from PureOS tells me in social media to email support, i will refer to this. PureOS engineers are damn smart, but for some reason they are not going about this fix the right way. Identify the conditions that lead to this, have the user query their system to see if the conditions exist, and then execute the commands to resolve the conditions… I’m very angry right now because I told my wife she could get this awesome machine for me. Now she thinks its a lemon and linux is stupid. Great.


#37

While I admit it’s unfortunate that you’ve been having issues, is there something preventing you from reinstalling the OS? If you just want a working computer, that would probably be the fastest and easiest way to get going again.


#38

Thank you for seeing/replying to my post. The only reason that i haven’t done that yet is that i think its silly. I like to know the reasons why operating systems break and the solutions. And I like to execute the fixes. IF the conditions that cause the problem are known and there is a way to resolve, we do that, we fix it. It seems to me that its fixable, but maybe its not because of encryption related reasons. If its not, we just need to be flat out told that we MUST re-install. I also find the one command at a time process painstakingly slow. I’d rather provide some diagnostic info about the system so that the PureOS team can identify the exact solution. Unless the exact solution is unknown, which would also be beneficial information. I will figure out how to back up and re-install. That brings a new issue: how does that impact my Librem Key? should i address this in a different post? thanks again.


#39

Ok, trying to catch up on this thread. I doubt I’ll be able to help, 'cause it seems like you know at least as much as I do, but just to confirm:

  1. If you try to boot normally, it fails and gives the cryptsetup error
  2. You can boot into recovery successfully
  3. Booting into recovery and re-running sudo apt update && sudo apt full-upgrade still leaves you with a broken system
    Edit: 4) And you’ve tried these steps? https://tracker.pureos.net/w/troubleshooting/broken_upgrade/

Is that right?


#40

That is mostly accurate. Instead of 2. Booting into recovery, i just boot into my original kernel: 4.16.02, since its available in the advanced menu and still works. I assumed that this was just as good as recovery mode when re-running update/full-upgrade. Which yes, still leaves broken system(cryptsetup error). so for the most part, yes, that is right. additional note: i have executed several full-upgrades that try to boot using the latest kernel(first 4.18, then 4.19), but they all fail; booting to 4.16.02 works fine, no recovery mode required. I’m running out of time today for this today, so I will try to compile the solutions attempted to date by this weekend and add them to this forum or another email support ticket. then i will investigate a re-install.