PureOS won't boot after upgrade, boots with recovery


#41

Can you paste the cryptsetup error as well? I’ll look for it in the thread but it would be good to confirm.


#42

Have you tried getting past the cryptsetup errors by modifying /etc/default/grub?

# GRUB_ENABLE_CRYPTODISK=y

Is what works for me. You’ll have to run;

sudo update-grub

afterwards.


#43

I do have that commented out line in my grub file: # GRUB_ENABLE_CRYPTODISK=y
i’ll have to follow up later with my exact cryptsetup err msg. (something like LUKS … cryptsetup failed. then a bunch of failed log ins, drops me to initramfs. at no point during the time the boot messages are scrolling can i submit a login)


#44

submitting to support@puri.sm since forum not designed for support. Tried this couple weeks ago and haven’t heard back since 6/16. putting ATTN Jeremiah in content of email.


#45

Just to be explicit: when you login using the 4.16.02 kernel, you have run sudo update-initramfs -u and it doesn’t fix anything?


#46

I believe i did try that last week. I will try again.


#47

Yes i ran sudo update-initramfs -u and it did not resolve this situation. For reference to this issue, from 2015! This is greek to me. so i’ll need help interpreting: https://unix.stackexchange.com/questions/164403/unlock-luks-encrypted-debian-root-with-key-file-on-boot-partition


#48

You see this same error?
cryptsetup: WARNING: target sdaX_crypt uses a key file, skipped.


#49

What is the error on your machine? Can you take a picture or write it down?