Qubes on Librem Mini

without seeing the boot menu and knowing what you selected, can’t determine much because SeaBIOS prints ‘booting from hard disk’ for SATA/NVMe/USB alike. I use Gnome disks to write USBs almost exclusively, shouldn’t be a problem as long as you ejected when done

updating coreboot test version work for me, i was able to install qubes 4.0.3

1 Like

that’s just it. it doesn’t respond to the usual keys “del” “F2” “Esc” “F12” etc. that other BIOS use. in other words i can’t select and see anything beyond this screen i attached. this is what i see for 60 seconds before it starts the whole thing all over gain …

i always eject any drive just to be sure that it doesn’t do anything at the moment i unplug …

only ESC brings up the menu. Hitting it more than once (ie, spamming it) will cause it to auto-boot from the first device in the list. If it’s not responding to ESC, then likely a keyboard compatibility issue – try another port, another port type, or another keyboard

so WHEN should i press it ? before the text appears or after it has appeared ? is it a light stroke or a more continuous tap ? you know this is ridiculous that this thing happens in 2020 (almost all BIOS/UEFI motherboards i have had access to enter the firmware options by keeping pressed or repeating-presses of the “DELETE” key before the boot-manager can select one for the user)

my keyboard is universal - the firmware is free-software > https://github.com/UltimateHackingKeyboard < there should be NO reason why it wouldn’t work but i do admit i have had it and the mouse BOTH plugged in in the two usb 2.0 ports available on the FRONT side of the LMini (where the power-button is)

will flashing pureBOOT on the LMini help at all ?

Refer Pureboot - How do I see the OS Boot Menus? ?

This seems a bit design-buggy. With most BIOSes, since you can’t be sure exactly when to press the key, and you don’t get absolutely immediate feedback that pressing the key has worked, whatever key is used to bash on in order to get into BIOS (/ or boot disk menu), must have no meaning within the BIOS (/ or boot disk menu).

This contrasts with, say, the GRUB menu, where you have exact feedback on the screen as to what’s going on, what to press, etc. - assuming that you choose, as I do, always to display the GRUB menu (for X seconds).

‘Del’ for the BIOS is pretty standard. The boot disk menu may not be. I have three computers here encompassing three different keys (each of them an Fx key) to get into the boot disk menu. How’s that for poor standardisation?

1 Like

the thing that’s troublesome is the fact that there is no reset button next to the power-on/off one on the front of the LMini so it takes extra time to reboot if i miss the key-press in order to get into the firmware and select the thingy (assuming that one exists in the LMini out-of-the-box firmware)

ctrl + alt + del is what triggers a system reboot but this key combination is not responsive when the screen i attached above is reached … is there another key or key combination that FORCES a reboot so i don’t have to waste 1 min before the whole thing is automatically triggered again ?

obviously i have NOT reached that far yet since i still have to install PureOS to disk first but since PureOS is based on Debian then this should be the case no ?

Debian 10 Buster GRUB boot menu is briefly visible for a few seconds during the init steps …

should i start a new thread and link to this one ?

Indeed. Understood.

this shouldn’t be the case for Purism products since they are quite standard in terms of what firmware they use and WHO implements that firmware …

it’s ALSO clear to me that i am confused about what triggers what when i write describing what i INTERPRET is happening on the screen during this whole process but please bear with me and inform me where i mean one thing and write another :slight_smile:

1 Like

@MrChromebox to make this a little more clear

i need to be able to select temporary in the firmware/BIOS settings on the Librem-Mini that allows me to make a temporarily-enforced-selection from a list of externally connected USB-bootable devices (usb2/3/etc/doesn’t matter) - UEFI is not a concern here since PureOS is a pure os :slight_smile:

in other words to be able to substitute the “booting from floppy …” to "booting from inserted-my-external-device-choice-here … "

I don’t understand the confusion. You need to bring up the SeaBIOS boot menu to select a USB. You need a working/compatible keyboard and to not spam the ESC key, just press it once when the prompt shows – it’s that simple.

That’s for Pureboot, not the standard coreboot/SeaBIOS firmware, which the provided pictures indicates is what is in use here

that’s not how SeaBIOS works though – it provides a clear indication of what key to press and when (as does the Purism boot splash screen, which the Mini will have in the next release).

1 Like

Oops. Sorry.

that is exactly what i have done. followed your instructions to the letter and pressed the key “ESC” only once immediately after the text prompt appeared …

i even went a bit further and tried different combinations of usb ports + 2 different bootable storage media that i created with GDisks.

i will mention that BOTH storage media (one usb 3.0 128gb thumb drive from kingston and one external usb-3 to SATA SSD 128gb from Patriot) ARE working perfectly on another UEFI AMD desktop machine and i have been ABLE to select and boot into the PureOS LIVE environment. this with the EXACT SAME keyboard + mouse + display cable + monitor i used to connect to the LMini (that did NOT work as i described earlier)

so the question/mystery remains … why is it working PERFECTLY on ONE machine but not with the Librem Mini ?

@MrChromebox what is bugging me is if this weird thing is happening because i added my own RAM + storage combo instead of the options available from the Purism Online Store ?

my combination looks like this :

1 > RAM > Kingston hyperx DDR4 2400mhz 2 modules (16GB each) < they fit and look very nice in black

2 > storage > https://www.westerndigital.com/products/internal-drives/wd-red-ssd < the 500 GB m2 SATA variety (80mm length)

and just to be clear, when you do that, the boot menu does not appear, but the box proceeds to attempt to boot from the default/highest priority device (internal storage by default)?

If that’s correct, it has nothing to do with anything other than your attached USB devices, most likely the keyboard itself. How they behave on another system is irrelevant. SeaBIOS has its idiosyncrasies.

indeed that is what is happening. it is trying to boot from the floppy (lol) < like the screenshot above shows < so weird

you know this makes me want to try with another keyboard (different type/model) just to see if this is ACTUALLY the case … if it IS then SeaBIOS is weird lol (or just primitive)

indeed the boot menu does not appear

it’s weird but expected :slight_smile:

please do, this isn’t my first rodeo, or first time debugging keyboard issues with SeaBIOS. Once you have a working keyboard and can install an OS, then we can reattach the non-working one, do a default boot, and then pull the firmware boot log to see what’s going on. If needed, I’ll have you flash a test build with more verbose logging for SeaBIOS so we can try to resolve the issue.

1 Like