Recently can't send MMS anymore

I’m still unable to send group SMS or send or receive group MMS or send MMS to a single person. I’m on T-Mobile. I emailed Purism support a few days ago and I was told that MMS is proven to work with SIMple, so I was planning to switch….🫤

For t-mobile can you try these settings;


In in: chats > preferences > SMS and MMS settings, then press apply at the upper left corner.

And let me know if this worked.

1 Like

Just rebooted phone sent MMS to/from phone and I see
purism@pureos:~$ sudo mmcli -m any --messaging-list-sms
No sms messages were found

1 Like

ok, this means that there is no pending inbound message in the modem. Did the other phone received the MMS?

1 Like

nope, other phone didn’t receive MMS.
How do I check if mms is even enabled? (which service should be running?)

1 Like

Settings in Chatty prefs and Mobile prefs are what you gave. I am sending .jpg files to iPhones but these are not being received.

The other subscriber is also on T-Mobile. I can receive images that the single person sends to me. They can’t see pictures I’m trying to send to them.

MMS is completely fine with SIMple.
I had to re-flash the phone and now everything is good.


I reflashed my L5, with updated chatty version 0.7.0rc5, mmsdtng version 1.13.0, system: Linux pureos 6.1.0-1-librem5 and sending and receiving SMS/MMS began working with T-Mobile.

However, about a week ago, my ability to send SMS abruptly stopped, although I could still receive SMS.

When I took the SIM card out of the L5 and reinserted it back into the iPhone, interestingly the SMS generated on the L5 was then subsequently received by the other party.


For me there are messages stuck in my modem:
/org/freedesktop/ModemManager1/SMS/139 (receiving) /org/freedesktop/ModemManager1/SMS/138 (receiving)

I have chatty 0.7 and mms-tng daemon 1.13 installed, using Awesim T-Mobile backbone. Issue same as previously reported no out or incoming MMS.

Tried to build 1.14 to see if there is an improvement but getting lots of compile errors pickle.load object etc

I should also mention that on the client side my side chatty spams the conversation with mms messages that failed to send every time i think you open up chatty. That has been an issue though for ~ 1 year so probably known.

Message: You received an MMS, but it expired on: 1970-01-01 08∶59

Message: You received an MMS, but it expired on: 1970-01-01 08∶59

If you receive the contents of the MMS, it will be displayed above. Is there any problem?

check your system date, if it is correct.

The date is right.

After updating, click on a person with many Chatty messages from the list to forcibly terminate Chatty. Help me.

Are you saying that chatty blocks on conversations with long messages?

After the OS update, chatty crashes when I try to open messages only for my wife who sends SMS messages in chatty. I can’t read the message inside. I can read the contents of other people’s messages because the number of messages is small. Only my wife is sending and receiving 300 to 500 messages, so for some reason chatty crashes when I open it. Please help me. Please.

Everything being equal as of March 2023 i have ordered a new L5 BroadMobi modem BM818-A1 using AWESIM and installed it in my existing L5. I did not change anything but the modem and the kernel, and Chatty software was otherwise identical, MMS (e.g. sending jpg pictures to a single person ~200KB size) works now. In addition when placing a call it is now ringing, which it did not do before all settings being equal. So to me that means that either the original modem P/N: BMCM1DOE1ACDB325 had a hardware defect, or more likely had older firmware installed from the factory (~2019 firmware based on L5 shipping date), compared to my new BM818 modem, shipped 2023 that has newer firmware installed (2020+).

My recommendation to Purism would be that all old BM818 modems with 2019 firmware need to be reflashed with 2020 plus firmware for AWESIM, or SIMPLE Purism plan users on T-Mobile because it appears to work slightly better with mms and haven’t noticed any downsides yet. Providing the procedures online or on this forum to do so may resolve a lot of peoples issues and time consumed trouble shooting. I have looked on the Broadmobi website, but didn’t find any firmware or instructions on how to upgrade the firmware.

This suggestions aside i find Purism documentation to be world class and way better than what i have seen produced by Windows or Apple.

Interestingly receiving images of ~1MB from another iPhone user still does not seem to work but that could be related to many other MMS type receiving parsing issues. I sent myself a 1.6MB .jpg image and that was sent and received just fine.


Yes, this too was my experience also, after installing a newer BM818-A1 modem. Unfortunately, the other bugs in the ointment, for me, are now the random, occult modem disconnects, so I’ve switched back to iPhone, for now. Others have posted scripts to alert any modem disconnect. I’d rather wait for a real fix, but I don’t know when that will happen.

Maybe soon: Cell modem failing? et seq

1 Like