Running Jupiter Hell which uses Vulkan on PureOS


#1

Anyone had any luck with this?

I’ve not tried running it on any other Linux distro. I’m pretty sure it is some proprietary software I need to run it, but I’d appreciate it if someone could tell me the repo I need to use to get it.


#2

I haven’t tried it, but the requirements for SteamOS + Linux are

MINIMUM

  • Requires a 64-bit processor and operating system
  • OS: 64-bit
  • Memory: 8 GB RAM
  • Graphics: OpenGL 4.3+ compatible
  • Storage: 2 GB available space

RECOMMENDED

  • Requires a 64-bit processor and operating system
  • OS: Ubuntu 16.04 64-bit
  • Memory: 8 GB RAM
  • Graphics: NVIDIA GeForce GTX 960 or better
  • Storage: 2 GB available space
  • Sound Card: DirectX compatible sound card

So I’d say check your OpenGL version if you’re not using an NVidia graphics driver.


#3

Thanks! Clearly it is the OpenGL drivers. Do you know how I can update them? I am assuming if there was an update for it then my continual apt updates would have already snagged it.

Do we know what the Librem 13 and 15 can officially support as far as OpenGL versions?


#4

On my ol’ lappy

[ruff@trx trunk]$ glewinfo | head
---------------------------
    GLEW Extension Info
---------------------------

GLEW version 2.1.0
Reporting capabilities of display , visual 0xd0
Running on a Mesa DRI Intel(R) Haswell Mobile  from Intel Open Source Technology Center
OpenGL version 3.0 Mesa 19.2.1 is supported

#5

Same here.

Whelp that solves it then. Bummer.


#6

I don’t know how much the Librem 13 and 15 have changed since they came out, but they are currently listed as having Intel HD Graphics 620.

Which does support OpenGL 4.5 and Vulkan 1.1.93.
I haven’t run PureOS yet, but as a Debian derivative, it would be doable. The trick to doing it nicely would be knowing what version of Debian to base things off of.
Can you run this from a terminal?

$ cat /etc/debian_version

It may be as simple as grabbing a Debian package, but could easily get more complicated if dependencies are involved.
More useful information on how to figure this out would be in the sources.lists file, which is where updates come from.

$ cat /etc/apt/sources.list

You don’t need to list the contents of that for us all, but if you could list the unique domain names that would be handy.


#7

Believe the v3 models are on HD Graphics 520, which support 4.4.

Debian version is buster/sid,

sources:
deb https://repo.puri.sm/pureos amber main
deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free
deb https://repo.pureos.net/pureos/ amber-security main
deb https://repo.pureos.net/pureos/ amber-updates main


#8

Actually it’s a bit more complex after reading latest developments.

[ruff@trx trunk]$ glewinfo | grep GL_VERSION_
GL_VERSION_1_1:                                                OK 
GL_VERSION_1_2:                                                OK 
GL_VERSION_1_2_1:                                              OK 
GL_VERSION_1_3:                                                OK 
GL_VERSION_1_4:                                                OK 
GL_VERSION_1_5:                                                OK 
GL_VERSION_2_0:                                                OK 
GL_VERSION_2_1:                                                OK 
GL_VERSION_3_0:                                                OK 
GL_VERSION_3_1:                                                OK 
GL_VERSION_3_2:                                                OK 
GL_VERSION_3_3:                                                OK 
GL_VERSION_4_0:                                                OK 
GL_VERSION_4_1:                                                MISSING 
GL_VERSION_4_2:                                                MISSING 
GL_VERSION_4_3:                                                MISSING 
GL_VERSION_4_4:                                                MISSING 
GL_VERSION_4_5:                                                OK 
GL_VERSION_4_6:                                                OK

#9

Interesting if the debian_version file lists buster/sid and the sources.list file is pointing to stretch. I think Ubuntu does something like that too, but they don’t point to Debian repos at all, naturally.

Yep, I confirmed this.

@ruff You’re old lappy is a Librem v3 model, yes?

Weirdly conflicting.


#10

No, it’s old ultraportable asus with haswell core i5. I never had librem laptop. Haswell should not support above 4.0 although there were some messages about bringing it up to 4.5


#11

Ahhh, ok.

Intel says they support OpenGL 4.4 on the HD Graphics 520.

Looks to me like the solution is to include the stretch-backports repo as you can get the latest vulkan drivers available from Debian that way.
That said, I haven’t looked through the Purism repos for anything which might conflict, specifically for dependencies. At a glance, that’s not a small feat.

This might be viable test too.


#12

For convenience, here is the link to adding backports, should you want to explore that and aren’t familiar with it.


#13

For what it’s worth, I’ve actually been playing this exact game on my Librem 15 v3 (with low graphic settings) using Pop OS 19.10. The hardware is good enough and the game is so worth the effort.

So that glewinfo command isn’t telling you what you think it is. Try this command instead:

$ glxinfo | grep -i "core profile version string"
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.2.1

OpenGL 4.5 on my Intel HD 620 here and the game runs well enough to be playable at low detail.


#14

Agreed. It is a great game. I’ve been playing the heck out of it on every little break I can find. Not surprised about Pop OS working. Based on Ubuntu, and Ubuntu just runs everything. However, PureOS is just so fast. I mean it just blows Ubuntu away with how responsive Gnome is on the Librem.

So I installed the mesa-vulkan-drivers, and restarted for good measure. Still crashing when trying to launch using vulcan and opengl.

I think just getting the updated OpenGL drivers would do the trick. Not really sure how to acquire them though.


#15

What do you get when you run :

$ glxinfo | grep -i "core profile version string"

The latest mesa driver from backports ( 18.2.8 ) should give you OpenGL 4.5.


#16

yep, this is the output:
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.6

Guess it wasn’t just drivers, but something else. I’ll putz around with it some.


#17

What errors are you getting?


#18

The game just crashes on start with a prompt to send the crash log to the dev team.


#19

If you know where/how it’s installed, you can run the same executable from a terminal and probably get lots of information about what’s wrong.
Also, check the system logs, specifically, Xorg.log, syslog and kern.log.


#20

The crash log says:
00:00:00.20 [CRITICAL] Video mode set failed: Installed Vulkan doesn’t implement the VK_KHR_surface extension

So it seems like the Vulkan driver under the vukan engine still is missing something in its implementation.

This is critical error when trying to run the OpenGL version:
00:00:00.18 [CRITICAL] Video mode set failed: Couldn’t find matching GLX visual

Once again something missing in the drivers implementation, or rather something missing in this distro.