Straight out of the box problems with fresh PureOS install

Received Librem Mini v2 in the mail yesterday. Upon startup and system configuration/OS install, seemed to be working (though wasn’t too happy about the compulsion to encrypt the disk… which may be contributing to my current problem).
However, at present, the main tasks which I was setting out to do with the system as-is are not feasible (“Boxes” crashed, and persists in having issues, so VMs are temporarily a no-go); the “Software” program per the GNOME suite fails to remove any application through the GUI, giving an error that “there are no packages to remove” for given app; the OS update option also gives the readout that there are unmet dependencies, but fails to list what dependencies are missing; upon sudo apt update, and sudo apt upgrade via terminal, all of the non-up-to-date software is shown as updated, but the status of PureOS as deprecated persists as outlined; upon both system restart and power cycling, the boot menu cannot seem to be accessed—as outlined here —and eventually, the system has got stuck on the loading bar for PureOS before user login; inconsistently, during startup the system will display the checking filesystem routine, and other times straight into the PureOS overlay after decrypting the disk. Those are the only problems I have found thus far. I emailed the Purism technical support staff yesterday, and as-of-yet have received no response. Any help would be much appreciated. I do have other HDs, so if this one is not usable and help not forthcomign, I will just take it out and start from scratch.

Edit: I neglected to mention, that during system initialization, it does (very briefly) say there is missing firmware. I have already checked the wiki, the forum, as well as other documentation, FAQ, etc. If I have merely missed something applicable, pointing in the right direction would be helpful.

2nd Edit: Can wipefs solve this issue, or will that potentially cause issues, since the disk has been encrypted?

3rd Edit: upon testing to see if I could remove certain applications via terminal, it gives the readout that it cannot locate the packages.

1 Like

This sounds very frustrating. Per other reports on the forum, the Purism support staff are probably busy or unavailable for the weekend.

I’m just some forum user, and not in any official place to give advice, but if I were you I think that I would probably:

  • Reinstall PureOS freshly on the hard drive to ensure that there is not any software issue in the current installed system (assuming that you’re still using the software install that was present on the device when it arrived)
  • Then if the clean software still doesn’t work, you have good data that it’s a hardware problem to keep pursuing help from support, who probably won’t be available to reply to you for at least 24 hours. I am not affiliated with Purism in any way, and I am simply making up that prediction based on nothing.

I don’t have a Librem mini but I have a Librem 14 that I received a few months ago, and it has been serving me quite well, although I decided that the encrypted hard drive does not bother me and was largely ignoring it. At some point, although nothing was wrong on my device, I reinstalled PureOS and the new install has been working just as well for me, minus the fact that on the boot screen there is a message about two modules missing that flashes on the screen for a fraction of a section. But, as far as I can tell, the device is still working fine so I have ignored the issue and not gone to get a camera to take a picture of the module names and look them up. (They go by really, really fast.)

In any case, PureOS has been working well for me so I figured I would add these thoughts. But, I also have always been updating from command line and no through the Software app. My device surely never reported that I had unmet dependencies, though.


I appreciate the recommendation. Perhaps I simply don’t know, but wouldn’t I need to be able to access the boot menu to do so? That is part of the problem.
The ‘esc’ key does not allow me to gain access to the boot menu, as described here. I am having a different issue. Upon system startup, the first thing I am presented with (just to be clear) is the decryption passphrase input screen; afterward, the graphical overlay for PureOS starts up, and if I press the ‘esc’ key at this juncture, it just takes me to the black screen listing the individual tasks being performed on system initialization. I have tried all the ‘f1-12’ keys, and holding down the ‘shift’ key (per the debian documentation, since PureOS is based off of it, I thought I would try…) but nothing helps. I also do not see any text displayed in the graphical overlay detailing how to gain access to the bootloader/boot menu. As such, how then would I reinstall the OS, if I am unable to gain access to such menu, in order to switch the bootable device? Perhaps I am missing something… I have never had this kind of an issue with a linux install before.

Edit: this is why I was wondering if I should just wipe the filesystem. I am reticent to do so, however, after reading posts to this effect. I don’t need the disc to be encrypted for my purposes. But now that it is, I want to make sure I won’t just be causing more hassle for myself by trying to fix this issue… whatever it is.

1 Like

Sounds like the Coreboot menu with the Purism logo splash screen is not displaying. You may want to reflash your boot firmware with Coreboot to see if that solves your issue.

After following those instructions, you should be able to press Esc to access the boot menu.

One issue at a time.


Thanks. I will look into that.

1 Like

Haven’t really had time or energy to focus on fixing this around my school schedule, but maybe the following is part of the issue? Just noticed that sudo apt full-upgrade gives readout:

E: Failed to fetch Could not resolve ''
E: Failed to fetch Could not resolve ''
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Any thoughts? I am talking with support as well. Appreciate the help.

Edit: following the recommendations on 3rd error line yield no results, gives same error for sudo apt full-upgrade --fix-missing, sans “maybe run/maybe try” comment. apt-get yields no errors, but also no results.

2nd Edit: I am going to look through the arch wiki’s systemd page to see if I can’t figure anything out, since there seems to be some kind of issue with it…?

1 Like

Do you live in a country where is blocked, or is your Librem offline?

1 Like

I am in California, same as the Purism company. The Librem is online.

Edit: Partial solution provided by tech support…

sudo apt clean
sudo rm -rf /var/cache/apt/*
sudo apt update
sudo apt full-upgrade

PureOS now shown as updated. Repo conflict is resolved. Applications in ‘Software’ app still show splash text: “Unable to remove [APPLICATION]: no packages to remove.” Was able to remove “cheese” via terminal, however, many others still output:

E: Unable to locate package [PACKAGE]


1 Like

You need to uninstall the software from the command line (Terminal)
Sudo apt remove [[package-name]]

1 Like

Was able to remove “cheese” via terminal, however, many others still output:

E: Unable to locate package [PACKAGE]

Edit: obviously, a typo in the terminal input (“vidos”, vs “videos”; this was corrected; I have same output for all applications, save for “cheese”, thus far)

1 Like

That looks like fairly agricultural syntax. It simply isn’t right.

Regardless, the key point that you are missing is that (unfortunately) every package has two names.

  1. The name that might get displayed on a GUI.
  2. The actual name of the package.

To remove a package via terminal, you have to know the actual name of the package, and that can be difficult to achieve, and may even involve guesswork unless you really want to deep dive. So I guess it depends on how much time you want to put in to removing software, which in turn may depend on what your reason is for doing so.

Edit: Adding: To help you on your way, Parental Controls, which I also want to remove from my Librem 5 (I have no need for it and disk space is a lot tighter) requires

sudo apt remove malcontent


Well, my reason for doing so is to create a linux environment in which I have installed only those applications that I would actually be using.

I appreciate your input, and I will work on my syntax. That issue notwithstanding, I am still having persistent issues unaddressed. I cannot access the bootloader menu and switch to other bootable devices.

What I have been told, and read in the other forum posts, is that the ‘esc’ key is what is pressed to access the boot menu. That simply is not true on my machine. I am looking into the comment made by user FranklyFlawless, concerning reflashing the coreboot firmware, as stated here.

What I see upon system startup is the following:

  1. Hard drive decryption prompt;
  2. Loading bar with no text;
  3. PureOS splash graphical overlay;
  4. User profile select/login;

and between steps 2-3 I can press the ‘esc’ key to access the kernel init script (black screen, green text, etc.), nothing more.

As I have already stated earlier, upon attempting to update PureOS and/or any of the preinstalled apps via the ‘Software’ application, it declared that there were unmet dependencies; furthermore, that the packages cannot be found for individual applications. As adding/removing programs is the sole purpose of the ‘Software’ application, if it is non-usable for that intended purpose, I have no use for it. I seek to optimize the system.

Switching to the terminal and inputting:

sudo apt update
sudo apt upgrade

I found that the ‘Software’ application still listed the PureOS update as pending. When trying to complete the update via the app, it would display a similar message of “unmet dependencies”, but fail to display what those dependencies were, for the message being cut off.

This was addressed by help from the technical support staff, as stated earlier, here. I am also experiencing erratic behavior of the operating system, such as the ‘Software’ program being opened while I am running ‘Tweaks’, specifically when I am in the “extensions” menu. I do not know what to attribute these all to.

Edit: my mistake on that last one (see edits).

1 Like

You would be pressing Esc earlier than that. To take a step back though, there are two possible firmware options: Coreboot and Pureboot. Have you stated which of these you are running? Which did you specify on your order? Sometimes it can be helpful to post a photo of the first thing that comes up on the screen.

Is there anything unusual / demanding about your monitor? Can you try a different monitor?

1 Like

If you mean that it should appear before the decryption prompt, then I suppose it would likely be the monitor. I do not have another monitor at present, so I would have to deal with that some other time.

Edit: it is an older monitor. I will see if it makes a difference trying to press the esc key as soon as I power the machine on.

Also, it is pureboot that is on the machine. Thanks.

1 Like

Older is often better unless it is really really old. What video interface are you using with the monitor?

I don’t have a Librem Mini but looking at the product page, it seems the options are:

  • HDMI 2.0
  • DisplayPort 1.2

(and for either of those options, up to 4K @ 60Hz)

which should be more than enough for an older monitor.

I guess another thing to check is the video cable even if you don’t have another monitor to try.

1 Like

I guess it depends how old is really old. I think it is a 2011 monitor. It is using a vga output to a Rankie vga-to-display port adapter. I originally was using this monitor for a dell optiplex 5055 that I have had for a while, however I bought the monitor and the computer separately. I didn’t realize how much older than the computer the monitor was, so when it arrived in the mail I decided to just get an adapter instead of returning it.

Thanks to your input, I did notice something odd. Namely, if I time the pressing of the ‘esc’ key shortly after the computer turns on, the monitor simply won’t turn on at all. If I leave it alone until the decryption prompt pops up, it will work fine. I may need to simply get another monitor. It worked fine for my other computer, and it works fine once PureOS has been loaded by default by the bootloader… but the monitor and/or adapter doesn’t seem to initialize/recognize/process the signal prior to that point.

If you think there is anything else that could be worth trying, I would look into it, but I don’t really know what else I can do presently.

1 Like

VGA is really old. I mean in theory it should work but there is much more scope for something not to work.

So to be clear … you are using the DisplayPort video output on the Librem Mini, going into a DisplayPort-to-VGA adapter, going into the VGA input port of the monitor?

There was a transitional period when monitors had both a VGA input and a digital video input of some sort (DVI, or HDMI, or theoretically DisplayPort). I take it that your monitor offers only a VGA input?

If you let it boot normally, what video resolution does PureOS report?

What about a TV? Do you have a TV that has either a DisplayPort input or an HDMI input?

Since the Librem Mini is so easily portable, can you take it round to a friend’s place and try a suitable monitor (or TV) there?

That is kind of expected. I would suggest: It shows that Esc is working. The boot firmware is stopping early on, because you pressed Esc, before even attempting to load an operating system, but due to some incompatibility between the boot firmware and the video output arrangements, you see nothing on the screen - and, unless you take some other action, the boot firmware will wait forever for you to do something.

In theory you could fly blind to continue the boot but as (I assume) you have never seen the boot firmware and don’t know what menus and options exist, that would be difficult.


If that is the case, Esc is not used during the boot sequence.

1 Like

So to be clear … you are using the DisplayPort video output on the Librem Mini, going into a DisplayPort-to-VGA adapter, going into the VGA input port of the monitor?

Correct. And it does have a DVI output. The monitor, however, was shipped with a VGA cable, so that was what I set about to using. I could see if there is any difference with the DVI port.

If you let it boot normally, what video resolution does PureOS report?

So like from neofetch? It reads out as 1920x1080.

I think I will take it with me, per your suggestion, to the computer lab at my university tomorrow, and put that hypothesis to the test. That seems the most likely explanation presently. You’ve been incredibly helpful, so thanks for the patience and willingness to walk through this with me.


Thanks for pointing that out. wouldn’t’ve figured out the main issue was (or at least seems to be) my monitor. Once I get it hooked up to something else, I can see if the issue persists, or no. You’ve been very helpful, so thanks.

1 Like