Terminal to clipboard

The thing is that with Librem5 in the terminal you can’t ctrl- anything as far as I know, and I did not found what is the right clitck.

Long pressing after selecting text just de-select the text. Long pressing anywhere gives you the option of select all ( which is not what you want) and paste (which is also not what you want).

And doing the select like in X does not put anything in the paperclip ( paste not available anywhere else after doing the selection ).

1 Like

oh yeah … it’s just now that i’ve looked closer and seen that you’ve posted under “Phones (Librem 5)” > converging on convergeance anyone ? :sweat_smile:


hehe yes that is beautiful :slight_smile:

1 Like

You have to install wl-clipboard from bullseye repository:

I tested it in Qemu with:
echo “123xcv” | wl-copy

The version in the normal pureos repository doesn’t work for me.
But I haven’t tried the version 2.0.0 from here yet:

Does it also work on your Librem5?


Yes version 2.0.0 works from https://packages.debian.org/en/bullseye/arm64/wl-clipboard/download

And also from http://repo.pureos.net/pureos/pool/main/w/wl-clipboard/wl-clipboard_2.0.0-1_arm64.deb

Thanks :wink:

That is the issue now the pass simple ui works with wl-clipboard and wl-clipboard-x11


Another method, that worked for me was:

Click on the globe-key and choose the “terminal” mode of the keyboard (which is standard in the terminal app, but also useful to switch to the extended keyboard or to have Cut-Paste functionality in other apps) …

… there we have ctl and up-down keys available and the “>_” key right side of the space-barr, which we click next …

so see the function keys, too …

… and by clicking “Menu” key, we get the copy / paste / select Menu.
I did not install anything for to get that functionality (Librem 5 Evergreen Oktober 2021)


You can use ctrl+c and ctrl+v. You can also just long press for a context menu.

1 Like

Works with other apps as well.

And the extended keyboard also shows the “Tab” key, which I find very useful within the terminal.

I tried that, but did not work.

Sorry, it’s ctrl+shift+c and ctrl+shif+v for the terminal.

1 Like

Didn’t work for me either.

Long pressing (not on the keyboard) brings up the context menu without having to switch between three different layouts.

It brings up the “paste / select all” menu. Then you choose “select all” …
and now?
Ctrl C / V does not work (for me). Hence - how to copy it. Clicking again helps nothing and the clipboard shows empty.

If you don’t need it of have an easier way, just don’t use it. :woman_shrugging:

1 Like

I see what you’re saying. Not very convenient to have to jump through those hoops in order to copy from the terminal.

1 Like

Sorry about hijacking this thread a little bit…

In general, using the Librem 5, how does a person select a portion of text in any application? For example, with gedit text editor running, there is a paragraph of text in it. I need to select just a couple sentences in the middle of that paragraph to copy to the clipboard. But I can’t figure out how to select that.


Sorry amarok, but if you were responding to me, I don’t see how that answers my question. Example:

I have a text file with this sentence in it -

The lazy fox jumps quickly over the brown log.

I open the text file and see that sentence in it. I wish to copy to the clipboard (so I can eventually paste elsewhere) the words in the middle of that sentence, “fox jumps quickly”.

How do I do that? I can’t figure that out.

It requires doing a long press until a word is selected, revealing selection tools under the word. Then you can drag one or both tools to the rest of the snippet you want.

Then in the keyboard, tap Menu to see copy, paste, cut, delete, etc.

Or use the little dialog box with symbols that pops up over the text.

It takes some practice. It helps to drag a little when doing the long press on a word.

If I do a long press in the browser on the text of your answer, I cant select anything. A menu pops up which me also does not select any item of its list. Just give it a shot on my text here in the browser.

1 Like

It’s tricky, and there’s a slight delay, too.

Maybe it’s more of a drag across the words than a long-press.

And it works more smoothly in Terminal than in the text editor.

Edit: Yes, it’s definitely a long drag, rather than a simple long press. Apologies.

Long press gets you this limited dialog (Select All, and Paste):