Test for Satellite flatpak app requested

There is a request in this issue to test Satellite on the Librem 5.

To test it do:

flatpak install --user https://dl.flathub.org/build-repo/21943/page.codeberg.tpikonen.satellite.flatpakref

I cannot test well myself because I fiddled to much with my location settings and I might have a broken GPS antenna.

1 Like

Hi @janvlug

I have just tried installing it from here https://flathub.org/apps/page.codeberg.tpikonen.satellite.
Does it make any difference?
Edit: I have now also tried to install it with the cmd you suggested. Same result, not working.

I guess it does not work on my L5. I see the following:

Yes, that is the unpatched version.

Furthermore, I just read the this comment by @jonsger on the issue.

I think you have to start the patched flatpak from the command line and add --source gnss-share.


flatpak run page.codeberg.tpikonen.satellite --source gnss-share --console-output

--console-output gives more info on the console, I guess.

For me it does not work though (but that might be because I broke my configuration), I get a popup with:

Error initializing NMEA source
Can you access "/var/run/gnss-share.sock"?
[Errno 13] Permission denied

And on the console:

Trying to initialize source "gnss-share"
[Errno 13] Permission denied

I get the exact same errors

1 Like

Where does one get this patched version? I have v0.4.0 from Flathub and was thinking about trying out GPS soon.

The command is in the first post of this thread. That is the patched version. Do not forget to add the ‘–source gnss-share’ when running the flatpak from the command line.

Let me know if you get it to work.

1 Like

I installed the PureOS flatpak version. No go. It does not request location services, and doesn’t display them.
‘Lock lost’, it tells me.

1 Like

It’s not going to work. You need elevated permissions to access gnss-share’s socket, and you’re not going to get those permissions from within flatpak containers.

1 Like

Then why is it in PureOS’s optimized-for-L5 flatpak repository?

The Satellite flatpak is an application independent from Purism. I saw it and wanted to use it to have some easy way to see the status of the GPS on the Librem 5.
The Satellite application project is hosted here.

Are you sure? Can you provide a link?

Someone reported that it worked. Not sure if it was on a Librem 5 though.

FYI: I think it does work after adding the default user purism to the geoclue group.
See here my results.

Well, yes, but this gives every application running as the user access to raw GPS data regardless of whether location services are enabled or not. chmod 777 would work too :wink:

1 Like

I don’t have a link, but if you enter ‘sat’ in the search box in the store, you will come across it.

The current state is:
To get Satellite 4.1 working you have to add the user (normally purism) to the geoclue group. This bad practice from a security point of view, but for GPS testing it might be handy.

To add the user to the geoclue group, do in a terminal:
sudo usermod -a -G geoclue purism

To remove the user again from the geoclue group, do in a terminal:
sudo deluser purism geoclue

Note that you have to reboot the phone to make changes to the groups where the user is in effective.

Make sure you have at least version 4.1 of Satellite installed.

You can start Satellite without any command line instructions via its icon, and it should work.

Unfortunately, Satellite confirms clearly for me that I do not receive any good satellite signals.

I’m reading about all the great navigation progress, so I will see if I can have the antenna connection fixed.

The weird thing is, that Satellite tells me there is ‘No Fix’ and there are no satellites visible (nor any bars in the display). Satellite says that ‘Source is none, model None’ and ‘Lock lost’.
Yet my location, both in Satellite and PureMaps is spot on. PureMaps is accurate to within a meter of my actual position; it’s spookily precise.
{Oh, and I switched off my wifi positioning.}

I would say there is something wrong with Satellite.

Hmm. Every now and then I get a fleeting glimpse of a few bars. Then they are gone again.

What I do get is 0/9 or even 0/13 active sats. Never more than 0.