Tor Browser does not start anymore


#1

Tor Browser does not start anymore. No Idea how to start it from cli to check for error messages.Tor Launcher fails in reinstalling.


Upgrade of Purebrowser fails
#2

location of torbrowser:

.local/share/torbrowser/tbb/x86_64/tor-browser_de/

starting

start-tor-browser.desktop

from cli worked.

tor shortcut using the “menu button” - is this the right term - does still not work.


#3

I’m having same problem . It is downloaded but won’t open. Can’t find any tutorials or videos anywhere


Is the Tor Browser Package in PureOS repos broken?
#4

The liberated pureos package does not seem to be working properly at the moment. If you don’t want to wait for them to fix it, delete the package then re-install, like so:

Remove:
sudo apt remove tor
sudo apt remove torbrowser-launcher

Add the following to your /etc/apt/sources.list:
deb http://deb.debian.org/debian jessie-backports main contrib
deb http://deb.debian.org/debian jessie-backports-sloppy main contrib

Reinstall:
Run sudo apt-get install torbrowser-launcher
Run your Tor Browser Launcher program
Go back and comment out or delete those lines from etc/apt/sources.list

You should now be able to launch, close and relaunch from the Terminal or the application icon.


#5

Just a little question … To ensure that I understand this corrrectly.

This is a bug with the TBB (or the Torbrowser itself) in the version in the PureOS package repo (“deb https://repo.puri.sm/pureos/ green main”), right?
When can a fix from Purism be expected (as far as I understand there is no general Bug with TBB just with PureOS)?

For the workaround:
When I add the sources @soundboard6 mentioned I probably should disable the PureOS repo temporarily for the installation of the jessie-backport version (I just tried it ones and I still faced the same issue - assuming that I installed the same version again). Correct?


#6

I don’t know about the first point.

I did not disable the PureOS repo in sources.list but to your point, I’m not sure how apt knew which version to pull. It definitely shouldn’t hurt anything to comment out the pureos repos as long as you are installing one are two specific packages. Just don’t forget to un-comment and comment out the jessie-backports before you update anything else.


#7

Ok Tor browser is working again (except that the sound is disabled in the new version but this is another topic).

So basically it worked like described by @soundboard6.
(I switched to root directly)

Remove existing tor browser + launcher:

apt remove tor
apt remove torbrowser-launcher

Add jessie backport repos to /etc/apt/sources.list (and disable purism repo temporarily):

# deb https://repo.puri.sm/pureos/ green main    
deb http://deb.debian.org/debian jessie-backports main contrib
deb http://deb.debian.org/debian jessie-backports-sloppy main contrib

Reinstall:

apt-get update    
apt-get install torbrowser-launcher 

Switch back to normal /etc/apt/sources.list setting:

deb https://repo.puri.sm/pureos/ green main    
# deb http://deb.debian.org/debian jessie-backports main contrib
# deb http://deb.debian.org/debian jessie-backports-sloppy main contrib

#8

Thanks for this. Do you have the address for the Buster repos? Is Tor also in there? Considering PureOS is based primarily off of Buster/Sid, I think it makes sense to download from there (if it exists yet).


#9

Can anyone get the Tor Browser, as downloaded from the PureOS repos, to work? My installation went fine but then nothing happens when I try to open the Tor Browser. How could this be an issue for so long (half a year+ now)? What am I missing?


Add an application (to favorites) to the Gnome dock
NewGuy, first day
#10

Download Tor browser package from their website:
https://www.torproject.org/dist/torbrowser/7.5.4/tor-browser-linux64-7.5.4_en-US.tar.xz

Extract the folder and open Tor using the start-tor-browser application.


#11

Thanks @eaoua, that works fine.

I guess I’m just curious why myself and others can’t get the program to work using a traditional install from the PureOS software repos.


#12

My terminal install (or install via Software application) acknowledges the install, however when I click on launch nothing seems happen no matter how long I wait.


#13

Exactly! That’s been the experience of everyone who has tried to install via the PureOS repos over the past 6+ months. Wonder when this will get fixed…


#14

Nothing makes it launch


#15

Tor Browser has NEVER started for me, so I gave up while dealing with other issues. This is on Purism hardware, too: a Librem 15 v3. Seems more than a little ironic since PureOS is described as being concerned with privacy and security. :neutral_face: Guess I’ll need to dig in with an unofficial repo.


#16

Yeah the PureOS repos version of Tor Browser hasn’t worked for anyone for 6+ months…


#17

Just to add here that I’m also unable to use Tor on PureOS by downloading from Purism’s repo. I had to download it manually from the Tor website. It works, but as someone who often forgets to upgrade software having it being automatically upgraded would be great.


#18

Added a comment to the PureOS bug tracker item related to the Tor Browser explaining our concerns. Hope this gets fixed soon!

https://tracker.pureos.net/T347