Trackpad lag:hardware or software issue?


#1

Coming from a Macbook I’ve started using my shiny new Librem 13 two weeks ago. I’m pretty happy with it, but the only thing that really bothers me is the trackpad. It “works”, but it’s not very precise, and it’s very laggy.

I now wondered; is this lag a hardware or a software issue? in case of the latter; is it in the driver or any higher level part?

If the lag on the trackpad could be reduced to the level of Apple laptops this would really be the perfect laptop. Does anybody have more information on this topic?

ps. if custom coding is required to solve the lag I’d be happy to chip in $1000. Maybe others would like to chip in as well?


#2

I experience the same thing, but most of the time the issue is when i drag something. When dragging it sometimes seem to lag or lock and sometimes what i drag gets dropped before i planned it.

I think it is a software issue as i find moving the cursor around the screen with nothing dragged to be consistent and precise (after getting used to the different “feel”), and i have had the same thing happen on most (if not all) “linux” os’s that i have used on various hardware.

Definitely agree that it is an issue worth focusing on as it makes a big difference to how i (and i think most “normal”/ non terminal happy users) find the overall laptop experience.

PS. Personally i also really miss the pinch zoom in/out function.


#3

I have two questions here:

  1. Are you using PureOS?
  2. Are you using tap-to-click?

I ask, because I’ve experienced none of these issue, and I’m using PureOS, and have tap-to-click disabled. I’ve had two Librems (a 13v2 and 15v3), and had the same experience on both.


#4
  1. Yes
  2. Yes, but will try now with it disabled. Used to tap-clicking though so guessing it will take some getting used to not doing that…

#5

Did not work for me. I definitely need tap-clicking!


#6

I had a similar issue on Debian, and purging the driver before reinstalling it made the problem go away. If I remember correctly, someone reported using libinput-gestures as being very responsive, so maybe downloading that package will help if the aforementioned tip doesn’t.

More info on those drivers: https://community.kde.org/KDE_Visual_Design_Group/Gestures (The Librem 13 has an Elantech trackpad btw)


#7

I have problem which could be described as a “lag”. (on new Librem 13 v2) Sometimes the touchpad gets crazy, the pointer does not move much, or jumps too far, makes random clicks (tap to click enabled), highlights text on the way and after while it’s better again. It seems to me as hardware issue.

I noticed the problem stops if I disconnect power adapter. I tried other power supply, but with that one it seemed even worse. I also opened case and checked if the touchpad is grounded properly. It is.


#8

If you can’t get trackpad responsiveness the way you want it using PureOS Settings, you can probably play with MinSpeed, MaxSpeed and AccelFactor options following the Debian Syaptics Touchpad Wiki

You might try playing with these in /usr/share/X11/xorg.conf.d/40-libinput.conf

There may be a tiny amount of lag at the beginning of a drag event, possibly while the system is trying to determine whether you really intend to drag, versus tap or click. But I am pretty happy after increasing the Touchpad Speed in Settings > Devices > Mouse & Touchpad.


#9

I just ran on battery for couple of hours and the touchpad worked perfectly smoothly. As soon as I connected the charger I experience problems which I described above.

Any Ideas how to fix it?


#10

That’s interesting, because in this thread the OP says when he’s using his trackpad, he gets “some minor electrical charge” while charging his laptop. :thinking:


#11

I don’t feel anything like that. I checked with multi-meter for continuity to ground pin of the electric socket. The touchpad surface is not conductive, but the shiny frame around it is conductive and grounded.


#12

Yes. I can also feel the “minor electrical charge” when charging. Have not noticed if its only when charging i have the problem (i have my laptop sitting on the charger most of the day)


#13

I have the same problem.

Is there any way to make touchpad in Librem 13 v3 more precise and accurate?

In every linux distribution (even PureOS) touchpad is almost unusable.

For that moment i have to use mouse to work but it shouldn’t be like that …


#14

Does the problem disappear when you disconnect charger and run on battery?


#15

Unfortunately no :frowning: Using this touchpad is so unprecise…


#16

It looks like when i’m using touchpad and suddenly remove fingers from touchpad (or stop moving fingers) - cursor is still moving for a moment. It’s something like lag.


#17

Following up on this thread, a recent apt update && apt upgrade has severely impacted the functionality of my touchpad. To me, this seems like proof that it is a software issue. I wonder if functionality would be restored if I downgrade the driver, but I’m not sure how I would do that

Follow-up: This may have something to do with the Intel Spectre microcode. After uninstalling, rebooting did not help, but after a full poweroff, touchpad functionality was restored!

Follow-up 2: After re-installing intel-microcode, I did a full poweroff and things still work. So the current theory is that if you install the intel-microcode, you need to do a full poweroff. Hope this helps someone!


#18

I recently got a new librem 13v2 and I’m stuck with the same problem, the trackpad has intermittently locked up in the past, but it generally “fixed itself” after a few minutes or a reboot. A few hours ago, however, it locked up completely and power-offs and reboots haven’t helped. I’m running PureOS and have done the customary apt update, upgrade, dist-upgrade, reboot dance, which also didn’t help.

@soundboard6 How did you re-install the intel microcode? I’ve tried using the official build_coreboot.sh script, but it has been running into problems for a while now, I can’t get it to build at all.

Any tips would be greatly appreciated. Cheers and thanks!

Update / Solution: Fn-F1 turned the trackpad on again, although I don’t recall having hit Fn-F1 before it stopped working.

Questions: can the Fn-F1 feature be disabled (trackpad always on) or would it be possible to add a visual hint somewhere. This also seems to be fairly low-level, as the trackpad was also disabled during boot (i.e.: before the login screen has loaded)


#19

@audegai Glad to hear you found a solution.

If you still want the Intel Microcode, try: sudo apt install intel-microcode More details on this thread

I haven’t tried disabling Fn features, but you can manage keyboard shortcuts in PureOS Settings -> Devices -> Keyboard

Let me know if you figure it out!