Trezor and Librem 5

Connecting the Trezor works on the Librem 5, with some manual steps. The easiest way is to ssh into the Librem 5 and run the commands there:

  1. Install the go programming language
    sudo apt install golang
  2. Follow these steps to clone, build and install udev rules
  3. I copied the trezord-go binary to ./local/bin
  4. Follow these steps here
    Make sure ExecStart is set to point to the trezord-go binary
    Set YOUR_USER to purism (or I guess it would be better to create a new user and let it run as that)
  5. Reboot phone
  6. Run: service trezord start
  7. Browse to


Awesome, @Jonas.

Would you copy your screenshot to here: List of Recommended Apps that fit and function well

I’ve written it into the list at the top. :slightly_smiling_face:

Edit: And also link to your instructions in this post, if you would like.

Appreciate the link Jonas! But let me ask would you trust dropping crypto onto your phone when the phone is still in experimental stage? I think this phone could be revolutionary and its why I jumped on board but if its up to me to hook my Trezor or Nano by typing code into the phone…I guarantee I`ll screw something up!! Thanks again for the response!

Looks cool Jonas!

Well, I wouldn’t be dropping crypto to the phone in this setup, it will still stay in the open-source HW crypto wallet. It would just work the same way that it works when I connect my Trezor to my Linux laptop. I wouldn’t say that the phone is an experimental stage, it is more in precommercial stage. According to me it will work. The operating system running in the Librem 5 is in now way near experimental stage, it is upstream Linux.


Or in the “pre-complete” stage?

hmm I know this was an old post, but I have tried this on the current libren5 but maybe something has changed… the go version I get from apt install is 1.15 and when I get down to the build I get

trezord-go$ go build .

“./trezord.go:105:24: info.Settings undefined (type *debug.BuildInfo has no field or method Settings)”

Anybody have any pointers on how I can get this to run on the librem 5 ?

I haven’t checked this for a while, but there is a trezor package in byzantium. You could try to install that. Then I think they moved away from the trezor wallet to trezor suite. Haven’t tried that either, but maybe its using the trezorctl binary that is included in the trezor package.