Update showing package can be upgraded

as I see this below issue is raised up again

the issue I created few month ago that after removing linux headers all working fine but is Linux Headers are important to install means for security purposes so after some hours he said to do update command and install then it worked now again this issue is arised.


Mark your answer as a solution.

1 Like

I don’t know this time where is the answer to my question
I Purged Linux Headers and afterwards updates are fine question is still pending why linux headers aren’t installing in PureOs distro again like it was happening few months ago see attached screen when I run

sudo apt install linux-headers-amd64

also I asked is Linux headers are recommended or will it comprise any security in my distro as I asked in previous thread and someone gave me solution but they simply said to sudo update and then run install linux-headers-amd64 command which is for now seems not working…


Hi all,

I have a similar problem: right after my yesterday’s update to 5.10.0-28-amd64 I get exactly the same error message:
The following packages have unmet dependencies:
linux-headers-amd64 : Depends: linux-headers-5.10.0-28-amd64 (= 5.10.209-2) but it is not installable
E: Unable to correct problems, you have held broken packages.

sudo apt-get purge linux-header* ,
sudo apt update , and
sudo apt install linux-headers-amd64

I still have the same error-message. This prevents my VirtualBox to start my VM…

What can be done to remediate this and how can we avoid to face a similar situation going forward?

Thanking you very much for your thoughts and information, I look forward to hearing from you.


1 Like

sudo apt-get purge linux-header*; sudo apt-get clean; sudo apt-get autoclean; sudo apt autoremove; sudo apt-get -f install; sudo dpkg --configure -a; sudo apt-get -f install; sudo apt install linux-headers-amd64; sudo apt update

1 Like

I am also having the same problem.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
linux-headers-amd64 : Depends: linux-headers-5.10.0-28-amd64 (= 5.10.209-2) but it is not installable
E: Unable to correct problems, you have held broken packages.

A bit out of my depth here, hoping for a fix. Any guidance would be appreciated.

EDIT: This does seem to be similar to the problem OP and I experienced in October 2023… discussion thread for that is here:

FYI I am on a Librem Mini (original flavor)

@joao.azevedo was able to help us then, but it seems his last post on this forum was in November 2023…

1 Like

Hi carlosgonz,

thanks a lot! Although - and unfortunately: no change: I have run all the above commands, with the same result when trying to install linux-headers-amd64…

As there seems to be a third user with the same problem, is this maybe a general system or data packet related issue?

1 Like

I have the same issue. According to this page the package is not installable: Binary package linux-headers-amd64/5.10.209-2 in byzantium @ pureos - PureOS Software.

Kernel module build failed during apt upgrade:

dkms: running auto installation service for kernel 5.10.0-28-amd64:Error! echo
Your kernel headers for kernel 5.10.0-28-amd64 cannot be found at
/lib/modules/5.10.0-28-amd64/build or /lib/modules/5.10.0-28-amd64/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
1 Like

As @n00ber highligted it is totally correct we asked this issue in 2023 and @joao.azevedo was able to help us then he told purpose of it is that they ship a DKMS module needed for the Librem laptops (librem-ec-acpi-dkms)

The driver librem_ec_acpi provides Linux kernel support for the ACPI embedded controller of the following devices:

  • Purism Librem 14 laptop

it was around Oct 2023 thread kindly look on it I pasted also below

1 Like

After this update on startup of PureOs it usually says error something related to Librem and also Linux headers are right now totally removed my questions are still pending

1- Linux Headers are recommended or something not recommended kindly give me suggestion.

2- If we install Linux Headers after this update it generates error what is the solution for it in future also because after fixing from forum it comes in some things afterwards.

1 Like

I had the same result as @SwissUser … ran all commands, still not able to install headers package.

@SabirSaleem70 I think headers may be optional, but having “purged” and so on I am concerned what would happen if I try to reboot without having headers installed.

Thanks @henhed for that link. Definitely something is missing from the repos…

I would hope that in future maintainers of PureOS would consider delaying pushing updates straight from Debian kernel until they are confirmed to be complete … but perhaps they already do? I tend to update as soon I as see them available… I could be more circumspect also!

1 Like

I’m having the same issue. I just sent an email to Purism Support. I’ll try to remember to post here what they said to do, unless they post here before I visit again.

1 Like

@n00ber : well, I need the headers to run my (Windows 10) virtual machine (via Oracle VM VirtualBox): without headers, this does not not work anymore…

1 Like

that would be great, thank you, @nochelibre

1 Like

@SwissUser ah I see… Sabir’s concern when this happened the first time (October 2023) seemed to be more about security, and for what it’s worth the package is listed on the repo page as “Priority: Optional” … but a VM use-case seems to require it.

Hopefully nochelibre gets some useful guidance!

1 Like

I didn’t her back from Purism Support after 2 days, so I emailed Mladen (Support Manager) directly late last night. I haven’t heard anything back from him yet, either. The issue with linux-headers-amd64 persists. :slightly_frowning_face:

1 Like

I have in the meantime also reached out to Mladen: he advised he unfortunately would not have any suggestion/workaround for this at the moment, but that he will point the PureOS developer to the forum thread.

So, hopefully we will hear from the developer next week.


Thanks @SwissUser! BTW, did you reach Mladen via email or some other way? I use a VPN and so my emails might get filtered by IP address-blocking software, and maybe that’s why I didn’t hear back from anyone yet.

1 Like

hi @nochelibre, hi @all,
@nochelibre : via email. Maybe you did not hear back because @all: the issue seems to having been solved: I just now I received a system notification about an update to be ready (linux-libc-dev): after installing it, I am now able to install linux-headers-amd64 successfully :smile: !

I will need to check later whether my VirtualBox / virtual machine does work again, too.


Yes this issue seems fixed today I run command for update now and it is installed successfully.

1 Like