Updating in the Software Center gives an error


#1

When I open the software center and click download on an OS update, it gives the error

Unable to download updates: The following packages have unmet dependencies:

and the rest of the message doesn’t display. When I open a terminal and log in as root, I can run apt update && apt upgrade and I don’t see any serious issues. It does say one package, lightdm can be upgraded, but then keeps the upgrade back. i’m assuming this is no big deal.

And probably the OS update is no big deal I would guess, but just in case I wanted to see if I need to do anything about this. Even after updating from the terminal the software center still reports that an OS update is available.

[Note: apologies if this has been reported elsewhere. Some other topics look a little similar to this, but often talk about details I don’t fully understand so I’m not sure if their issues are the same as this.]


#2

Sometimes packages get held back like in your case. In general, this is not a big deal as you say. You may chose to update (with the usual apt update command) and then do a full upgrade with a apt full-upgrade which bring all your packages up to date and should stop the warnings you’re seeing. If the warnings don’t stop, please report back here with any messages the machine is displaying.


#3

I run into the same as addem with the following error:

gusnan@pureos:~ > LC_ALL=C sudo apt upgrade lightdm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lightdm : Depends: logind or
                    consolekit but it is not installable
E: Broken packages

a apt full-upgrade simply says that lightdm has been held back.


#4

After running apt full-upgrade as root nothing changes. A further command to apt full-upgrade still attempts to upgrade lightdm and holds it back. When opening the software center, it still reports that an OS update is available, but when trying to download it, the same error message as above appears.


#5

You already know a little about what is holding things up. When I have had similar situations, however, I have “pretended” to force an install with -s:

 apt-get install -s <pkg>

I then start working down the dependency tree. I can usually find out exactly what versions are needed, etc. As you have found, there is usually some package that has not been updated in green (PureOS), but it helps to have the version numbers too.


#6

Ok, tried sudo apt install -s lightdm which returned

The following packages have unmet dependencies: lightdm : Depends: logind or consolekit but it is not installable

So after sudo apt install logind it returns

The following packages have unmet dependencies: libpam-elogind : Depends: elogind (= 239.3+20190131-1+debian1) but it is not going to be installed

So after sudo apt install elogind it goes through an attempt to install but eventually hits a line:

systemd is the active init system, please switch to another before removing systemd. dpkg: error processing package systemd (--remove): installed systemd package pre-removal script subprocess returned error exit status 1 Errors were encountered while processing: systemd E: Sub-process /usr/bin/dpkg returned an error code (1)

After a little searching to see what to do about this, I only find results that I’m not sure apply and if they do, I’m not sure how to follow their recommended fixes.


#7

I would stick with using ‘-s’ while trying this until you can point to something specific and note that I specified apt-get. I am not sure what a ‘-s’ will do with apt itself; it may ignore it.

Changing from systemd is outside my expertise. I looked at the “Packages” utility. Interestingly, systemd utility libraries are required for elogind, so your situation is puzzling. Maybe someone more knowledgable about this can help you further. Something does not make sense here.

At least you have a little more info.


#8

Are you trying to remove systemd? That’s not recommended.


#9

This Debian bug report gives more info (It’s rather technical though):

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=922160

Looks like there’s an upload coming that should fix this.


#10

I’m just following whatever instructions I find. And lo and behold, this has crashed the computer. When it boots I get a terminal, not a login screen. I log in, and it gives the message

`Linux pure 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64

The programs included with the PureOS system are free software…`

And so on, followed by a blinking cursor. The only thing I can do from here is follow instructions on a previous screen to issue systemctl reboot. Rebooting just takes me right back to the same place.


#11

When you’re at the cursor, try this command;

systemctl default

That should bring up a login.


#12

It responds

System has not been booted with systemd as init system (POD 1). Can't operate. Failed to connect to bus: Host is down

It now can’t reboot either. It responds to sudo systemctl reboot with the same message as above.


#13

You may want to re-install as I think you currently have no init system on the device.
https://tracker.pureos.net/w/installation_guide/oem_installation/


#14

Well, I downloaded the latest ISO, checked the checksum, used Unetbootin on a FAT32 formatted thumbdrive, put it in the laptop, hit exit to go to the boot menu, and it spent 8 hours overnight running some process I couldn’t tell what it was. I have no idea if I’m doing something wrong (entirely possible, I’m just grabbing random pages on how to install Linux) or if the computer is doing something weird. A picture of the screen is below.


#15

That screen shot shows the memtest program that tests memory under Linux on your Librem 15 v4. It should tell you if you have any bad blocks of memory.


#16

Is it supposed to run for over 8 hours? I shut it down assuming that couldn’t be right.