<USERNAME> is not in the sudoers file. This incident will be reported

can’t install Brother Printer model MFC-J450DW using the driver supplied for linux deb.
When password is input the system returns:
is not in the sudoers file. This incident will be reported.

If the system reports thiswhat should I expect to happen in this regard?

Found my own answer

copied driver pkg to every directory where required by oem and home dir

then followed the recommended commands per oem

First, login as root by runing this into your terminal:

# su

Enter your password. Then run this command:

# usermod -a -G sudo username

where username is your login name.

1 Like

I opened a terminal
I typed “su”
Then system responds:
I type in "my password for new user "
then system responds
“su: Authentication failure”

Then I try my root password and I get the same response

I had a problem with installing an odd model of printer but was able to figure it out and now my printer works just fine with most of its features as if in MS Windows 7. So I am able to get around using linux commands by persistence and trying different suggestions from others on various linux help forums and the like. But the current problem is taking rather much more work and still not getting anywhere. If you or anybody else knows what to suggest I will keep trying

Ok got it., it seems. Did all of the suggestions according to Mladen by using

usermod -a -G sudo “my log in name”

System responded with a normal prompt but no error messages or the like

So it looks like the system liked that line.

Now if only I can remember why I had to use that in the first place…

Oh yeah to install the printer. I all works now. Convoluted or what. I’ll get used to Pure OS like I got used to Ubuntu over the last 4-5 years.

1 Like