Vacationing with the Librem 5

To preface this story, on most days, I use an old Android phone as a wireless device (without a Sim card) for some functions: for my work computer’s two-factor authentication, to play white noise at night, as an alarm clock, to sync with my Fitbit device and to play a couple of games. For the past week, I left my Android device at home and just used my Librem 5 while I was on vacation.

For the most part, I didn’t miss my Android device, with a couple of exceptions:

  1. Since I was unable to sync with my Fitbit app (and I was in a different time zone), I was unable to change the time on my Fitbit device. This wasn’t too much of a hassle. I’ve lived in three different time zones in my life; I’m used to making those calculations in my head.
  2. I thought I was going to need an Uber/Lyft to take me to the airport. In the end, I was able to find a ride without it, but I thought about trying to use Waydroid or Anbox. I’ve tried these programs in the past, without any luck. Maybe I should try playing with them again.

For my white noise at night, I played some files with Amberol. I did also need to use my alarm clock once.

Of course, a major issue is still the battery life. I ended up recharging in the middle of the day or using the Belkin 10000mAh Power Bank that I bought before I left.

1 Like

From what I can tell:

  1. Don’t try Anbox.
  2. Use Waydroid but it is not something you want to be stuffing around with on holidays i.e. you would get it installed and working before you leave. As far as I know, it is not yet in the realm of just installing it from the repo, start the new application and away you go.

If the 2FA is standard then you should be able to get this for the Librem 5. That said, there are some arguments in favour of leaving 2FA on a better isolated device.

It’s quite close.

Download from here:

Extract it and install it with:
sudo apt install ./wayland-file.deb

Reboot and run waydroid, It will need to download and install the android img but once that is done, you are away.

More detailed instructions can be found here:


thank you so much for the link!
Please, I need help: how to install gapps?
I succesfully downloaded and installed waydroid and f-droid but I need also gapps. I downloaded from xda website but I can’t find how to install it here on waydroid. Please, someone could tell me how to do it?
Or do you suggest me to install only single .apk apps? (Eg. Twitter app, zoom,… included Google app as gmaps, gmail,…)
Thank you so much! :pray:

I haven’t actually done that. But as I understand you will need to uninstall waydroid and reinstall it. There are instructions on how to do that at the provided link.

When you first launch waydroid after the reboot it will want to download an app image.

Replace the text VANILLA in one of the text boxes with GAPPS and it should download an img with gapps already installed.

As I have not done this myself I can not confirm that this will work, but it shouldn’t damage anything if you try.

1 Like

I don’t have it installed atm but iirc this worked and may also do this for you:

1 Like

Help!! I did it! I substituted “VANILLA” with “GAPPS” and it worked but now I have it!
Please, is there a way to solve it?

1 Like

I decided never to use any Android or Apple apps on my Librem 5, ever. Using those apps is kind of (in my opinion) like saying to yourself “I’ll only invite a few known thieves to the party at my house, instead of leaving my home wide open to any thief who wants in”. If an app isn’t opensource, I don’t install it, end of story. If my phone can’t be a suitable daily driver for now, I’ll wait and keep trying until it can be.


I’m with you. It wouldn’t be my first choice and, like I said, I ultimately didn’t need it. If I needed it, would be nice if you could easily turn it off and on. I suppose a systelctl command would accomplish that.

What isn’t working? is it just the play store or the entire os?

Play store

I would recommend installing F-Droid and then installing Aurora Store from there to install apps, instead of using the Google Play store. The anonymous login gets rate-limited very quickly, but you can still login with your Google account to download apps in Aurora.


I didn’t know about Aurora, thank you so much!! I’m using it with success!! :pray:


Just wanted to let you know that you can use Lyft through a web browser like Firefox or Epiphany Web.

I tried making it a progressive web app through Web but it wouldn’t let me login because it needs a pop-up window or new tab.

Yes. Unfortunately, Lyft wasn’t available for the area where I was staying. The rideshare app I actually needed was called Wridz, which didn’t work with a browser.

You could ether look into using Aurora Store as some have suggested or look into device spoofing. In older versions of Android, device spoofing was easy, but now days it is somewhat more complicated. These instructions may work:

You will need to install Magisk, which you can find instructions on how to do here:

I haven’t actually done any of this on Waydroid so I can’t confirm that it works. Apparently the kernel you device is running can effect if the Magisk install works or not. If it doesn’t I wouldn’t recommend changing your kernel.


While I was waiting roughly four years for my Librem 5, I found what appears to be the best solution yet, when it comes to having both privacy and a lot of good apps on the same device. This solution appears at first to be counter-intuitive. But it appears to be working very well for me.

1.) Buy a Google Pixil phone directly from Google. If you buy it from your phone carrier, this won’t work. I bought a Pixil 6 Pro directly from Google.
2.) Install Grapheneos on to your Pixil phone. Graphineos is opensource, from the Android Open Source Project. It’s easier than you think to install this new operating system. Just follow some simple directions from the Grapheneos web site.
3.) When you boot your Pixil phone every time after that, you are completely anonymous. Don’t enter your name and don’t log in to the Google Play store. Download all of your favorite Android apps anonymously going forward from the Aurora Store. All apps so far have worked for me.
4.) This is the best part. It takes a lot of time, but I get a great deal of satisfaction from it. Disable the Google Play Store and the Google Framework. No hacking is needed. There is an on/off slider in each case. You simply turn them both off. Then go in to the permissions for each app and turn everything off that you don’t think a given app should need. Do this to every installed app, one at a time. I also turned location tracking off in every app, including in Google Maps. When I need help navigating, I turn location services on temporarily until I arrive at my destination. Then I turn it back off. All of your apps run in their own sandboxes (in complete submission to the operating system that protects your privacy and doesn’t know who you are anyway). No app has any elevated permissions. They can’t talk to eachother. They don’t even know who you are. Even with the Google Play Store and the Google Framework turned off, most apps still work after they are installed and have been tested with the Store and Framework turned on the first time. If an app doesn’t work, turn the Store and Framework on temporarily and turn them both off after you close that app. Those controls are quick and easy to access. While installing, testing, and turning off permissions, you will see that Google has been put under complete submission. Each app will beg for each permission that you disable. Get used to clicking on the “Deny” button each time you are asked. Every time you do this, the app threatens to not function properly without that permission. Don’t believe it until you see it later as you use that app. It’s usually a bluff and the app works just fine. If you really like/need that app. It’s easy to grant the needed permissions immediately before you use the app, and then revoke that permission immediately afterward.
5.) There seems to be no end to all of the ways of controlling each app’s access to anything that could invade your privacy, and in adjusting system settings to add yet more privacy. By default, most invasive things come already in the privacy protecting mode. Even the location (GPS) seems to really be fully disabled when it is turned off. The only thing I seem to lose this way is the ability to use paid apps. You have to sign in to the Google Play Store to get access to paid apps. That is something I refuse to do. To install the Aurira Store, use the web browser to install the F-Droid store first. Then install the Aurora Store from F-Droid. I downloaded most of my apps from the Aurora Store at around 4:00 AM. There are limits to how many apps you can install at busy times. You can also reboot to reset your quota limits.

1 Like

Directly giving your money to Google is exactly the most privacy-erroding consumer action you can be doing at any given point in time.


Not really! Google gets a one-time amount of roughly $1K from me. In exchange, I get both: 1.) all of the fully developed apps and also 2.) my privacy -protected by FOSS- (with maybe some intrusive firmware blobs) for the life of the phone. That’s an honest trade. The advertisers get nothing from me in that case. For the most part, it’s still FOSS that protects my privacy.

If law enforcement wants to track me, they’re going to be successful at it, no matter what phone I am on, including the Librem 5. You can’t live in lock-down mode all of the time. Although I disagree with the surveilance state in principal, from a practical perspective, I don’t care enough about law enforcement tracking me to live in lock down mode most of the time anyway. So Grapheneos solves all privacy issues for the moment. Who knows what the future will bring? If the government starts executing protesters, I’ll take my Librem 5 with me if I attend any protests.

Did you ever consider upgrading to the Librem 5 USA? That was how I expedited my order.