Viewable Applications List on Librem 15

Good evening,
I have installed a few applications on my new Librem 15. If I go into the terminal, I can run them. The issue is the application does not show in my application list.

Does anyone know why that might be the case?


Press Purism key and type the name of the application to see if it will show up.

Tried that one and it did not show up. One of the programs is Pycharm I had a similar challenge a day or two ago when I installed Spotify. That one, after a few hours, just seemed to show up.

Any insight will be awesome.


How are you installing these programs? Dpkg or with apt? Using a Deb file?

The applications you are able to see are stored in /usr/share/applications/

This is an example one that I made for Godot Game engine.

[Desktop Entry]
Name=Godot Engine
GenericName=Godot game engine
Comment=Multi-platform 2D and 3D game engine with a feature-rich editor

You will save it with .desktop extension and then you’ll be able to see it in the menu.
More info; Gnome desktop files

Usually if you install an application trough Debian/Purism repositories should appear in the menu already

Here is an example of what I put into the terminal via nano.

[Desktop Entry]
Version = 1.0
Type = Application
Terminal = false
Name = xxxxxxxxx
Exec = /usr/bin/xxxxxxxxxx
Icon = /opt/xxxxxxxx/xxxxxxxx.png
Categories = Application;

Wasn’t sure if there is a Librem-esque thing gong on preventing me from setting it up.


To make it clear, after putting in this information, it still does not show up in my menu of applications.

Well, I found some syntax errors. I was able to get the name to show, but some reason, the icon I selected will not show. Soooo…I have a current workable, but not desired total solution.

I wonder why the desktop syntax did not go to the file location and selection my icon.

If it’s a common app just write the app name as icon, the system will try to load from your selected icon theme the proper one, should be stored in /usr/share/icons/adwaita(or your actual icon theme)/…

Well, after the 30th try…lol, it worked. I re-downloaded the icon and attached the icon and it worked. Not sure what the deal was or why it would not work all the other the times.

That is now one less thing I have to fool with…lol.