VoLTE in Australia

Does anyone in Australia with a L5 currently have VoLTE switched on and working?

The three major providers are shutting down their 3G networks this year.

I have tried to use the BM818 tool to enable VoLTE, but tests indicate that during a live call it is still falling back to HDSPA+, which I think is 3G still. Does anyone have this working for Telstra? (@irvinewade - pinging you because I’ve seen from other posts that you are also based in Australia and may have set this up already).

The firmware version is below.


It is out of date, so contact Purism support (support@puri.sm); my modem firmware version below is up to date.


I think it might be necessary to reboot as well.


I’ve sent a support email I’ll update here if I get it working.

I believe I’ve reset both phone and modem multiple times after toggling the switch.

1 Like

Sorry, I have not tested Telstra now that I am using VoLTE.

The SIM in my Librem 5 is Voda. And I did specifically verify that 4G stays as 4G when making a “voice” call on the Librem 5 using Voda immediately after I enabled VoLTE. (I realise that’s not much help if you are on Telstra.)

For what it’s worth, even now on Voda I sometimes see the data connection change from 4G to 3G (and it still works, but presumably more slowly). So I don’t think Voda has fully shut down their entire 3G network and 3G support. I guess it could depend on the specific tower that you are using. 15 Dec last year (?) may have been the start date for the exercise, not the end date.


Fascinating. My firmware version is far older (2019) and, albeit I use Mint Mobile USA, VoLTE works as described by those using current firmware.

Is there a compelling reason for me to upgrade?


It depends if you like having the newest firmware for security patches, more optimized code for faster processing, etc. Take the time to weigh the benefits and consequences for yourself.

That being said, if it ain’t broke…


Only if you are experiencing problems.


So I got some support help to update my modem firmware and that process seems to have worked, but the phone still seems to be using HSDPA+ or UMTS when I press the “Check Volte” button in the bm818 tool during a live call. Often the phosh indicator still says 4G at the same time.

1 Like

Thanks for this update - did you test with the bm818 tool? because it doesnt look like the phosh indicator is always up-to-date?

I have a second pre-paid sim with amaysim (Optus) that I might test with also.

Im fairly sure that volte was working with my boost / telstra sim on the pinephone previously, so seems strange that it then would not work with this modem.

1 Like

No, m8. I just, you know, made a phone call and looked at the top line. :slight_smile:

Remember that a reboot may be needed in order to get everything to recognise that you have enabled VoLTE after doing so.

1 Like

I’ve had the same experience as you (my phone is in with repair rn so I haven’t tried it since before Christmas). Same thing, latest firmware, enabled VoLTE, confirmed with my carrier that my account had it enabled (works on an android phone) and I have never gotten it to work. Voice calls remain HSPA. Sounds like your network and Rogers here in Canada might be using the same gear perhaps. Obviously there is something in the modem firmware that isn’t negotiating the VoLTE part correctly for us for some reason. Maybe we’ll get a 5G modem soon…lol.

1 Like

Ok - so i had some time to try different sims.

I had access to 3:
Boost (Telstra)
Amaysim (Optus)
TPG (Vodafone)

The only one I could get VoLTE working with was the TPG/Vodafone one, which is unfortunate because it has by far the worst coverage. The Boost / Telstra SIM is by far the best experience - although I don’t know how much of that relates to where I was testing. Amaysim / Optus was absolutely horrible - by far the worst. The phosh modem status just looped between Amaysim and “Cellular” constantly and I was unable to make a call or use data.

1 Like

I had the same issue with modem firmware and an update has made it work on Vodafone in Australia (this thread)
I was able to get access to a Telsta sim so I tried that as well and calls do not work and bm818-tool reports it drops to UMTS while the call is active.

1 Like

I’m not sure this is something that is possible…

Reading things like this https://forums.whirlpool.net.au/archive/9m01z7np it seems that we need to install a MBN file on the modem.

Page 53 of this Quectel documentation includes a AT command to 4.4.1. AT+QMBNCFG="List" Query Imported MBN File List. They even mention Telstra :slight_smile:

That command doesn’t work on my BM818. So I’m assuming that not all Quectel modems support it.

According to this post there is a full list of AT commands available. There is no mention of MBN, Telstra or VoLTE there.

EDIT: Not all of the commands listed in https://www.waveshare.net/w/upload/6/68/SIM7500_SIM7600_Series_AT_Command_Manual_V2.00.pdf pointed to from Using AT commands and commandline to do stuff work either. So it seems that isn’t the correct list. Maybe someone from Purism has a list of AT commands?

So unless somone can figure out a way to add extra MBNs, update the firmware or replace the modem we might all need to switch to Vodafone or switch phones

1 Like

The Librem 5 doesn’t have a Quectel modem in it. (The PinePhone does however.)

Unfortunately at the more niche end of modem function, different modems use all sorts of proprietary / non-standard AT commands. On top of that, some modems will have undocumented AT commands. On top of that, the host computer may be using e.g. QMI instead of AT commands (but you can still use AT commands to do whatever AT commands can do).

I would think that the modem manufacturer (Broadmobi) needs to provide more info in order to move this forward.

1 Like

I have a few updates on getting this working.

According to 4G VoLTE calls confirmed working with carrier x the PinePhone works with Telstra and VoLTE. I did a test today and my PinePhone seemed to stay connected to the LTE network during the call (although audio didn’t work).

The post Quectel EM12-G WWAN 4G Modem on Librem 5 also did some testing on using a Quectel EM12-G in the Librem 5.

The Quectel EM12-G is similar to what is in the PinePhone (the actual PinePhone EG25 modem looks to be too large for the Librem 5). The Quectel EM12-G datasheet indicates that it is compatible with Telstra as well

So I’m hoping that something like this could be swapped out in the Librem 5 and then used to get VoLTE.

1 Like

There are some challenges with swapping the modem:

  • First and foremost, be very careful when disconnecting the antennae. Several users have managed to break the connectors in some way when doing that. Theoretically there is a correct tool for prising the connector apart but even then … be very careful.
  • Secondly, it is unknown what software and config changes would be needed in order to use a random other modem or what to do if things don’t work out-of-the-box. Sure, you may get lucky. The modem itself is cheap so you may feel like just going for it.
1 Like

Thanks for the heads up. I’ll try to be extra gentle. I’m a little surprised the connectors are so brittle. I use u.FL connectors for other things and have never had any issues.

I have swapped the WiFi cards before and I had trouble with the lengths, but hopefully the two cards are similar enough that it will work.

Yeah, the config changes are the hard part. I’m hoping it isn’t too hard as the modem should be similar to the one in the PinePhone which is generally well supported.

Considering the issues with the modem on the Librem5 (Mobile data stops working, outgoing packets still sent but incoming packets no longer arrive (#328) · Issues · Librem5 / OS-issues · GitLab) I’m also hoping this might help.

Realistically though, there isn’t much choice. We (as in Librem5 users) need to either find a VoLTE solution or we are limited to Vodafone only in Australia. Even then as more 3G networks worldwide get switched off this is only going to get worse and worse.


I was one of those that managed to pop off the u.fl on my modem when doing the procedure to replace the WiFi card. I looked at the modem afterwards and it really looked to me like a cold solder joint on the u.fl. I know they are only meant for around 10 cycles or so but not half a cycle. In hindsight maybe I should have applied the tip of my soldering iron to it before I removed the cable…lol.

1 Like