Why can't I update?

When notified there are security and app updates, I try to update but get this message:

“unable to download updates from ‘odrs.gnome.org’ failed to download https://odrs.gnome.org/1.0/reviews/api/ratings: cannt resolve hostname”

but my network connections are fine. This has been happening for weeks.

Any suggestions? Thanks, John

1 Like

Looks like something not working with DNS resolution.

Can you try dig odrs.gnome.org ?

And then dig @ odrs.gnome.org ?


Perhaps might help:

$ sudo apt update && sudo apt upgrade
$ sudo apt autoremove gnome-software && sudo apt install gnome-software

Above is in accordance with this link.

1 Like

Thanks purismforum. Both dig commands returned what seemed like normal results.
‘dig’ is new to me; what would be a sign of trouble in their output? Thanks, JAA84

1 Like

Thanks Quarnero. Is the first of your suggested commands going to upgrade my entire operating system? Not sure I’m ready for that. jaa84

1 Like

Yes, you are!

1 Like

You should be looking at the Answer section, all is ok if there is something in it.

Example :

odrs.gnome.org.         900     IN      CNAME   openshift.gnome.org.
openshift.gnome.org.    900     IN      A
openshift.gnome.org.    900     IN      A
openshift.gnome.org.    900     IN      A

If Dig works, then the DNS resolution looks to be working.

What did you get with the apt commands suggested by @quarnero?


I saw exactly the output that you just showed in ‘example’. So DNS is working.

I’m leery of the ‘apt upgrade’ command. will that take me from amber to byzantium ( or which ever way it goes?) Thanks, jaa84


No, it will not take you to Byzantium. It will upgrade Amber.

EDIT: Anyway, please wait until @purismforum or someone else confirms my suggestion (perhaps solution without searching for reason why this happened, as you described).

1 Like

Hey, might be just a temporary DNS resolution issue.

And usually yes apt update && apt upgrade should be ok.

See this from the wiki --> https://tracker.pureos.net/w/recommendations/upgrading_packages/

Unless you updated the apt source somehow. Frankly I am sad to say that I have been using Ubuntu for a while now, and that I always do apt update && apt upgrade almost daily with no issues.


Yes, this is the way to stay on the safe side, basic rule. And as it was very late for myself yesterday, let us try to help @jaa84 understand why regular (usually automated) updates are important:

  • Here is my Debian output, current one:

$ sudo apt update
Hit:1 http://security.debian.org stable/updates InRelease
Hit:2 etc.
All packages are up to date.
$ sudo apt upgrade apt

apt is already the newest version (
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Here are two step-by-step proposals (to resolve particular issue here):

  1. $ sudo apt update
    $ sudo apt upgrade gnome-software

  2. $ sudo apt update
    $ sudo apt purge gnome-software ($ sudo apt autoremove …)
    $ sudo apt install gnome-software

I tried debugging a similar issue two years ago. I finally gave up and stopped using gnome-software for the most part. It worked; I just kept getting erroneous messages.

I still get those, and similar, messages on both PureOS and Debian buster.

I hope someone can figure this out.

Thanks Quarnero. The Amber upgrade you recommended seems to have done the trick.
I didn’t need to remove and reinstall gnome-software.

By the way, I understand the importance of regular updates, and had been doing them faithfully until about a month ago, when I started getting the failed-to-download message. jaa84