Why I stopped using my Librem 5 after two weeks of hassle

Yes @irvinewade is the best!

2 Likes

A little update… I’ve started attempt #2 for using my Librem 5 as a daily driver. I’m working a new job where having a working phone isn’t as big of a deal, so I can deal with some unreliability here and there.

The cellular data issue is seemingly (I’ll have to use it for a longer period to be sure) no longer an issue when I run the command to completely turn off suspend for the modem, not just change the autosuspend timer values (1000 to 5000 didn’t work, as eventually it’d happen again). It would be ideal if they get around to fixing this issue outright, seems like it might require quite some debugging of the software stack though.

Call audio knock on wood hasn’t been an issue with the recent kernel updates I’ve applied. Only issue is with speakerphone being unreliable and not always turning on, but that’s overall minor for me.

I’ve not really checked to see if the settings changes I’ve played with in Mullvad’s app have worked, so I’ll have to get back on that later.

Cameras are still awful, but I’ve seen that Martijn Braam is working on software improvements for them, and I’ve also managed to get some okay photos by playing with the exposure setting… Still greatly looking forward to improvements on that front!

GPS is still a major pain in the butt. I tried using the AGPS python script, but it seems that I’ll still have to let the phone sit for a few minutes to get a fix, which is really crappy. It also really sucks that it still doesn’t have accelerometer and magnometer data tied in to give better accuracy. Hopefully these are on the TODO list of things.

In terms of battery life, I’ve found the setting in the mobile settings app to turn on the experimental suspend button in the power button menu. Now I can enable suspend only when I know it won’t interfere with my alarms or hotspot usage. Purism should really add a automatic toggle where when you have suspend enabled and turn on a hotspot, it temporarily disables system suspend until you’re done and give you a warning saying that it did that in the UI. I’m also eagerly looking forward to alarms being tied into the system RTC so that they can wake the phone… This is something third party apps for the PinePhone have had for years now, so it’d be really great to see this get more priority on PureOS.

And finally… The UI and stability… I installed the PostmarketOS mobile config for firefox and it made things a little more bearable, but the new tab button is still glitched out and I still cannot access the addons menu either… They just don’t respond to touch. I end up having to use the hamburger menu. In response to that issue, I started using Gnome-web more, but unfortunately while it’s not a half bad experience except for some stuttering here and there (I would really love to see some improvements in terms of GPU acceleration, so that applications don’t stutter as much when scrolling for example… Maybe Vulkan can be implemented so that GTK4 can do some nice hardware acceleration magic?), the browser crashes randomly and sometimes the keyboard input gets stuck in the URL bar, meaning you have to hit tab in order to type into web pages again, or just plug in a keyboard and mouse. Quite a pain. Gnome software and bits of the UI going off the screen are still just as much of an issue as they always have been, I just don’t really get bothered by it anymore as I’ve found workarounds like changing the screen orientation in conjunction with using scaling in the mobile settings app. That said they really need to add a theming section to that mobile settings app like the PostmarketOS one has!

7 Likes

Did you install the original mobile config? If so, you may should try out the further customized mobile config by @Emma. He fixed the addons (and the solution worked for me so far). You can find it here. And if you still have some issues, I’m sure he will try to fix it. It’s cool to have someone inside our community with so much efforts.

7 Likes

Hi guys, let me give you the most recent update problems with my L5 USA…

  1. Wfi and Cell connectivity seems to be a battle over which gets Selected to be used.
    Explanation: if both are on it takes forever to get one to be used UNLESS I shut one off… problem is the one that would work you just turned off so nothing happens… turn off that one and switch to other and then it is instantaneous.

  2. Start up… when I first got it you could press and release the power button briefly to see what the power status of battery was … forget when that disappeared due to other quirks.
    2A. Sometimes phone will start after pressing button and wait til the light changes orangish and release.
    Most times does nothing!
    Press and hold while count to 10 or 12 and release… sometimes continues and starts… not always!
    Press and hold same as above does not not start you press again and hold until you see the screen activate then you know you got it.

  3. My display scale cannot stay on 175% it either switches to 100% (too small) or 200%. It will work on all except 175%… will change it self so I use 150%. @t restart it will not stay where previously set so have to set when I turn on!

I found that Falkon works better than FireFox but one quirk… main entry you have to double type character to make words, however the home button for Falkon search and other entries are fine… best work around just load a bunch of book marks to avoid typing.

PureOs needs to put that CSS user0 made into the updates and straighten up the Start Up issues and how about the battery life?

As for Epiphany ALMOST NEVER GOES TO A WEB PAGE! Once in a while it surprises me.

If I am away from WiFi @ home I turn it off! @home … always messing with them both.
That is the biggest FAIL lately…
If you want to make a great impression FIX the TWO Main things
Phone connectivity and a good browser!

Just when I think it’s getting better something else does not work after updates. Yes I’m backed up but want forward movement not slipping backward.
Please see what you guys can do. (not a programmer just average terminal experience)

Sincerely D. Spring

5 Likes

Re your item 2A, see: Screen doesn't come on after power-on

Re your item 3, you could probably create a script to scale at 175% and have it start at power-up. See: Tutorial: Create Shortcuts to Scale Display Up/Down for some ideas, although it’s about creating an “app” to change scale on demand, not to start automatically.

2 Likes

I have not come across the bug for #3 and I use 175% scale all the time. I will say there is a bug that once you set the scale at either 175% or 150% the display settings will erroneously say it is at 100% for some reason.

2 Likes

For me it’s just 175% that jumps to 100%. But in real it’s still 175%. 150% works just fine in any way. It’s interesting that we have different behaviors.

3 Likes

Sorry, its been awhile since I used 150% regularly. You are correct @Ick it is only with 175% that the settings display the wrong scale.

3 Likes

Just do: echo 'on' | sudo tee /sys/bus/usb/devices/1-1.2/power/control

It has completely resolved the issues for me. Set it up to be set on boot and you’re golden. May affect power consumption a little bit but it hasn’t been noticeable enough for me.

EDIT: As per this thread it may be fixed in a new kernel Modem woes and reliability - #86 by lo0

2 Likes

Dont like this, too. With every decent computer the display scaling would be persistent (except you choose different). My Librem5 does not even stay with any value but 200%. I’m old but I have good glasses - why am I forced to this kindergarten-200%-view?

Because you don’t know how to set up your system correctly. :stuck_out_tongue:

In fact, it’s not your fault. Such things should be set by settings. But you can change this manually. Create a file in /etc/phosh/ called phoc.ini and enter these lines:

[output:DSI-1]
scale = 1.5

or instead 1.5 (150%) you can choose any other scale you want. After each restart it will be set to this value. And written in etc makes changes persist against updates. It overwrites the lines of /usr/share/phosh/phoc.ini, which can be updated and so they’re not persist.

8 Likes

Display scale issue resolved

Kind answer reflecting the dilemma with Librem5 … Result is:

YEAH!
This looks good and it works! Thank you!

Remark: Dir

/etc/phosh/

did not exist.
ssh, mkdir, vi, paste, reboot: Fine,
it works!

This should be part of the Manual
(better: default + GUI-stuff)

Appreciate your help!

3 Likes

I had this problem when using Mullvad VPN. I also have Protonvpn and the MMS do come through with protonvpn. so, this isn’t a generic vpn issue. It seems to vary from based on which vpn?

We are edging ever closer to AI consciousness, so the machines that exploit you may spite you and shove the knife deeper through their manipulation of those around you to make you go back.

So, good luck! The software debt runs very deep if we are going to catch up to the world of proprietary garbage, and just as soon as we do they will likewise push ahead to surpass us. But if we can be okay with that, pick specific objectives and then hack the handset until it meets those objectives, it can be a good life. Or at least it seems that way to me.

I use 2 chargers and 4 batteries for my Librem 5, and it can instant charge without turning off by plugging in the L5 power, removing the battery while it’s on, and inserting the new battery. So for me, device power and availability seem to be surpassing Android in some ways.

3 Likes